# 强制关机导致文件系统损坏，Linux弹性云服务器启动失败
#### 问题描述
强制关机后，可能会小概率遇到文件系统损坏的情况，导致再次启动弹性云服务器失败，如[图1]所示。
图1启动弹性云服务器失败   
![](https://support.huaweicloud.com/ecs_faq/zh-cn_image_0102010422.png)
#### 可能原因
从[图1]可以看出，弹性云服务器无法启动的原因是文件系统发生损坏。强制关机/强制重启属于高危操作，可能会引起文件系统内部元数据不一致，造成文件系统损坏。
#### 处理方法
通过Linux操作系统自带的磁盘修复工具（fsck）进行修复，操作如下：
以[图1]为例，磁盘问题分区为/dev/xvdb1。
1. 根据界面提示，输入Linux弹性云服务器的root账号密码。
2. 执行以下命令，查看是否已挂载磁盘问题分区。 **mount \| grep xvdb1**
   - 是，执行[3]。
   
   - 否，执行[4]。
    
3. 执行以下命令，卸载问题分区。
   **umount /dev/xvdb1**
   
4. 执行以下命令，修复问题分区的文件系统。
   **fsck -y /dev/xvdb1**
   
5. 修复完成后，执行以下命令，重启弹性云服务器。 **reboot**
   ![](https://support.huaweicloud.com/ecs_faq/public_sys-resources/note_3.0-zh-cn.png)
   如果仍未解决问题，请联系客服获取技术支持。
   
 
