# Linux云服务器变更规格时执行驱动安装脚本失败怎么办？
#### 问题描述
变更弹性云服务器规格时，如果使用自动化脚本的方式为Linux云服务器安装驱动。
如果安装过程中出现如下回显信息，说明脚本已经执行完成驱动安装步骤，但在最后检查时失败，可能原因是由于云服务器中缺少某个驱动。
```
...
Info:ECS modify success (mkinitrd)
Info:Check xen and virtio driver again!
...
Error:ECS modify error!
```
图1驱动安装成功但是检查失败   
![](https://support.huaweicloud.com/ecs_faq/zh-cn_image_0214977680.png "点击放大")
#### 解决方案
请先参考[XEN实例变更为KVM实例（Linux-手动配置）](https://support.huaweicloud.com/usermanual-ecs/ecs_03_0163.html)中"检查云服务器配置是否成功"的操作步骤检查驱动是否安装成功。
如果驱动安装失败，可能是由于自动化脚本与当前操作系统不适配，建议参考[XEN实例变更为KVM实例（Linux-手动配置）](https://support.huaweicloud.com/usermanual-ecs/ecs_03_0163.html)，手动安装Linux云服务器驱动。
部分Linux云服务器由于内核版本过低或对内核做过某些修改，导致云服务器缺少virtio_scsi驱动。缺少virtio_scsi驱动将导致云服务器无法正常挂载SCSI类型磁盘，但不影响XEN实例变更为KVM实例。如确认不使用SCSI类型磁盘，则可以在缺少virtio_scsi驱动的情况下变更规格。
