
# 创建DRS任务后执行自动功能失败
当用户创建DRS任务使用的是子账号，执行定时启动任务、全量完成自动结束、自动续传失败任务、定时对比任务等自动功能时，可能会访问全局服务或是Region级别服务，需要使用"账户委托"，否则会导致执行失败。
![](https://support.huaweicloud.com/drs_faq/public_sys-resources/note_3.0-zh-cn.png)
因为缺少委托而导致定时启动失败的任务，需要在增加委托后重建任务。
#### 解决方案
- 方法一：使用主账号重新创建一次任务，主账号默认有Security Administrator权限，可在创建任务后将委托创建出来。
- 方法二：使用主账号在子账号所在的用户组添加Security Administrator权限后，重新创建任务。添加权限的具体操作请参见：[创建用户并授权使用DRS](https://support.huaweicloud.com/usermanual-iam/iam_03_0001.html)。
- 方法三：手动添加"账户委托"，添加步骤如下：
  1. 使用主账号登录华为云界面，在右上角单击"控制台"。
  
  2. 在控制台页面，鼠标移动至右上方的账号名，在下拉列表中选择"统一身份认证"。
  
  3. 在统一身份认证页面，单击左侧导航窗格中"委托"，进入"委托"页面。
  
  4. 在"委托"页面，单击右上方的"创建委托"进行委托创建。
  
  5. 填写委托名称为"DRS_AGENTCY" ，委托类型为 "普通账号"时， 委托的账号为 "op_svc_rds"；委托类型为"云服务"时，选择"关系型数据库MySQL"；持续时间为"永久"，完成后单击"完成"。
     图1创建委托   
     ![](https://support.huaweicloud.com/drs_faq/figure/zh-cn_image_0000002147078293.png "点击放大")
     
     
     
  
  6. 在"选择策略"页面，选择DRS_AGENTCY的授权策略，委托权限需配置全局的 Tenant Administrator，完成后单击右下角的"下一步"。
     图2选择策略   
     ![](https://support.huaweicloud.com/drs_faq/figure/zh-cn_image_0000001261743503.png "点击放大") 
  
  7. 在"设置最小授权范围"页面，先选择全局服务资源授权后，再基于指定区域设置最小授权范围，完成后单击右下角的"确定"。
     图3全局服务资源授权   
     ![](https://support.huaweicloud.com/drs_faq/figure/zh-cn_image_0000001423373309.png "点击放大")
     图4指定区域项目授权   
     ![](https://support.huaweicloud.com/drs_faq/figure/zh-cn_image_0000001373573354.png "点击放大") 
  
  8. 授权完成后，单击委托名称，在"授权记录"中可看到全局服务和指定区域两条授权记录。
     图5授权记录   
     ![](https://support.huaweicloud.com/drs_faq/figure/zh-cn_image_0000001423694749.png "点击放大") 
  
  9. 权限生效时间提醒，您选中的OBS权限由于系统设计的原因，授权后需等待15-30分钟才可生效，权限生效后重新创建即可。
   
 
