
# 常见问题
- 主降备超时导致switchover超时： 主降备超时主要是因为后台线程或者关键线程的退出超时。需要查看日志定位（$GAUSSLOG/gs_log/dn_xxxx/gaussdb-\*.log）。
  
- 备升主超时导致switchover超时：
  - 观测是否有Xlog积压。
  
  - 查询日志在升主阶段是否有错误信息，判断是否是异常导致升主流程中断。
   
 
