
# 常见问题
问题：过载逃生不生效，导致数据库动态内存使用率高于逃生阈值。
解决：查看use_workload_manager、enable_memory_limit是否打开，若关闭则无法生效。
```
gaussdb=# SHOW enable_memory_limit;
 enable_memory_limit 
---------------------
 on
(1 row)
gaussdb=# SHOW use_workload_manager;
 use_workload_manager 
----------------------
 on
(1 row)
```
查看resilience_memory_reject_percent参数是否成功设置，如果设置时恢复阈值大于触发逃生的阈值，会导致参数设置失败，仍为默认值，通过系统视图pg_roles查看业务的执行用户是否具有sysadmin或monadmin权限，有这两种权限的用户默认不触发过载逃生。
```
gaussdb=# SHOW resilience_memory_reject_percent;
 resilience_memory_reject_percent 
----------------------------------
 50,90
(1 row)
gaussdb=# SELECT rolname, rolsystemadmin, rolmonitoradmin FROM pg_roles WHERE rolname = 'Mike';
            rolname            | rolsystemadmin | rolmonitoradmin 
-------------------------------+----------------+-----------------
 Mike                          | t              | t
(1 rows)
gaussdb=# SHOW resilience_escape_user_permissions;
 resilience_escape_user_permissions 
------------------------------------
(1 row)
```
问题：频繁触发过载逃生。
解决：查看resilience_memory_reject_percent设置是否过小，将过载的阈值增大。
