
# 绑定密钥对失败如何处理？
#### 问题描述
当对弹性云服务器执行绑定密钥对操作时失败。
![](https://support.huaweicloud.com/dew_faq/public_sys-resources/note_3.0-zh-cn.png)
- 管理控制台上"密钥对执行失败记录"对话框中的失败记录只记录了弹性云服务器的操作历史，不会影响弹性云服务器的状态及后续操作，可单击失败记录所在行的"删除"，直接删除失败记录，或者单击"删除所有失败记录"，删除所有执行失败的记录。
- 单击"了解更多"，查看相关文档。
 
#### KPS密钥对任务常见失败信息
| 错误大类         | 失败信息                                                                 | 错误原因                                                                                                                                                                                                                                                                                                                                                    | 解决方案                      |
|:---|:---|:---|:---|
| SSH连接失败      | Server login credential invalid. Message:\*\*\*\*\*\*                | 使用用户提供的鉴权信息SSH登录弹性云服务器失败，可能原因： 1. 用户提供了错误的鉴权信息。  2. 用户修改了弹性云服务器的SSH配置。  3. 云服务器多次鉴权失败后锁定、其它。   | 使用密码、私钥登录弹性云服务器，检查密码是否正确。 |
| SSH连接失败      | SSH connect refuse. Check your port.                                 | 使用用户提供的鉴权信息SSH登录弹性云服务器失败，可能原因：SSH服务未绑定给定端口、或SSH服务异常。                                                                                                                                                                                                                                                                                                    | SSH登录弹性云服务器，检查服务端口监听情况。   |
| SSH连接失败      | Timeout: socket is not established. Check your security group rules. | 使用用户提供的鉴权信息SSH登录弹性云服务器失败，可能原因： 1. 弹性云服务器安全组给定SSH端口入方向未对100.125.0.0/16开放。  2. 弹性云服务器配置了相应防火墙规则。                                                                          | SSH登录弹性云服务器，检查安全组、防火墙规则。  |
| 弹性云服务器状态检查失败 | The current server is executing                                      | 弹性云服务器状态检查失败，可能原因：云服务器正在创建。                                                                                                                                                                                                                                                                                                                             | 等待云服务器创建成功。               |
| 弹性云服务器状态检查失败 | Image info of Server not found                                       | 弹性云服务器状态检查失败，可能原因：使用了未注册镜像。                                                                                                                                                                                                                                                                                                                             | 使用注册镜像。                   |
| 弹性云服务器状态检查失败 | Server Operating System is not supported                             | 弹性云服务器状态检查失败，可能原因：使用了不支持的操作系统类型。                                                                                                                                                                                                                                                                                                                        | 使用KPS服务支持的操作系统类型。         |
| 弹性云服务器状态检查失败 | The server status error                                              | 弹性云服务器状态检查失败，可能原因： - 机器状态不是ACTIVE。  - 机器状态不是SHUTOFF。                                                                                                        | 在弹性云服务器控制台进行操作，使其为对应状态。   |
| 弹性云服务器状态检查失败 | The system volume is not found                                       | 弹性云服务器状态检查失败，可能原因：查询弹性云服务器所挂载的磁盘失败。                                                                                                                                                                                                                                                                                                                     | 在弹性云服务器控制台进行操作，为其挂载磁盘。    |
| 绑定密钥对失败      | Batch to bind ECS keypair exceed the max limit.                      | 批量绑定密钥对失败，可能原因：批量绑定密钥对数量超过限额。                                                                                                                                                                                                                                                                                                                           | 减少批量绑定数量。                 |
| 绑定密钥对失败      | Batch to bind ECS keypair name is inconsistency.                     | 批量绑定密钥对失败，可能原因：不同密钥对批量绑定。                                                                                                                                                                                                                                                                                                                               | 只允许相同的密钥对进行批量绑定。          |
| 绑定密钥对失败      | \* ecs flavor \* is unavailable.                                     | 绑定密钥对失败，可能原因：获取规格信息失败。                                                                                                                                                                                                                                                                                                                                  | 检查弹性云服务器规格信息。             |
| 密钥对接口参数检查    | The imported private key does not match the public key               | 密钥对检查失败，可能原因： - 当前公私钥格式有误。  - 非同一对公私钥。                                                                                                                       | 检查公私钥格式、检查公私钥是否同一对密钥对。    |
| 密钥对接口参数检查    | Invalid parameter                                                    | 密钥对接口参数检查失败，可能原因： 1. 必填参数为空。  2. 密钥对名不合法。  3. 其它参数不在规定取值范围内。                              | 检查调用参数。                   |
| 密钥对接口参数检查    | keypair type invalid                                                 | 密钥对接口参数检查失败，可能原因：密钥对type必须为ssh或x509。                                                                                                                                                                                                                                                                                                                    | 检查调用参数。                   |
   
#### 处理方法
可参照以下方法进行常规排查：
1. 查看弹性云服务器的状态。 
   - 运行中，请执行[步骤 2]。
   
   - 关机，请执行[步骤 5]。
   
   
   
   
2. 使用密码登录弹性云服务器，检查密码是否正确。
   
   - 正确，请执行[步骤 4]。
   
   - 错误，请使用正确的密码再次执行绑定密钥对操作。
   
   
   
   
3. 检查弹性云服务器的"/root/.ssh/authorized_keys"文件权限路径和属组是否被修改过。 
   - 是，请恢复至以下权限：
     - 每级属组都是root:root权限。
     
     - .ssh权限为700。
     
     - authorized_keys权限为600。
      
   
   - 否，请执行[步骤 4]。
   
   
   
   
4. 检查弹性云服务器的"/root/.ssh/authorized_keys"文件是否被修改过。
   
   - 是，请根据实际情况恢复"/root/.ssh/authorized_keys"文件的原始内容。
   
   - 否，请执行[步骤 5]。
   
   
   
   
5. 检查ECS安全组22端口入方向是否对100.125.0.0/16开放，即允许100.125.0.0/16地址通过SSH远程连接到Linux弹性云服务器。
   
   - 是，请执行[步骤 6]。
   
   - 否，请添加如下安全组规则后再次执行绑定密钥对操作。添加安全组规则具体操作请参见[添加安全组规则](https://support.huaweicloud.com/usermanual-vpc/zh-cn_topic_0030969470.html)。
     
     | 方向  | 协议/应用   | 端口 | 源地址            |
     |:---|:---|:---|:---|
     | 入方向 | SSH（22） | 22 | 100.125.0.0/16 |
        
     
   
   
   
   
6. 请检查执行密钥对绑定操作的弹性云服务器是否可以正常开机、关机和登录使用等操作。
   
   - 是，请再次执行绑定密钥对操作。
   
   - 否，请执行[步骤 7]。
   
   
   
   
7. 检查网络是否发生故障。
   
   - 是，请联系技术支持工程师查看并定位原因。
   
   - 否，请再次执行绑定密钥对操作。
   
   
   
   
 
