
# 如何处理blob.storage.directory配置/home目录时启动yarn-session失败
#### 问题
当用户设置"blob.storage.directory"为"/home"时，用户没有权限在"/home"下创建"blobStore-UUID"的文件，导致yarn-session启动失败。
#### 回答
1. 建议将"blob.storage.directory"配置选项设置成"/tmp"或者"/opt/huawei/Bigdata/tmp"。
2. 当用户将"blob.storage.directory"配置选项设置成自定义目录时，需要手动赋予用户该目录的owner权限。以下以FusionInsight的admin用户为例。 
   1. 修改Flink客户端配置文件conf/flink-conf.yaml，配置blob.storage.directory: /home/testdir/testdirdir/xxx。
   
   2. 创建目录/home/testdir（创建一层目录即可），设置该目录为admin用户所属。 ![](https://support.huaweicloud.com/devg-lts-mrs/zh-cn_image_0000001298930573.jpg "点击放大")
      ![](https://support.huaweicloud.com/devg-lts-mrs/public_sys-resources/note_3.0-zh-cn.png)
      /home/testdir/下的testdirdir/xxx目录在启动Flink集群时会在每个节点下自动创建。
      
   
   3. 进入客户端路径，执行命令**./bin/yarn-session.sh -jm 2048 -tm 3072** ，可以看到yarn-session正常启动并且成功创建目录。
      ![](https://support.huaweicloud.com/devg-lts-mrs/zh-cn_image_0000001252690942.jpg "点击放大")
      
   
   
   
   
 
