# 内存资源监控
#### 内存监控
DWS支持在监控面板(DMS)查看集群内存使用情况，详情参考[在监控面板(DMS)查看DWS集群监控](https://support.huaweicloud.com/mgtg-dws/dws_01_00014.html)章节。
DWS也提供了监控整个集群内存使用状态的视图：
查询pgxc_total_memory_detail视图，必须具有sysadmin权限。
```
SELECT * FROM pgxc_total_memory_detail;
```
如果查询该视图时出现以下错误，请开启内存管理功能（该功能由GUC参数enable_memory_limit控制，该参数默认开启。若确认参数已关闭，请联系技术支持开启）。
```
SELECT * FROM pgxc_total_memory_detail;
ERROR:  unsupported view for memory protection feature is disabled.
CONTEXT:  PL/pgSQL function pgxc_total_memory_detail() line 12 at FOR over EXECUTE statement
```
用户可通过DWS控制台修改max_process_memory参数，调整数据库节点可用的最大物理内存，方法如下：
1. 登录[DWS控制台](https://console.huaweicloud.com/dws)。
2. 在左侧导航栏中，单击**"集群 \> 集群列表"**。
3. 在集群列表中找到所需要的集群，单击集群名称，进入**"集群详情"**页面。
4. 单击"参数修改"页签，并在"参数列表"模块修改"max_process_memory"参数值，修改建议参考[max_process_memory](https://support.huaweicloud.com/devg-dws/dws_04_0893.html#ZH-CN_TOPIC_0000001811610373__sadc1e0e8c1c246a4a6cad3967deebaad)，然后单击**"** **保存"**。
5. 在**"修改预览** **"** 窗口，确认修改无误后，单击**"保存"**。
 
