
# 普通用户部署安装/卸载Docker服务报错
#### 问题现象
部署"安装/卸载Docker"步骤中的安装Docker操作时，选择普通用户的主机，日志提示信息如下：
```
fatal: [***.***.***.***: FAILED! ={"changed": false, "module_stderr": "Shared connection to ***.***.***.***closed.\r\n", "module_stdout": "sudo: 需要密码\r\n", "msg": "MODULE FAILURE\nSee stdout/stderr for the exact error", "rc": 1}
```
#### 原因分析
安装Docker必须使用root用户或者使用具有sudo权限的用户，而该用户切换sudo权限需要密码所以部署失败。
#### 处理方法
使用root用户安装Docker，或者给该用户加入免密的sudo权限。
