
# 在Oracle增量读取过程中，数据库日志失效，报错信息包含"ORA-01292: no log file has been specified for the current LogMiner session"怎么办？
#### 问题描述
在Oracle增量读取过程中，数据库日志失效， jobmanager或者task manager日志报错"ORA-01292: no log file has been specified for the current LogMiner session"。
#### 原因分析
日志文件被Oracle数据库删除了，可以和Oracle DBA 确认 startScn =\> '1963710021', endScn =\> '1963730021' 的日志时间，确认是否被清理。
#### 解决方案
- 如果确认被清理了，需要和DBA沟通修改日志的清理方式，日志至少保留3天。
- 如果日志已经保留3天，且确认日志已经被清理，可以全量加增量重新迁移该任务。
 
