
# Oracle增量读取启动时提示补充日志未开启, 报错信息包含"supplement logging not properly configured"怎么办？
#### 问题描述
Oracle为源端的实时链路在增量同步过程中报补充日志未开启，JobManager或者TaskManager日志报错"supplement logging not properly configured"。
#### 原因分析
Oracle为源端的实时链路同步数据时需要同步的表开启补充日志，开启补充日志后才能在日志中读取到完整的数据。
#### 解决方案
同步的Oracle表开启补充日志，设置方法：
```
ALTER TABLE "schema_name"."table_name" ADD SUPPLEMENTAL LOG DATA (ALL) COLUMNS;
```
设置成功后可查询到KEY ALL_COLUMN_LOGGING（该表已经开启了全量补充日志）：
```
SELECT LOG_GROUP_TYPE FROM ALL_LOG_GROUPS WHERE OWNER = 'schema_name' AND TABLE_NAME = 'table_name';  
KEY ALL_COLUMN_LOGGING
```
