
# GaussDB作为源端时，增量同步过程中报错且信息包含"no gs_hba.conf entry for replication connection from host "xxxx", user "xxx", SSL off"怎么办？
#### 问题描述
GaussDB作为源端时，增量同步过程中报错且信息包含"no gs_hba.conf entry for replication connection from host "xxxx", user "xxx", SSL off"。
#### 原因分析
没有在配置文件中添加资源组网段的白名单。
#### 解决方案
1. 确认源库的wal_level参数是否设置为logical。
   图1查看参数   
   ![](https://support.huaweicloud.com/dataartsstudio_faq/zh-cn_image_0000002397820237.png "点击放大") 
2. 配置GaussDB连接白名单。 以下配置中，user为实时同步作业使用的账号（数据连接中配置的用户名），ip为资源组网段，或者直接设置为0.0.0.0/0，避免多次配置。
   - 集中式：在源数据库的"gs_hba.conf"配置文件添加配置"host all \<user\> \<ip\> sha256"和"host replication \<user\> \<ip\> sha256"。
   
   - 分布式：在源数据库CN节点的"gs_hba.conf"配置文件添加配置"host all \<user\> \<ip\> sha256"；在源数据库DN节点的"gs_hba.conf"配置文件添加配置"host all \<user\> \<ip\> sha256"和"host replication \<user\>\<ip\> sha256"。
   
   - 在源库使用系统管理员用户执行语句"select pg_reload_conf();"生效，或重启数据库实例生效。
    
 
