
# PostgreSQL/GaussDB作为源端时，作业启动失败且报错信息包含"permission denied for function pg_ls_waldir"怎么办？
#### 问题描述
PostgreSQL/GaussDB作为源端时，实时作业启动失败且报错信息包含"permission denied for function pg_ls_waldir"。
#### 原因分析
PostgreSQL/GaussDB实时作业需要通过wal诊断函数"pg_ls_waldir"查看日志LSN（日志序列号，用于记录日志位置）和时间戳的对应关系，该函数查询需要有monitor的权限。
该函数主要用于指定启动位点和查询复制槽推进位点的时候找到对应的日志文件。
#### 解决方案
对实时同步作业使用的账号（数据连接中配置的用户名）提权。
授权的具体操作请参见[如何增加PostgreSQL、Gaussdb数据源额外权限？](https://support.huaweicloud.com/dataartsstudio_faq/dataartsstudio_03_7600.html)。
