
# PostgreSQL/GaussDB作为源端时，实时作业启动失败且报错信息包含"all replication slots are in use"怎么办？
#### 问题描述
PostgreSQL/GaussDB作为源端时，实时作业启动失败且报错信息包含"all replication slots are in use"。
#### 原因分析
复制槽数量达到上限。
#### 解决方案
- 提高复制槽数量上限。
  在PostgreSQL/GaussDB的参数管理中修改参数max_replication_slots，建议将此参数大小设置为不小于PostgreSQL/GaussDB为源端的实时任务数量，参数修改后需要重启才能生效。
  图1配置参数   
  ![](https://support.huaweicloud.com/dataartsstudio_faq/zh-cn_image_0000002363662496.png "点击放大") 
- 删除弃用的复制槽。删除复制槽 手动删除复制槽请参见[PostgreSQL数据源如何手动删除复制槽？](https://support.huaweicloud.com/dataartsstudio_faq/dataartsstudio_03_7586.html)。
  
 
