
# sonarqube引擎的check阶段失败日志里elasticSearch启动报错
#### 问题现象
elasticSearch启动报错"max file descriptors \[4096\] for elasticsearch process is too low, increase to at least \[65535\]"。
#### 原因分析
单个进程可以同时打开的文件数太少。
#### 处理方法
1. 以root用户登录执行代码检查任务的执行机。
2. 执行以下命令，查看当前可打开的文件数。 
   ```
   ulimit -Hn
   ulimit -Sn
   ```
   
   
3. 执行"vim /etc/security/limits.conf"命令，打开文件。
4. 增加以下配置命令，用户退出后重新登录生效。 
   ```
   * soft nofile 65536
   * hard nofile 65536
   ```
   命令前需要注意带"\*"号。
   
   
5. 按"Esc"键返回普通模式。
6. 输入":wq"保存并退出。
7. 执行以下命令，查看当前可打开的文件数是否已修改为65536。 
   ```
   ulimit -Hn
   ulimit -Sn
   ```
   
   
 
