
# 为什么已备份的Hive表无法执行drop操作
#### 问题
为什么已备份的Hive表执行drop操作会失败？
#### 回答
由于已备份Hive表对应的HDFS目录创建了快照，导致HDFS目录无法删除，造成Hive表删除失败。
Hive表在执行备份操作时，会创建表对应的HDFS数据目录快照。而HDFS的快照机制有一个约束：如果一个HDFS目录已创建快照，则在快照完全删除之前，该目录无法删除或修改名称。Hive表（除EXTERNAL表外）执行drop操作时，会尝试删除该表对应的HDFS数据目录，如果目录删除失败，系统会提示表删除失败。
如果确实需要删除该表，可手动删除涉及到该表的所有备份任务。
