
# 调整DataNode磁盘坏卷信息
#### 操作场景
在开源版本中，如果为DataNode配置多个数据存放卷，默认情况下其中一个卷损坏，则DataNode将不再提供服务。
用户可以通过MRS修改配置项"dfs.datanode.failed.volumes.tolerated"的值，指定失败的个数，小于该个数，DataNode可以继续提供服务。
#### 操作步骤
1. 登录FusionInsight Manager。 
   登录集群Manager具体操作，请参考[访问MRS集群Manager](https://support.huaweicloud.com/usermanual-mrs/mrs_01_0128.html)。
   
   
2. 选择"集群 \> 服务 \> HDFS \> 配置 \> 全部配置"。
3. 搜索以下参数，并根据实际需要修改。 
   表1参数说明 
   | **参数**                                | **描述**                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    | **取值样例** |
   |:---|:---|:---|
   | dfs.datanode.failed.volumes.tolerated | DataNode停止提供服务前允许失败的卷数。 默认情况下，必须至少有一个有效卷。 取值范围：-1\~*DataNode上配置的磁盘卷数* - -1：表示有效卷的最小值是1。  - 大于等于0：表示允许失败的卷数。   | -1       |
      
   
   
4. 保存修改的配置。保存完成后请重新启动配置过期的服务或实例以使配置生效。
 
#### 相关文档
[dfs.datanode.data.dir中定义的磁盘数量等于dfs.datanode.failed.volumes.tolerated的值时，DataNode启动失败](https://support.huaweicloud.com/trouble-mrs/mrs_01_1696.html)
