# 节点池异常状态排查
#### 排查思路
请根据具体节点池异常状态确定具体问题原因，如[表1]所示。
 表1节点池异常 
| 节点池异常状态                                                                        | 说明                                                                                                               | 解决方案                                                                                                                                                                                                                                                                                                                                                                                                                                                                           |
|:---|:---|:---|
| 错误 Error                                        | 节点池删除失败                                                                                                           | 重试删除节点池操作，如果节点池仍旧无法删除，请提交工单帮助删除错误节点池。                                                                                                                                                                                                                                                                                                                                                                                                                                          |
| 配额不足 QuotaInsufficient                      | 用户配额不足导致节点池无法扩容                                                                                                   | 请提交工单申请扩大账号配额。                                                                                                                                                                                                                                                                                                                                                                                                                                                                 |
| 资源不足 SoldOut                                | 底层资源不足                                                                                                           | 更新节点池配置，选择其他可用资源。                                                                                                                                                                                                                                                                                                                                                                                                                                                                |
| 配置异常 ConfigurationInvalid                      | 云服务器组不存在（ServerGroupNotExists）： 节点池绑定的云服务器组不存在，可能由于用户手动删除了云服务器组导致。                | 1. 请登录CCE控制台，在左侧导航栏中单击"节点管理"，并单击节点池名称，在"总览"页签中单击"展开高级配置"，查看所属云服务器组。  2. 登录ECS控制台，在左侧导航栏中单击"弹性云服务器 \> 云服务器组"，确认云服务器组是否存在。  3. 如果云服务器组已经不存在，请登录CCE控制台，在左侧导航栏中单击"节点管理"，找到目标节点池单击"更新"，在"高级配置"中解绑云服务器组或者切换云服务器组。                                                             |
| 配置异常 ConfigurationInvalid                      | 私有镜像配置异常（InvalidPrivateImage）： 节点池私有镜像要求的MinDisk配置大于节点池系统盘容量，该配置会导致节点池扩容失败。  | 请登录CCE控制台，在左侧导航栏中单击"节点管理"，找到目标节点池单击"更新"，在"存储配置"中修改系统盘的容量。                                                                                                                                                                                                                                                                                                                                                                                                                       |
| 配置异常 ConfigurationInvalid                      | 节点池 OS 配置错误（OSNotSupportedByClusterVersion）： 节点池配置的操作系统版本已停止维护（EOS），请及时升级节点池操作系统。 | 请登录CCE控制台，在左侧导航栏中单击"节点管理"，找到目标节点池单击"更新"，在"操作系统"中选择可用的OS。                                                                                                                                                                                                                                                                                                                                                                                                                        |
| 云服务器组配额不足InstanceAboveServerGroup                                            | 云服务器超过云服务器组上限                                                                                                  | 1. 请登录CCE控制台，在左侧导航栏中单击"节点管理"，并单击节点池名称，在"总览"页签中单击"展开高级配置"，查看所属云服务器组。  2. 登录ECS控制台，在左侧导航栏中单击"弹性云服务器 \> 云服务器组"，检查云服务器组配额。  3. 如果云服务器组配额不足，请登录CCE控制台，在左侧导航栏中单击"节点管理"，找到目标节点池单击"更新"，在"高级配置"中解绑云服务器组或者切换云服务器组。                                                                  |
| 容量预留不足 InvalidCapacityReservation           | 容量预留错误                                                                                                         | 更新节点池，选择其他容量预留规格。                                                                                                                                                                                                                                                                                                                                                                                                                                                              |
| 节点池/伸缩组的期望节点数已达到弹性扩容最大值 MaxNodeCountReached | 当前节点池或者伸缩组内期望节点数已达到当前弹性扩容最大值。                                                                                   | - 节点池/伸缩组内期望节点数达到当前规格弹性扩容最大值时，节点池或者伸缩组无法触发弹性扩容，节点池手动扩容则不受影响，您可以通过手动扩容添加解决。  - 如需解决该异常，请在"节点管理\>节点池"页面中单击节点池的"弹性伸缩"按钮，并修改"节点数范围"。 如果关闭节点池或者伸缩组的"弹性伸缩"开关，也可以解决该异常。                                                                                                                                |
| 部分节点状态异常 HasAbnormalNode                     | 当前节点池或者伸缩组中存在部分节点状态异常。                                                                                            | - 节点状态不可用时，请参考[集群可用但节点状态为"不可用"如何解决？](https://support.huaweicloud.com/cce_faq/cce_faq_00120.html)。  - 节点状态错误时，说明节点出现了删除失败的情况，请重试删除该节点。                                                                                                                                                                                                       |
| 权限不足                                                                        | 云服务委托权限不足或者SCP限制，节点池无法扩容                                                                                      | 请登录CCE控制台，在左侧导航栏中单击"节点管理"，并单击节点池名称后的![](https://support.huaweicloud.com/cce_faq/zh-cn_image_0000002525467660.png)图标，展开tips详情，查看原因。 - **缺少权限**：请登录IAM控制台，在左侧导航栏中单击"委托"，找到cce_admin_trust或者CCEServiceAgency委托，添加缺少的权限。  - **SCP限制**：请登录IAM控制台，在左侧导航栏中单击"委托"，找到cce_admin_trust或者CCEServiceAgency委托，删除相关的SCP策略。   |
   
