# 集群安装nginx-ingress插件失败，一直处于创建中？
#### 问题背景
客户已经购买并搭建了CCE集群，希望在公网上可以访问到CCE上部署的应用服务，目前最高效的方式是在ingress资源上注册该应用的Service路径，从而满足要求。
但客户安装ingress插件后，插件状态一直显示"创建中"，nginx-ingress-controller的pod一直处于pending状态。
#### 解决方案
nginx限制的内存资源不足导致无法启动，取消限制后正常。
#### 场景模拟
1. 新集群3个节点，规格 6cpu，12G内存，每个节点2U4G。
2. 单击nginx-ingress插件安装，选择规格2核2G。
3. nginx-ingress deployment安装成功，但是nginx-ingress-controller安装失败。 
   图1一直处于创建中   
   ![](https://support.huaweicloud.com/cce_faq/zh-cn_image_0226126410.png)
   图2安装失败   
   ![](https://support.huaweicloud.com/cce_faq/zh-cn_image_0226126411.png "点击放大")
   
   
4. 错误显示资源不足。 
   ![](https://support.huaweicloud.com/cce_faq/zh-cn_image_0226126992.png)
   
   
5. 添加节点资源为4U8G后，nginx-ingress安装正常。
 
#### 问题原因
最初建立的集群中各节点的基本配置为2U4G，且各节点上有kubelet，kube-proxy及docker等相关程序占用系统资源，导致节点可用资源低于2000m，无法满足nginx-ingress插件的要求，从而无法安装。
#### 建议方案
请重新购买节点，节点要求（\>=4U8G）。
