更新时间:2021-12-29 GMT+08:00
分享

升级前准备

升级前检查

升级操作前,请按照表1中序号顺序进行检查,并记录检查结果。

表1 升级前检查表

序号

项目

检查标准

1

检查软件版本

  1. 查询并记录当前系统中Atlas 800 训练服务器(型号9000)版本。
  2. 确认需要升级的版本。

2

检查系统状态

检查Atlas 800 训练服务器(型号9000)告警:

  • 未出现告警,可直接升级。
  • 出现告警时,请与华为技术支持确认告警情况,然后再决定下一步动作。

不同芯片的软件版本支持情况如表2所示。

表2 软件版本配套表

芯片名称

适配版本

Ascend 910 A

20.0.0、20.1.0、20.2.0

Ascend 910 B

20.0.0、20.1.0、20.2.0

Ascend 910 Pro A

20.0.0、20.1.0、20.2.0

Ascend 910 Pro B

20.2.0.SPC300

Ascend 910 Premium A

20.2.0.SPC300

获取升级包

请通过下述方法获取升级包。

1. 登录A800-9000

2. 打开目标版本“A800-9000 X.X.X”。

固件、驱动与CANN的配套关系,请查看CANN软件版本的《CANN 版本配套表》。

在指定版本页面下载对应升级包到客户端(本地PC)。获取的升级包如表3所示。

  • 下文中所有x.x.x代表软件版本号。
  • A800-9000-npu-driver_x.x.x_linux-aarch64.run适配所有操作系统。
表3 升级包信息

硬件形态

host操作系统版本

host操作系统内核版本

驱动包名称

固件包名称

aarch_64+Atlas 800 训练服务器(型号9000)

EulerOS 2.8

4.19.36-vhulk1907.1.0.h475

A800-9000-npu-driver_x.x.x_euleros2.8-aarch64.run

A800-9000-npu-firmware_x.x.x.run

CentOS7.6

4.14.0-115.el7a.0.1.aarch64

A800-9000-npu-driver_x.x.x_centos7.6-aarch64-.run

Ubuntu18.04

4.15.0-45-generic

说明:

若内核版本和操作系统版本匹配失败,需先安装dkms,安装方法请参见驱动源码编译

A800-9000-npu-driver_x.x.x_ubuntu18.04-aarch64.run

CentOS8.2

4.18.X

说明:

支持升级到5.6.14。

A800-9000-npu-driver_x.x.x_linux-aarch64.run

BC_Linux 7.6

4.19

A800-9000-npu-driver_x.x.x_centos7.6-aarch64-.run

A800-9000-npu-driver_x.x.x_linux-aarch64.run

kylinosv10SP1

说明:

kylinosv10SP1在21.0.rc1及以上版本才支持。

4.19.90-17.ky10.aarch64

A800-9000-npu-driver_x.x.x_linux-aarch64.run

BC_Linux 7.7

说明:

BC_Linux 7.7在21.0.rc1及以上版本才支持。

4.19.25-203.e17.bclinux.aarch64

A800-9000-npu-driver_x.x.x_linux-aarch64.run

检查软件包完整性

为了防止软件包在传递过程或存储期间被恶意篡改,下载软件包时需下载对应的数字签名文件用于完整性验证。

在软件包下载之后,请参考《OpenPGP签名验证指南》,对从Support网站下载的软件包进行PGP数字签名校验。如果校验失败,请不要使用该软件包,先联系华为技术支持工程师解决。

使用软件包安装/升级之前,也需要按上述过程先验证软件包的数字签名,确保软件包未被篡改。

运营商客户请访问:http://support.huawei.com/carrier/digitalSignatureAction

企业客户请访问:https://support.huawei.com/enterprise/zh/tool/pgp-verify-TL1000000054

分享:

    相关文档

    相关产品

close