更新时间:2021-12-29 GMT+08:00
分享

系统要求和环境检查

软件包要求的操作系统和内核,如表1表2所示。

表1 二进制驱动包默认操作系统版本信息

硬件形态

host操作系统版本

软件包默认的host操作系统内核版本

GCC编译器版本

aarch64+Atlas 800 9000

Ubuntu 18.04

4.15.0-45-generic

说明:

若内核版本和操作系统版本匹配失败,需先安装dkms,安装方法请参见驱动源码编译

7.4.0

aarch64+Atlas 800 9000

EulerOS 2.8

4.19.36-vhulk1907.1.0.h475

7.3.0

aarch64+Atlas 800 9000

CentOS 7.6

4.14.0-115.el7a.0.1.aarch64

-

aarch64+Atlas 800 9000

BC_Linux 7.6

4.19

-

表2 通用驱动包兼容操作系统版本信息

硬件形态

host操作系统版本

软件包默认的host操作系统内核版本

GCC编译器版本

aarch64+Atlas 800 9000

CentOS 8.2

4.18.X

说明:

支持升级到5.6.14。

8.3.1

aarch64+Atlas 800 9000

BC_Linux 7.6

4.19

-

aarch64+Atlas 800 9000

kylinosv10SP1

说明:

kylinosv10SP1在21.0.rc1及以上版本才支持。

4.19.90-17.ky10.aarch64

8.3.1-4.5

aarch64+Atlas 800 9000

BC_Linux 7.7

说明:

BC_Linux 7.7在21.0.rc1及以上版本才支持。

4.19.25-203.e17.bclinux.aarch64

4.8.5

  1. 验证Linux操作系统版本信息

执行uname -m && cat /etc/*release命令,查询正在运行的操作系统版本和操作系统架构。

系统正在运行的操作系统版本和操作系统架构必须与表1表2中要求一致。

  1. 通用驱动包特有检查项
  • 确认make工具是否已安装;执行make -v命令,若能查询到make工具的版本,则make已安装。
  • 以下2个检查项满足其中任意一个,驱动就可以安装成功。
    • 确认系统已安装dkms等安装依赖;具体请参见驱动源码编译
    • 确认默认内核源码路径“/lib/modules/`uname -r`/build”是否存在;执行ls /lib/modules/`uname -r`/build命令,查看路径是否存在。
      • 若存在,则会自动使用内核进行驱动编译。
      • 若不存在,您可以在安装时提供对应的源码路径,具体请参见5
  1. 验证Linux操作系统内核版本

执行uname -r命令,查询当前host操作系统的内核版本。

  • 若使用二进制驱动包安装,当前host操作系统的内核版本必须与表1中要求一致。若不一致,有两种解决方法:
  • 若使用通用驱动包安装,当前host操作系统的内核版本与表2中要求一致,若不一致,可能导致驱动包安装不成功或者影响功能使用。
  1. 检查运行环境是否安装过软件包

如需要升级系统内核版本,在升级之前,请确保当前系统上未安装软件包。否则会出现内核升级后软件包启动异常的问题。出现该问题时请参见升级系统内核版本时未卸载软件包导致软件包不可用解决。请使用lsmod|grep drv命令查询是否安装过软件包。

  • 如无内容表示未安装过软件包,可以直接升级系统内核版本。
  • 如有内容,表示安装过软件包,需要先卸载软件包后,升级系统内核版本。卸载请参见卸载驱动和固件
分享:

    相关文档

    相关产品

close