
# 创建服务网关时，提示500错误
#### 问题描述
一键创建体验应用Bookinfo时，提示"创建对外访问方式失败"。
#### 排查思路
登录ASM控制台，按"F12"，切换到Network页签查看接口。发现post请求创建gateway接口全部返回500，查看返回内容提示如下信息：
```
IP is not the same with LoadBalancerIP
```
#### 原因分析
istio-system命名空间下有gatewayservice残留。残留原因是一键删除模板实例前没有删除已添加的对外访问配置。
#### 解决方法
istio-system命名空间下残留gatewayservice，需要删除该service。
**kubectl delete svc** *\<svc-name\>* **-n namespace**
其中，*\<svc-name\>*为service的名称。
