
# 添加的对外访问方式不能生效，如何排查？
出现上述问题可能是访问相关的资源配置有缺失或错误，请按照如下方法进行排查：
- 通过弹性负载均衡服务界面查看使用的ELB是否成功监听使用的外部端口和弹性云服务器。
- 登录集群，使用**kubectl get gateway -n istio-system** 命令查看使用的gateway是否配置好使用的IP/域名和端口。使用**kubectl get svc -n istio-system**命令查看使用的ingressgateway是否有对应的IP和端口，且未处于pending状态。
- 核实加入服务网格的内部访问协议和添加网络配置的外部访问协议一致。
- 如果通过浏览器访问出现"ERR_UNSAFE_PORT"错误，是因为该端口被浏览器识别为危险端口，此时应更换为其他外部端口。
 
