
# 伸缩组启用失败如何处理？
伸缩组启用失败处理方法：
- 情况描述：云服务器配额不足、云硬盘配额不足、弹性公网IP配额不足等。 可能原因：配额不足。
  处理方法：申请扩大配额或者删除不需要的资源，之后重新启用伸缩组。
  
- 情况描述：伸缩组使用的VPC不存在、子网不存在等。 可能原因：虚拟私有云服务异常或者相关资源被删除。
  处理方法：等待虚拟私有云服务恢复或者修改伸缩组中VPC、子网相关参数，之后重新启用伸缩组。
  
- 情况描述：负载均衡监听器不存在、后端云服务器组不存在、负载均衡器不可用等。 可能原因：负载均衡服务异常或者相关资源被删除。
  处理方法：等待负载均衡服务恢复或者修改伸缩组中负载均衡相关参数，之后重新启用伸缩组。
  
- 情况描述：您添加到负载均衡监听器的后端云服务器超过最大限制。 可能原因：伸缩组使用经典型负载均衡，会自动地将加入伸缩组的实例添加到负载均衡监听器。一个监听器最多可添加300个后端云服务器。
  处理方法：您可以从监听器上移除不需要的且不在该伸缩组中的后端云服务器，之后重新启用伸缩组。
  
- 情况描述：伸缩配置使用的镜像不存在、规格不存在、密钥对不存在等。 可能原因：相关资源被删除。
  处理方法：为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：生命周期挂钩使用的通知主题不存在。 可能原因：伸缩组添加了生命周期挂钩，且伸缩活动开始前生命周期挂钩使用的通知主题被删除。如果伸缩活动开始后通知主题被删除，则下次伸缩活动时伸缩组会异常。
  处理方法：修改生命周期挂钩使用的通知主题或者删除生命周期挂钩，之后重新启用伸缩组。
  
- 情况描述：您选择的子网下私有IP不足。 可能原因：伸缩组使用的子网下私有IP地址被用尽。
  处理方法：修改伸缩组中的子网信息，之后重新启用伸缩组。
  
- 情况描述：您选择的可用区下的该类型云服务器资源已售罄。 可能原因：您为伸缩组选择的可用区下该类型云服务器资源售罄，或者该可用区不支持该类型云服务器资源。该类型云服务器指的是伸缩配置里选择的云服务器规格。
  处理方法：您可以为伸缩组更换新的伸缩配置，之后重新启用伸缩组。当您的伸缩组中没有实例时，还可以修改伸缩组的可用区信息，之后重新启用伸缩组。
  
- 情况描述：您选择的规格和磁盘不匹配。 可能原因：伸缩配置中的云服务器类型和磁盘类型不匹配导致创建云服务器失败。
  处理方法：为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：您选择的规格和镜像不匹配。 可能原因：伸缩配置中的云服务器类型和镜像不匹配导致创建云服务器失败。
  处理方法：为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：您选择的可用区下的该类型存储资源已售罄。 可能原因：您为伸缩组选择的可用区下该类型存储资源售罄，或者该可用区不支持该类型存储资源。该类型存储资源指的是伸缩配置里选择的磁盘（包括系统盘和数据盘）类型。
  处理方法：您可以为伸缩组更换新的伸缩配置，之后重新启用伸缩组。当您的伸缩组中没有实例时，还可以修改伸缩组的可用区信息，之后重新启用伸缩组。
  
- 情况描述：您选择的伸缩配置中定义的共享带宽不存在。 可能原因：相关资源被删除。
  处理方法：您可以使用新购买的共享带宽或者其他存在的共享带宽资源重新创建伸缩配置，为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：伸缩配置中定义的共享带宽绑定的EIP个数超过最大限制。 可能原因：单个共享带宽最多可以添加20个公网IP。
  处理方法：您可以申请扩大配额或者从共享带宽上移出不需要的公网IP，或者为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：您的伸缩配置中选择的专属主机不存在，请更换伸缩配置。 可能原因：相关资源被删除。
  处理方法：您可以使用新购买的专属主机或者其他存在的专属主机资源重新创建伸缩配置，为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：无可用的专属主机资源，请确保当前有可用的专属主机资源。 处理方法：您可以排除专属主机的故障使其恢复可用状态或者开启专属主机自动放置属性，之后重新启用伸缩组。还可以使用新购买的专属主机资源重新创建伸缩配置，为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：您的伸缩配置中选择的专属主机可用容量不足。 处理方法：您可以删除专属主机上不需要的云服务器资源之后重新启用伸缩组，或者使用新购买的专属主机资源重新创建伸缩配置，为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：您的伸缩组中选择的可用区下无可用的专属主机资源。 处理方法：您可以在该可用区下购买新的专属主机资源，重新创建伸缩配置，为伸缩组更换新的伸缩配置，之后重新启用伸缩组。当您的伸缩组中没有实例时，还可以修改伸缩组的可用区信息，之后重新启用伸缩组。
  
- 情况描述：您的伸缩配置中选择的专属主机不支持该类型云服务器，请更换伸缩配置。 处理方法：您可以选择专属主机支持的规格重新创建伸缩配置，为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：系统异常。 可能原因：弹性伸缩或者周边服务异常、网络异常等。
  处理方法：请稍后重试，或联系技术支持。
  
- 情况描述：您选择的伸缩配置中定义的规格不可用。 处理方法：您可以通过错误提示信息重新创建伸缩配置更换新的规格，并为伸缩组更换新的伸缩配置，之后重新启用伸缩组
  
- 情况描述：您选择的伸缩配置无法被当前伸缩组使用。 处理方法：您可以通过错误提示信息重新创建伸缩配置，并为伸缩组更换新的伸缩配置，之后重新启用伸缩组。
  
- 情况描述：您的账户已欠费或余额不足。 可能原因：账户欠费或余额不足时，伸缩组无法进行扩容。
  处理方法：您可以在充值之后重新启用伸缩组。
  
