
# 支持Cloud-Init特性后，对使用弹性伸缩有哪些影响？
Cloud-init是开源的云初始化程序，能够对新创建弹性云服务器中指定的自定义信息（主机名、密钥和用户数据等）进行初始化配置。在创建伸缩配置时，通过Cloud-Init进行对云服务器的初始化配置。
弹性伸缩组使用的伸缩配置中的私有镜像若没有安装Cloud-Init/Cloudbase-init工具，伸缩活动创建的弹性云服务器会出现如下情况：
- 如使用未安装Cloudbase-init的Windows私有镜像创建的弹性云服务器，在获取弹性云服务器密码时，系统将提示查询不到密码。您只能通过镜像本身的密码登录此云服务器。若忘记镜像本身密码，可以通过云服务器页面"重置密码"功能，自助完成云服务器的密码重置。
- 如使用未安装Cloud-Init的Linux私有镜像创建的云服务器，使用创建时输入的密码或密钥将无法正常登录云服务器。您只能通过镜像本身的密码或密钥登录此云服务器。若忘记镜像本身密码，或镜像本身的密钥丢失，可以通过云服务器页面"重置密码"功能，自助完成云服务器的密码重置。
- 如使用未安装Cloud-Init/Cloudbase-init的私有镜像创建云服务器时，实例自定义数据注入会失败。
  鉴于出现上述情况，在使用弹性伸缩时，请检查伸缩配置中的私有镜像是否已经安装并配置了Cloud-Init或者Cloudbase-init工具，请将使用了未安装Cloud-Init/Cloudbase-init的私有镜像的伸缩配置删除，并使用已安装Cloud-Init/Cloudbase-init的私有镜像创建新的伸缩配置。具体操作步骤：
  1. 登录[AS控制台](https://console.huaweicloud.com/ecm/?#/as/manager/groupConfigInfo/groupList)。
  
  2. 选择"伸缩配置"页签，进入伸缩配置列表页面。
  
  3. 单击"创建伸缩配置"，选择已安装Cloud-Init或Cloudbase-init工具的私有镜像创建新的伸缩配置。
  
  4. 在伸缩组中将伸缩配置修改为新创建的伸缩配置。
    
 
