
# CCE接入常见问题与解决方法汇总
#### 通过CCE安装探针失败，没有打印日志
问题原因：通过CCE安装探针失败，没有打印日志的原因可能是JAVA_TOOL_OPTIONS没有生效。用户是通过sudo启动的服务，sudo启动的脚本会忽略所有环境变量。
解决方案：使用如下命令进入文件中，将Defaults env_reset改成Defaults !env_reset。
```
/etc/sudoers
```
#### 从CCE启动正常，但稍后离线且无任何数据报送
问题原因：用户在启动脚本设置用户启动（adt），但从CCE启动时，使用root用户执行启动脚本，在脚本里面切换到adt用户，会发生"从CCE启动正常，但稍后离线且无任何数据报送"的情况。
- apm.log.0打印在root用户的根目录下。
- JavaAgent自动离线，无心跳，无日志。
- 离线时如果用户删除对应实例，会存在没有任务应用接入的假象。
解决方案：
- 暂时解决方法：用户在容器内先切到与脚本匹配的用户如：adt下，再执行启动脚本，即可正常启动并报送数据。
- 最终解决方法：修改adt用户/home写日志权限，或是手动修改apm.config中log.path=指定路径。
 
#### CCE通过Fuxi接入APM没有数据
先找apm.log，如果连日志文件都没有，说明在启动时没有加接探针的命令：
查看fuxi主干配置：
```
"JAVA_TOOL_OPTIONS": "-javaagent:/paas-apm2/javaagent/apm-javaagent/apm-javaagent.jar"
```
查看CCE中的容器1是否有JAVA_TOOL_OPTIONS这个环境变量
查看CCE中是否存在容器2，查看实例启动事件，是否有加载javaagent的swr镜像。
#### 通过CCE接入失败，日志显示master地址为null
在CCE界面接入时，选择noroot版本的探针。详细操作参见[CCE容器接入JavaAgent](https://support.huaweicloud.com/usermanual-apm2/apm_08_0052.html)。
#### CCE方式接入APM报错master address illegal
![](https://support.huaweicloud.com/apm2_faq/zh-cn_image_0000002510689136.png "点击放大")
解决方案：此原因是容器做了安全加固所致，切换noroot版本的agent即可。
