
# 错误码
调用API出错后，将不会返回结果数据。调用方可根据每个API对应的错误码来定位错误原因。当调用出错时，HTTP请求返回一个4xx或5xx的状态码。返回的消息体中是具体的错误代码及错误信息。在调用方找不到错误原因时，可以联系客服，并提供错误码，以便尽快帮您解决问题。
- 异常响应示例
  ```
  {
      "error_code": "VIAS.00010006",
      "error_msg": "An internal error occurs.",
      "detail": "Request method 'GET' not supported",
      "params": [],
      "reason": "An internal error occurs.",
      "advice": "An internal error occurs."
  }
  ```
  
- 参数说明
  
  | 参数名称       | 描述信息  |
  |:---|:---|
  | error_code | 错误码。  |
  | error_msg  | 错误信息。 |
  | detail     | 错误详情。 |
  | params     | 涉及参数。 |
  | reason     | 原因。   |
  | advice     | 处理建议。 |
     
  
- 错误码说明
  
  | 状态码 | 错误码           | 错误信息                                                                            | 描述                                                | 处理措施                  |
  |:---|:---|:---|:---|:---|
  | 400 | VIAS.00010001 | The parameters are invalid.                                                     | 参数非法。                                             | 请确保输入的参数合法。           |
  | 400 | VIAS.00010002 | The object does not exist.                                                      | 指定对象不存在。                                          | 检查配置。                 |
  | 400 | VIAS.00010003 | The object already exists.                                                      | 对象已存在。                                            | 使用或创建另一个对象。           |
  | 400 | VIAS.00010004 | The object or parameter is invalid.                                             | 对象或参数无效。                                          | 确认对象或参数的格式。           |
  | 401 | VIAS.00010005 | Authorization failed.                                                           | 鉴权失败。                                             | 检查用户权限。               |
  | 500 | VIAS.00010006 | An internal error occurs.                                                       | 内部错误。                                             | 内部错误，结合日志定位。          |
  | 400 | VIAS.00010007 | No task is found based on the task ID.                                          | 根据任务ID找不到相应的任务。                                   | 请检查您的任务ID。            |
  | 400 | VIAS.00010008 | No task is found based on the ID.                                               | 根据ID找不到相应的任务。                                     | 请检查您的ID。              |
  | 500 | VIAS.00010009 | The serviced failed to be accessed. (Internal error)                            | 访问服务失败。                                           | 内部错误，结合日志定位。          |
  | 400 | VIAS.00010010 | There is a video source with the same name.                                     | 已有同名视频源。                                          | 修改视频源名称。              |
  | 400 | VIAS.00010011 | There is a job with the same name.                                              | 已有同名作业。                                           | 修改作业名称。               |
  | 500 | VIAS.00010012 | This operation is not allowed. (Internal error)                                 | 此操作不允许。                                           | 内部错误，结合日志定位。          |
  | 500 | VIAS.00010013 | Requests are sent too frequently.                                               | 请求过于频繁。                                           | 请稍后重试。                |
  | 500 | VIAS.00010014 | This operation is forbidden. (Internal error)                                   | 禁止该操作。                                            | 内部错误，结合日志定位。          |
  | 500 | VIAS.00010015 | The resource is not found. (Internal error)                                     | 资源未找到。                                            | 内部错误，结合日志定位。          |
  | 500 | VIAS.00010016 | Dependent services are unavailable. (Internal error)                            | 依赖服务不可用。                                          | 内部错误，检查依赖服务的状态。       |
  | 400 | VIAS.00010017 | The resource code is duplicate. (Internal error)                                | 资源编码重复。                                           | 内部错误，结合日志定位。          |
  | 400 | VIAS.00010018 | The video source configuration is invalid.                                      | 视频源配置参数无效。                                        | 请检查配置参数是否合法。          |
  | 400 | VIAS.00010019 | The project ID is invalid.                                                      | 项目ID无效。                                           | 检查项目id是否正确。           |
  | 500 | VIAS.00010020 | An error occurs on the agency client. (Internal error)                          | 委托客户端错误。                                          | 内部错误，结合日志定位。          |
  | 401 | VIAS.00010021 | The account is restricted, frozen, or unauthenticated.                          | 账户已被限制、冻结或未经身份验证。                                 | 进行实名认证。               |
  | 400 | VIAS.00010022 | The database entity object is not found. (Internal error)                       | 数据库实体对象未找到。                                       | 内部错误，检查实体对象不存在的原因。    |
  | 500 | VIAS.00010023 | Token authentication failed or the permission is insufficient. (Internal error) | token认证失败或权限不足。                                   | 内部错误，检查请求的权限。         |
  | 500 | VIAS.00010024 | The request is invalid. (Internal error)                                        | 请求不合法。                                            | 内部错误，检查请求的权限。         |
  | 500 | VIAS.00010025 | A network error occurs when the dependent service is accessed.                  | 与依赖服务间存在网络错误。                                     | 内部错误，检查与依赖服务间的网络状态。   |
  | 500 | VIAS.00010026 | The internal response body cannot be analyzed. (Internal error)                 | 内部响应体无法分析。                                        | 内部错误，检查内部响应体格式。       |
  | 500 | VIAS.00010027 | The agency parameters are invalid. (Internal error)                             | 委托参数无效。                                           | 内部错误，检查委托操作的请求参数。     |
  | 500 | VIAS.00010028 | An IAM service exception occurs. (Internal error)                               | IAM服务端异常。                                         | 内部错误，检查IAM服务状态。       |
  | 500 | VIAS.00010029 | The maximum number of agencies has been reached. (Internal error)               | 委托数量达到最大限制。                                       | 内部错误，删除其他委托。          |
  | 500 | VIAS.00010030 | The current zone has the same name as the trusted zone. (Internal error)        | 当前域与信任域同名。                                        | 内部错误，当前域与信任域名称不能相同。   |
  | 500 | VIAS.00010031 | The agency is not found. (Internal error)                                       | 委托无法找到。                                           | 内部错误，结合日志定位。          |
  | 500 | VIAS.00010032 | The trusted zone name is incorrect. (Internal error)                            | 信任域名错误。                                           | 内部错误，检查信任域参数。         |
  | 500 | VIAS.00010033 | Deleting the agency failed. (Internal error)                                    | 委托删除失败。                                           | 内部错误，检查数据库表操作。        |
  | 500 | VIAS.00010034 | Updating the agency failed. (Internal error)                                    | 委托更新失败。                                           | 内部错误，检查数据库表操作。        |
  | 500 | VIAS.00010035 | An agency with the same name already exists. (Internal error)                   | 委托已经存在。                                           | 内部错误，无需创建委托，或创建其他委托。  |
  | 500 | VIAS.00010036 | An interrupt exception occurs when the IAM API is called. (Internal error)      | 请求IAM接口发生中断异常。                                    | 内部错误，检查请求。            |
  | 500 | VIAS.00010037 | An exception occurs when the IAM API is called. (Internal error)                | 请求IAM接口时异常。                                       | 内部错误，检查请求。            |
  | 500 | VIAS.00010038 | The request body for calling the IAM API is invalid. (Internal error)           | 请求IAM接口时，构造的请求体不合法。                               | 内部错误，检查构造的请求体。        |
  | 500 | VIAS.00010039 | Failed to verify the image repository. (Internal error)                         | 镜像仓校验失败。                                          | 内部错误，检查内部token是否成功获取。 |
  | 400 | VIAS.00010040 | The account type is not supported.                                              | 不支持的账号类型。                                         | 请使用非op_svc账号登录。       |
  | 400 | VIAS.00010045 | The OBS object does not exist.                                                  | OBS对象不存在。     | 请选择已有的OBS对象。          |
  | 400 | VIAS.00010046 | IVM has not been enabled.                                                       | IVM服务未开通。                                         | 请开通IVM服务。             |
  | 400 | VIAS.00010047 | The maximum number of video sources has been reached.                           | 视频源配额超过上限。    | 请联系管理员调整配额。           |
  | 400 | VIAS.00010048 | The maximum number of tasks has been reached.                                   | 任务配额超过上限。  | 请联系管理员调整配额。           |
  | 400 | VIAS.00010050 | Pool quota exceeds the upper limit.                                             | 资源池创建已达上限。                                        | 请购买更多许可或删除空闲资源池。      |
  | 400 | VIAS.00010051 | do not match unique constraint.                                                 | 唯一性校验失败。                                          | 检查参数唯一性。              |
  | 400 | VIAS.00010501 | Quota not enough.                                                               | 配额不足。                                             | 联系服务运维人员。             |
  | 400 | VIAS.00010502 | More than one process tried to change the quota at the same time.               | 多个进程重试修改配额数量。                                     | 请稍后重试该操作。             |
     
  
 
