
# 错误码
| 状态码 | 错误码               | 错误信息                                                                            | 描述                     | 处理措施               |
|:---|:---|:---|:---|:---|
| 404 | common.0011       | query job fail                                                                  | 查询任务失败                 | 请确认参数是否正确。         |
| 400 | VolumeBackup.0014 | submit job exception                                                            | 提交任务异常。                | 请重试，若仍未解决，请联系技术支持。 |
| 401 | VolumeBackup.0041 | api roles is null or empty                                                      | 检查用户权限失败。              | 添加对应的用户权限。         |
| 403 | VolumeBackup.0042 | user role is not allowed for this action                                        | 用户无权限操作。               | 添加对应的操作权限。         |
| 401 | VolumeBackup.0044 | invalid token roles                                                             | 用户的权限无效。               | 获取合法的token。        |
| 400 | VolumeBackup.0002 | api request parameter instance null                                             | 请求的备份格式错误。             | 使用合法的备份格式。         |
| 400 | VolumeBackup.0003 | api request parameter name over length                                          | 请求中名称参数过长。             | 使用合法的名称参数。         |
| 400 | VolumeBackup.0004 | api request parameter name invalid character                                    | 请求中名称参数含有非法字符。         | 使用合法的名称参数。         |
| 400 | VolumeBackup.0005 | api request parameter name invalid prefix                                       | 请求中名称参数不能以auto开头。      | 使用合法的名称参数。         |
| 400 | VolumeBackup.0006 | api request parameter description is invalid                                    | 请求中描述参数过长或包含非法字符。      | 使用合法的描述参数。         |
| 400 | VolumeBackup.0007 | api request parameter name is null                                              | 请求中名称参数为空。             | 使用合法的名称参数。         |
| 400 | VolumeBackup.0008 | get assume role token fail                                                      | 获取权限信息失败。              | 使用合法的token。        |
| 400 | VolumeBackup.0009 | call IAM api to get shadow domain ak and sk fail.                               | 获取密钥信息失败。              | 具体原因请联系技术支持。       |
| 400 | VolumeBackup.0010 | api request parameter volume_id null                                            | 请求中云硬盘ID参数为空。          | 使用合法的云硬盘ID。        |
| 400 | VolumeBackup.0011 | api request parameter volume_id invalid UUID pattern                            | 请求中云硬盘ID参数格式错误。        | 使用合法的云硬盘ID。        |
| 400 | VolumeBackup.0012 | volume status is not available or in-use                                        | 云硬盘的状态不是"可用"或"正在使用"。   | 请在正确的状态下执行该操作。     |
| 400 | VolumeBackup.0013 | volume's last backup progress is not finished                                   | 云硬盘的上一个创建备份任务仍未结束。     | 请等待上次备份任务结束后再次备份   |
| 400 | VolumeBackup.0017 | fsp cinder create snapshot exception                                            | 创建快照异常。                | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0018 | fsp cinder return null snapshot                                                 | 创建快照结果为空。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0019 | fsp cinder get snapshot detail exception                                        | 创建备份时查询快照异常。           | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0020 | got snapshot detail is null                                                     | 查询快照结果为空。              | 请重试，若仍未解决，请联系技术支持。 |
| 404 | VolumeBackup.0021 | volume not exists                                                               | 云硬盘不存在，或已被用户删除。        | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0022 | fsp cinder create volume exception                                              | 创建临时云硬盘结果异常。           | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0023 | fsp cinder return null volume                                                   | 创建临时云硬盘结果为空。           | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0024 | fsp cinder get volume detail exception                                          | 查询临时云硬盘结果异常。           | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0025 | got volume detail is null                                                       | 查询临时云硬盘结果为空。           | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0026 | api request parameter name length is too short                                  | 请求中名称参数过短。             | 使用合法的名称参数。         |
| 400 | VolumeBackup.0027 | fsp cinder or ebackup create backup exception                                   | 创建备份结果异常。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0028 | fsp cinder or ebackup return null backup                                        | 创建备份结果为空。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0029 | fsp cinder get backup detail exception                                          | 查询备份结果异常。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0030 | got backup detail is null                                                       | 查询备份结果为空。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0035 | fsp cinder get volume details exception                                         | 查询用户所有云硬盘异常。           | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0036 | fsp cinder get backup details exception                                         | 查询用户所有备份异常。            | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0037 | created snapshot status is not available or query snapshot exception            | 查询快照状态异常。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0038 | created volume status is not available or query volume exception                | 查询临时云硬盘状态异常。           | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0039 | created backup status is not available or query backup exception                | 查询备份状态异常。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0040 | volume's backup number is over limit                                            | 云硬盘已有备份数目达到上限。         | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0043 | fsp cinder get volume or backup detail exception                                | 查询云硬盘或备份异常。            | 请使用正确的云硬盘或备份。      |
| 400 | VolumeBackup.0049 | api request tag parameter is invalid                                            | 标签参数不合法。               | 使用合法的标签参数。         |
| 400 | VolumeBackup.0050 | The number of tags exceeded                                                     | 标签数量达到上限。              | 请合法使用标签功能。         |
| 400 | VolumeBackup.0051 | volume of this pod does not support backup                                      | 当前磁盘不支持备份。             | 暂不支持备份，可联系技术支持。    |
| 400 | VolumeBackup.0053 | DESS volume type is not support backup                                          | 专属企业存储类型的磁盘不能创建备份。     | 暂不支持备份，可联系技术支持。    |
| 400 | VolumeBackup.0062 | fsp cinder return snapshot status is error                                      | 快照状态为error。            | 请在正确的状态下执行该操作。     |
| 400 | VolumeBackup.0063 | fsp cinder return temp volume status is error                                   | 临时云硬盘状态为error。         | 请在正确的状态下执行该操作。     |
| 400 | VolumeBackup.0064 | fsp cinder return backup status is error                                        | 备份状态为error。            | 请在正确的状态下执行该操作。     |
| 400 | VolumeBackup.0070 | query quota usage exception                                                     | 查询配额信息异常。              | 具体原因请联系技术支持。       |
| 400 | VolumeBackup.0071 | no enough sas volume quota num                                                  | SAS类型的云硬盘数目配额已满。       | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0072 | no enough sas volume quota bytes                                                | SAS类型的云硬盘容量配额已满。       | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0073 | no enough sata volume quota num                                                 | SATA类型的云硬盘数目配额已满。      | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0074 | no enough sata volume quota bytes                                               | SATA类型的云硬盘容量配额已满。      | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0075 | no enough ssd volume quota num                                                  | SSD类型的云硬盘数目配额已满。       | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0076 | no enough ssd volume quota bytes                                                | SSD类型的云硬盘容量配额已满。       | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0077 | no enough sas snapshot quota num                                                | SAS类型的快照数目配额已满。        | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0078 | no enough sata snapshot quota num                                               | SATA类型的快照数目配额已满。       | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0079 | no enough ssd snapshot quota num                                                | SSD类型的快照数目配额已满。        | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0080 | no enough backup quota num                                                      | 备份数目配额已满。              | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0081 | no enough backup quota bytes                                                    | 备份容量配额已满。              | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0082 | no enough volume quota num                                                      | 云硬盘数目配额已满。             | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0083 | no enough volume quota bytes                                                    | 云硬盘容量配额已满。             | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0084 | no enough snapshot quota num                                                    | 快照数目配额已满。              | 请联系客服扩大配额。         |
| 400 | VolumeBackup.0100 | submit subjod exception in delete backup status                                 | 提交子任务异常。               | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0101 | delete snapshot exception in delete backup status                               | 删除快照异常。                | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0102 | delete backup exception when call openstack api                                 | 删除备份结果异常。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0103 | query backup detail exception in delete backup status                           | 查询备份详情异常。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0104 | get glance msg from fsp failed.                                                 | 获取镜像信息异常。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0105 | the url is invalid                                                              | 删除备份请求格式错误。            | 使用合法的请求参数。         |
| 400 | VolumeBackup.0109 | query snapshot from fsp failed                                                  | 删除备份时查询快照异常。           | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0110 | the backup details msg is null                                                  | 查询备份异常。                | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0113 | The backup has been made as an image, cannot delete it                          | 备份制作过镜像，无法删除。          | 请先删除对应的镜像后再删除备份。   |
| 400 | VolumeBackup.0123 | query the backup details is null from FSP                                       | 查询所有备份异常。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0125 | failed to delete the backup.                                                    | 执行删除备份失败。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | VolumeBackup.0129 | Deleting this type of backups is not allowed                                    | 禁止删除此类型的备份。            | 具体原因请联系技术支持。       |
| 400 | VolumeBackup.0900 | error with ClientException                                                      | 服务暂时异常。                | 具体原因请联系技术支持。       |
| 404 | VolumeBackup.0111 | the volume info or backup detail is not exist                                   | 恢复的云硬盘或备份不存在。          | 使用合法的云硬盘与备份。       |
| 400 | VolumeBackup.0200 | restore backup exception                                                        | 恢复数据结果异常。              | 具体原因请联系技术支持。       |
| 400 | VolumeBackup.0201 | restore backup null response                                                    | 恢复数据结果为空。              | 具体原因请联系技术支持。       |
| 400 | VolumeBackup.0202 | restore backup volume error                                                     | 云硬盘的状态为error。          | 具体原因请联系技术支持。       |
| 400 | VolumeBackup.0203 | api request parameter backup_id null                                            | 请求中备份ID为空。             | 使用合法的备份ID。         |
| 400 | VolumeBackup.0204 | api request parameter backup_id invalid UUID pattern                            | 请求中备份ID格式错误。           | 使用合法的备份ID。         |
| 400 | VolumeBackup.0205 | volume for restore state is not available                                       | 云硬盘的状态不可用。             | 使用状态合法的云硬盘。        |
| 400 | VolumeBackup.0206 | volume for restore is creating backup                                           | 云硬盘正在创建备份。             | 等待备份完成后再重试任务。      |
| 404 | VolumeBackup.0207 | query the volume backup details msg is null                                     | 查询云硬盘不存在。              | 使用合法的云硬盘。          |
| 400 | VolumeBackup.0208 | volumeID in body is null or empty                                               | 请求中云硬盘ID错误。            | 使用合法的云硬盘ID。        |
| 400 | VolumeBackup.0209 | volume size is less than backup size                                            | 云硬盘大小需大于等于备份大小。        | 请对云硬盘进行扩容。         |
| 400 | VolumeBackup.0210 | body in request is empty                                                        | 恢复备份请求格式错误。            | 使用合法的恢复参数。         |
| 400 | VolumeBackup.0211 | Cloud disks at the disaster recovery site cannot be restored.                   | 容灾端的云硬盘不允许恢复操作。        | 使用合法的恢复参数。         |
| 400 | VolumeBackup.0089 | backup status is not available                                                  | 云硬盘备份状态为非可用状态。         | 使用正确状态的云硬盘备份。      |
| 400 | AutoBackup.0000   | request body is empty                                                           | 请求体为空。                 | 使用合法的请求体。          |
| 400 | AutoBackup.0001   | request body exist empty structure                                              | 请求体中对象为空。              | 使用合法的请求体。          |
| 401 | AutoBackup.0002   | request token is empty                                                          | 请求头中Token为空。           | 使用合法的token。        |
| 401 | AutoBackup.0003   | request token is expired                                                        | 请求头中Token已过期。          | 使用合法的token。        |
| 401 | AutoBackup.0005   | request domain id is empty                                                      | 请求头中Token无法获取domainID。 | 使用合法的token。        |
| 400 | AutoBackup.0006   | request policy id is empty                                                      | 请求中策略ID为空。             | 使用合法的请求参数。         |
| 400 | AutoBackup.0008   | convert request to JSON object failed                                           | 请求转化成JSON对象失败。         | 使用合法的请求参数。         |
| 500 | AutoBackup.0009   | internal error                                                                  | 系统内部处理出现异常。            | 请重试，若仍未解决，请联系技术支持。 |
| 400 | AutoBackup.0100   | normal tenant has no right to operator default policy                           | 租户不能修改默认备份策略。          | 具体原因请联系技术支持。       |
| 400 | AutoBackup.0101   | backup policy name length is illegal                                            | 备份策略的名称长度不合法。          | 使用合法的策略长度。         |
| 400 | AutoBackup.0102   | backup policy name is invalid                                                   | 备份策略的名称参数不合法。          | 使用合法的策略名称。         |
| 400 | AutoBackup.0103   | schedule policy start time format error                                         | 备份开始时间参数不合法。           | 使用合法的备份开始时间。       |
| 400 | AutoBackup.0104   | schedule policy status is illegal                                               | 备份策略状态参数不合法。           | 使用合法的策略状态。         |
| 400 | AutoBackup.0105   | schedule policy remain firstbackup of cur month is illegal                      | 是否保留当月第一份备份参数不合法。      | 使用合法的保留当月第一份备份。    |
| 400 | AutoBackup.0106   | schedule policy frequency is out of range                                       | 备份间隔参数不合法。             | 使用合法的备份间隔参数。       |
| 400 | AutoBackup.0107   | schedule policy rentention num is out of range                                  | 保留份数参数不合法。             | 使用合法的保留份数。         |
| 400 | AutoBackup.0108   | schedule policy rentention day is out of range                                  | 保留天数参数不合法。             | 使用合法的备份保留天数。       |
| 400 | AutoBackup.0109   | schedule policy week frequency is illegal, must in(SUN，MON，TUE，WED，THU，FRI，SAT) | 备份周期参数合法。              | 使用合法的备份周期参数。       |
| 400 | AutoBackup.0203   | backup policy num over limit                                                    | 创建的备份策略数量达到上限。         | 在限制范围内合理使用策略。      |
| 400 | AutoBackup.0204   | number of volumes reaches limit                                                 | 绑定磁盘的数量达到上限。           | 超出数量限制的磁盘绑定到新的策略。  |
| 404 | AutoBackup.0205   | policyId is not exist                                                           | 策略不存在。                 | 请正确使用策略。           |
| 400 | AutoBackup.1100   | query policy with null input or null tenantId                                   | 查询策略不存在。               | 请正确使用策略。           |
| 400 | AutoBackup.1300   | delete policy: delete policy by policyId failed                                 | 删除策略失败。                | 请重试，若仍未解决，请联系技术支持。 |
| 400 | AutoBackup.1400   | policy bind resources: resources illegal                                        | 绑定资源时，资源不合法。           | 使用合法的资源参数。         |
| 400 | AutoBackup.1700   | execute policy: input param invalid                                             | 执行备份策略失败。              | 请重试，若仍未解决，请联系技术支持。 |
| 400 | AutoBackup.0206   | volume to bind is in bad status                                                 | 需要绑定的磁盘状态不合法。          | 请在正确的磁盘状态下执行该操作。   |
| 400 | AutoBackup.0207   | resource to bind is empty                                                       | 绑定的资源为空。               | 使用合法的绑定参数。         |
| 404 | AutoBackup.0208   | unable to get specified resource detail, may be incorrect resource id           | 您所要操作的磁盘不存在，无法进行绑定和解绑。 | 请明确具体操作约束。         |
| 400 | AutoBackup.0209   | resource id or resource name is empty                                           | 资源ID或资源类型为空。           | 使用合法的资源参数。         |
| 400 | AutoBackup.0210   | HANA volume cannot bind to backup policy                                        | HANA磁盘无法绑定备份策略。        | 暂不支持备份，可联系技术支持。    |
| 400 | AutoBackup.0211   | bad resource type                                                               | 资源类型不合法。               | 使用合法的资源。           |
| 400 | AutoBackup.0213   | Unauthorized request                                                            | 请求权限不足。                | 添加对应的用户权限。         |
| 400 | AutoBackup.0217   | Snapshot quota is not enough                                                    | 快照配额不足。                | 请联系客服扩大配额。         |
| 400 | AutoBackup.0218   | Backup number quota is not enough                                               | 备份配额不足。                | 请联系客服扩大配额。         |
| 400 | AutoBackup.0220   | DESS volume cannot bind to backup policy                                        | DESS磁盘无法绑定到备份策略。       | 暂不支持备份，可联系技术支持。    |
| 400 | AutoBackup.0221   | The request contains invalid parametersThe request contains invalid parameters  | 请求中不能包含"\<"，"\>"字符。    | 使用合法的参数。           |
| 400 | AutoBackup.0222   | Only specified action is supported                                              | 只支持指定的action。          | 具体原因请联系技术支持。       |
| 400 | AutoBackup.0225   | the backup policy is being executed, failed to execute the backup task          | 备份策略正在执行，无法执行本次备份任务。   | 请等待该次备份完成后再继续执行任务。 |
| 401 | AutoBackup.9002   | authorization Filter fail                                                       | 系统鉴权时，发生内部异常。          | 请重试，若仍未解决，请联系技术支持。 |
   
