
# 错误码
当您调用API时，如果遇到"APIGW"开头的错误码，请参见[API网关错误码](https://support.huaweicloud.com/devg-apisign/api-sign-errorcode.html)进行处理。
更多服务错误码请参见[API错误中心](https://apierrorcenter.developer.huaweicloud.com/apierrorcenter)。
| 状态码 | 错误码      | 错误信息                                                                                                    | 描述                     | 处理措施                               |
|:---|:---|:---|:---|:---|
| 200 | TMS.5060 | Rules have been enabled.                                                                                | 规则已启用                  | 规则已启用，无需重复操作                       |
| 200 | TMS.5064 | An unexpected error occurred when calling FG.                                                           | 调用FG发生不在预期中的错误         | 请尝试等待后重试                           |
| 200 | TMS.5065 | Successfully created the dependency package in FG, but failed to obtain the dependency package version. | 在FG创建依赖包成功，但没有获取到依赖包版本 | 请检查FG云服务运行是否正常，并尝试等待后重试            |
| 200 | TMS.5066 | The requested region is not supported by the current rule.                                              | 当前规则不支持请求的Region       | 确认规则支持的region范围，确保操作的Region在支持的范围内 |
| 200 | TMS.6002 | The user function failed to run.                                                                        | 用户函数运行报错               | 请根据错误提示信息排查自身代码问题                  |
| 200 | TMS.6010 | Invoke timed out.                                                                                       | 函数执行超时                 | 请检查函数超时的原因和配置的超时时间                 |
| 200 | TMS.6014 | Reading the storeObject timeout.Use larger memory.                                                      | 加载依赖包超时                | 请增加函数的内存规格                         |
| 200 | TMS.6041 | The number of functions exceeds the maximum allowed limit.                                              | 租户的函数数量超过限制            | 检查租户的函数数量是否超限，超过配额请申请扩大配额          |
| 200 | TMS.6045 | The number of dependencies exceeds the maximum allowed limit.                                           | 依赖包数量超过了最大限制           | 检查依赖包数量是否超过了最大限制                   |
| 200 | TMS.6052 | The specified function version does not exist.                                                          | 找不到指定的函数版本             | 检查函数版本是否存在                         |
| 200 | TMS.6061 | The function already exists.                                                                            | 函数已经存在                 | 检查是否重复创建函数                         |
| 200 | TMS.6307 | The trigger name already exists.                                                                        | 触发器名称已存在               | 检查触发器名称是否重复                        |
| 200 | TMS.6403 | Forbidden.                                                                                              | 禁止操作                   | 检查用户的操作权限                          |
| 200 | TMS.6501 | The agency settings of the function are incorrect.                                                      | 函数的委托设置不正确             | 请检查请求函数的委托设置是否正确                   |
| 400 | TMS.0002 | Bad request.                                                                                            | 请求数据非法                 | 请检查请求参数                            |
| 400 | TMS.0007 | Limit is invalid.                                                                                       | limit不合法               | 请检查limit参数                         |
| 400 | TMS.0008 | Marker is invalid.                                                                                      | marker不合法              | 请检查marker参数                        |
| 400 | TMS.0009 | Key is invalid.                                                                                         | key不合法                 | 请检查key参数                           |
| 400 | TMS.0010 | Value is invalid.                                                                                       | value不合法               | 请检查value参数                         |
| 400 | TMS.0011 | Action is invalid.                                                                                      | action不合法              | 请检查action参数                        |
| 400 | TMS.0012 | Tags is empty.                                                                                          | tags为空                 | 请检查tags参数                          |
| 400 | TMS.0013 | Empty element in tags.                                                                                  | tags含有空元素              | 请检查tags参数                          |
| 400 | TMS.0016 | Values is too much.                                                                                     | value超过最大限额            | 请检查value参数                         |
| 400 | TMS.0017 | Offset is invalid.                                                                                      | offset不合法              | 请检查tags参数                          |
| 400 | TMS.1001 | The number of predefine tag exceeds the upper limit.                                                    | 预定义标签达到限额              | 请删除无用的预定义标签                        |
| 400 | TMS.1002 | Old_tag cannot be found.                                                                                | 旧标签不存在                 | 请检查旧标签参数                           |
| 400 | TMS.1003 | New_tag already exists.                                                                                 | 新标签已存在                 | 请检查新标签参数                           |
| 400 | TMS.1004 | Old_tag is empty.                                                                                       | 旧标签为空                  | 请检查旧标签参数                           |
| 400 | TMS.1005 | Invalid key in old_tag.                                                                                 | 旧标签中key无效              | 请检查旧标签Key参数                        |
| 400 | TMS.1006 | Invalid value in old_tag.                                                                               | 旧标签中value无效            | 请检查旧标签Value参数                      |
| 400 | TMS.1007 | New_tag is empty.                                                                                       | 新标签为空                  | 请检查新标签参数                           |
| 400 | TMS.1008 | Invalid key in new_tag.                                                                                 | 新标签中key无效              | 请检查新标签Key参数                        |
| 400 | TMS.1009 | Invalid value in new_tag.                                                                               | 新标签中value无效            | 请检查新标签Value参数                      |
| 400 | TMS.1010 | Order_field is invalid.                                                                                 | sortField不合法           | 请检查sortField参数                     |
| 400 | TMS.1011 | Order_method is invalid.                                                                                | orderMethod不合法         | 请检查orderMethod参数                   |
| 400 | TMS.5058 | Tag inheritance is not enabled.                                                                         | 标签继承能力未开通              | 请先开通标签继承能力，再进行操作                   |
| 400 | TMS.5059 | The requested rule is not enabled (the rule does not exist).                                            | 请求的规则未启用（规则不存在）        | 请先启用规则，再进行操作                       |
| 400 | TMS.5061 | System rule. The operation is not allowed.                                                              | 系统规则，不允许操作             | 请操作正常的继承规则                         |
| 400 | TMS.5062 | The request does not contain valid operational area information.                                        | 请求中没有有效的可以操作的区域信息      | 请检查区域信息是否正确                        |
| 400 | TMS.5063 | Failed to create agency.                                                                                | 创建委托失败                 | 请检查用户是否拥有创建委托权限                    |
| 401 | TMS.0003 | Unauthorized user.                                                                                      | 用户未被授权                 | 请检查认证token                         |
| 403 | TMS.0004 | Permission error.                                                                                       | 权限不足                   | 请检查权限                              |
| 403 | TMS.0006 | The request is too much, try again later.                                                               | 请求过多,稍后重试              | 请求过多,稍后重试                          |
| 404 | TMS.0005 | Requested resources not found.                                                                          | 资源未找到                  | 请联系服务支持人员确认接口是否注册                  |
| 409 | TMS.0014 | Conflict                                                                                                | 内部冲突                   | 请联系服务支持人员                          |
| 500 | TMS.0001 | System error.                                                                                           | 系统错误                   | 请联系服务支持人员                          |
| 504 | TMS.0018 | Query Time Out.                                                                                         | 查询超时                   | 请稍后再试                              |
   
