
# 错误码
当调用出错时，HTTP请求返回一个4xx或5xx的HTTP状态码。返回的消息体中是具体的错误代码及错误信息。在调用方找不到错误原因时，可以联系企业技术人员，并提供错误码，以便尽快帮您解决问题。
#### 返回体格式
当接口调用出错时，会返回错误码及错误信息说明，错误响应的Body体格式如下所示
```
{ 
        "error_msg": "xxx",
        "error_code": "JOB_MANAGER.12050009"
}
```
其中，error_code表示错误码，error_msg表示错误描述信息。
表1异常响应说明 
| 名称         | 参数类型   | 说明      |
|:---|:---|:---|
| error_code | String | 错误码。    |
| error_msg  | String | 错误详细信息。 |
   
#### 错误码说明
当您调用API时，如果遇到"APIGW"开头的错误码，请参见[API网关错误码](https://support.huaweicloud.com/devg-apisign/api-sign-errorcode.html)进行处理。
表2错误码 
| 状态码 | 错误码                  | 错误信息                                                                                                                         | 描述                                                               | 处理措施                                                                                                                                         |
|:---|:---|:---|:---|:---|
| 401 | OptVerse_10000001    | Authenticate token failure.                                                                                                  | 校验Token失败。                                                       | 请联系管理员处理                                                                                                                                     |
| 401 | OptVerse_10000003    | The X-User-Profile header is missing.                                                                                        | 当前请求中没有X-User-Profile。                                           | 请联系管理员处理                                                                                                                                     |
| 403 | OptVerse_10000004    | The tenant {0} is not allowed to access the service.                                                                         | 该租户 {0} 禁止访问本服务。                                                 | 请联系管理员处理                                                                                                                                     |
| 403 | OptVerse_10000005    | The user does not have access to this project \[{0}\].                                                                       | 用户无权访问项目\[{0}\]。                                                 | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_10000006    | Failed to get project info, because {0}.                                                                                     | 获取项目信息失败，因为{0}。                                                  | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_10000007    | Failed to get agency token, domainId:{0}, because {1}.                                                                       | 获取委托token失败，domainId：{0}，原因：{1}。                                 | 请检查是否在边缘应用-容器应用页面授权天筹求解器服务访问您的智能边缘平台服务（IEF）                                                                                                  |
| 401 | OptVerse_10000008    | The X-User-Profile decode error.                                                                                             | X-User-Profile解码失败。                                              | 请联系管理员处理                                                                                                                                     |
| 403 | OptVerse_10000009    | Access is denied due to the user being frozen or restricted.                                                                 | 由于用户被冻结或受限，访问被拒绝。                                                | 您当前用户被冻结或受限，请到账号中心查明具体原因                                                                                                                     |
| 400 | OptVerse_12040001    | The product is not found on service type {0} and region {1}.                                                                 | 在服务类型{0}和区域{1}上找不到该产品。                                           | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_12040002    | Get product error: {0}.                                                                                                      | 获取产品失败：{0}。                                                      | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_12040003    | The product is not found on resource spec code {0}.                                                                          | 未找到产品资源规格代码：{0}。                                                 | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_12040010    | The product concurrent number {0} not in range 1\~1000.                                                                      | 产品并发数 {0} 不在 1\~1000 规定范围内。                                      | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_12040011    | The resource is frozen. Please go to the Billing Center to check the reason.                                                 | 资源已冻结，请前往费用中心查看原因。                                               | 请联系管理员处理                                                                                                                                     |
| 500 | OptVerse_12040012    | Failed to enable ondemand. Please contact the administrator.                                                                 | 开通按需失败，请联系管理员。                                                   | 请联系管理员排查                                                                                                                                     |
| 404 | OptVerse_12040014    | The user \[{0}\] of service \[{1}\] is not found.                                                                            | 在服务\[{1}\]中用户\[{0}\]不存在。                                         | 请联系管理员处理                                                                                                                                     |
| 500 | JOB_MANAGER_12000001 | System error. no response. Please try again later or contact customer service.                                               | 系统异常，暂无响应，请稍后重试，或联系客服。                                           | 请联系管理员处理                                                                                                                                     |
| 400 | JOB_MANAGER_12060004 | Failed to create OBS client, projectId: {0}.                                                                                 | 创建OBS客户端失败, 用户: {0}。                                             | 请联系管理员处理                                                                                                                                     |
| 400 | JOB_MANAGER_12060005 | File upload to OBS failed,bucket: {0}, object: {1}, filePath: {2}.                                                           | OBS上传文件失败, 桶：{0}，对象：{1}，文件路径: {2}。                               | 请联系管理员处理                                                                                                                                     |
| 400 | JOB_MANAGER_12060007 | OBS download failed, bucket: {0}, object: {1}, projectId: {2}.                                                               | OBS下载对象失败，桶: {0}, 对象: {1}, 用户: {2}。                              | 请联系管理员处理                                                                                                                                     |
| 400 | JOB_MANAGER_12060008 | The OBS url {0} format is incorrect.                                                                                         | OBS路径{0}格式错误。                                                    | 请联系管理员处理                                                                                                                                     |
| 400 | JOB_MANAGER_12060009 | Get OBS temporary URL error.                                                                                                 | 获取OBS临时URL失败。                                                    | 请联系管理员处理                                                                                                                                     |
| 404 | OptVerse_12080001    | SDK license not found, project_id:{0}, service_type:{1}, sub_job_id:{2}.                                                     | 未找到SDK许可文件，用户项目id：{0}，服务类型：{1}，资源id：{2}。                         | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_1212080002  | The SDK license file has not been uploaded, project_id:{0}, service_type:{1}, sub_job_id:{2}.                                | SDK许可文件未上传，用户项目id：{0}，服务类型：{1}，资源id：{2}。                         | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_1212080003  | SDK version does not exist, versionId: {0}, serviceType: {1}.                                                                | SDK版本不存在，版本ID：{0}，服务类型：{1}。                                      | 请刷新页面重试                                                                                                                                      |
| 400 | OptVerse_1212080004  | SDK version is offline, versionId: {0}, serviceType: {1}.                                                                    | 该SDK版本已下线，版本ID：{0}，服务类型：{1}。                                     | 请刷新页面重试                                                                                                                                      |
| 400 | OptVerse_1212080005  | No active license for downloading SDK, projectId: {0}, serviceType: {1}.                                                     | 没有可用于下载SDK的许可文件，用户项目ID：{0}，服务类型：{1}。                             | 请先订阅该SDK                                                                                                                                     |
| 400 | JOB_MANAGER_12020001 | The task {0} does not exist.                                                                                                 | 任务{0}不存在。                                                        | 任务不存在或已被删除，请检查task_id                                                                                                                        |
| 400 | JOB_MANAGER_12020002 | The task type {0} does not exist.                                                                                            | 任务类型{0}不存在。                                                      | 任务类型不存在，请检查URL中的service_type                                                                                                                 |
| 400 | JOB_MANAGER_12020004 | User \[{0}\] was not authorized for service \[{1}\].                                                                         | 用户\[{0}\]未被授予调用服务\[{1}\]的权限。                                     | 请使用管理员账号在服务管理-服务列表为子用户分配并发数                                                                                                                  |
| 400 | JOB_MANAGER_12020005 | The total number of task for the OptVerse service exceeds the limit. Please try again later or contact customer service.     | 云服务总并发数超出限额，请稍后重试，或联系客服。                                         | 云服务总并发数超出限额，请稍后重试，或联系客服                                                                                                                      |
| 400 | JOB_MANAGER_12020007 | The task input valid error, {0}.                                                                                             | 任务输入校验失败，{0}。                                                    | 请根据具体报错描述信息，检查入参问题                                                                                                                           |
| 400 | JOB_MANAGER_12020008 | UserId \[{0}\] exceeds the service \[{1}\] concurrent limit \[{2}\].                                                         | 用户\[{0}\]超出服务\[{1}\]给的并发数限额\[{2}\]。                              | 用户超出对应服务给的并发数限额，请稍后重试                                                                                                                        |
| 400 | JOB_MANAGER_12020010 | The resource is not found for task.                                                                                          | 任务的按需资源信息不存在。                                                    | 请联系管理员处理                                                                                                                                     |
| 400 | JOB_MANAGER_12020011 | The resource status is \[{0}\], and user can't create tasks.                                                                 | 按需资源状态为\[{0}\]，用户不能创建任务。                                         | 请检查您购买的资源是否冻结或受限                                                                                                                             |
| 500 | JOB_MANAGER_12020013 | Failed to insert the task \[{0}\] to the {1}.                                                                                | 任务{0}插入{1}失败。                                                    | 请联系管理员处理                                                                                                                                     |
| 500 | JOB_MANAGER_12020014 | Service \[{0}\] does not have schema.                                                                                        | 服务{0}不存在Schema。                                                  | 请联系管理员处理                                                                                                                                     |
| 403 | JOB_MANAGER_12020015 | Concurrency for service \[{1}\] of user\[{0}\] frozen, can't create tasks.                                                   | 用户\[{0}\]的并发数被冻结。                                                | 用户所分配的并发数所对应的资源已被冻结，请检查                                                                                                                      |
| 400 | JOB_MANAGER_12020017 | ProjectId \[{0}\] have 0 concurrent for service \[{1}\], can't create tasks.                                                 | 项目\[{0}\]在服务\[{1}\]拥有的共享并发数为0，不能创建任务。                            | 请使用租户管理员账号在服务管理-服务列表为子用户调整共享并发数，或稍后再试                                                                                                        |
| 400 | JOB_MANAGER_12020018 | In the params, start_time and end_time must be used together, and end_time must be later than start_time.                    | 查询参数中，开始时间和结束时间必须搭配使用，且结束时间必须晚于开始时间。                             | 查询参数中，开始时间和结束时间必须搭配使用，且结束时间必须晚于开始时间，请检查                                                                                                      |
| 400 | JOB_MANAGER_12020019 | Free trial has expired, project_id: \[{0}\], user_id: \[{1}\], service_type: \[{2}\].                                        | 免费试用已到期，项目ID：\[{0}\]，用户ID：\[{1}\]，服务类型：\[{2}\]。                  | 免费试用已到期                                                                                                                                      |
| 500 | JOB_MANAGER_12020020 | Service type: {0}, project id: {1}, no resource pool matched.                                                                | 服务类型：{0}，项目id：{1}，未匹配到资源池。                                       | 请联系管理员处理                                                                                                                                     |
| 404 | OptVerse_12030001    | The service \[{1}\] in the given project \[{0}\] is not found.                                                               | 项目\[{0}\]下的指定服务\[{1}\]不存在。                                       | 请联系管理员处理                                                                                                                                     |
| 401 | OptVerse_12030002    | The requested \[{0}\] concurrency is over the quota of resource \[{1}\].                                                     | 请求的\[{0}\]并发数超过资源\[{1}\]拥有的配额。                                   | 为子用户分配的并发数超过资源拥有的配额                                                                                                                          |
| 404 | OptVerse_12030004    | The resource \[{1}\] in the given project \[{0}\] is not found.                                                              | 项目\[{0}\]下的指定资源\[{1}\]不存在。                                       | 请联系管理员处理                                                                                                                                     |
| 403 | OptVerse_12030005    | The resource \[{0}\] is abnormal, can't assign.                                                                              | 资源\[{0}\]异常，不可分配。                                                | 订单状态异常，请检查是否已冻结或受限                                                                                                                           |
| 403 | OptVerse_12030006    | The service \[{0}\] have 0 concurrent, can't set concurrency type to shared.                                                 | 服务类型\[{0}\]下可共享并发数为0，不可将用户设为共享。                                  | 该服务类型下可共享并发数为0，不可将用户设为共享                                                                                                                     |
| 400 | OptVerse_12030007    | Get product error: {0}                                                                                                       | 获取产品失败：{0}。                                                      | 请联系管理员处理                                                                                                                                     |
| 409 | OptVerse_12090001    | Conflict notification rules exist: \[{0}\].                                                                                  | 存在冲突的通知规则：\[{0}\]。                                               | 请根据具体报错信息检查存在冲突的通知规则。检查是否存在冲突的通知规则，user和serviceType均存在相同或包含关系，即为冲突                                                                           |
| 500 | OptVerse_12090002    | Failed to add notification, please contact the administrator.                                                                | 添加通知失败，请与管理员联系。                                                  | 添加通知失败，请与管理员联系                                                                                                                               |
| 400 | OptVerse_13020001    | The node arch is different from the image arch. The node arch is {0}, and the image arch is {1}, deployment name:\[{2}\].    | 节点结构与镜像架构不一致。节点架构是{0}，镜像架构是{1}，部署名称：\[{2}\]。                     | 节点结构与镜像架构不一致，请根据报错信息选择符合架构的镜像                                                                                                                |
| 400 | OptVerse_13020002    | If the IEF instance is pro edition, the replicas must be 1, deployment name:\[{0}\].                                         | 如果IEF实例为专业版，实例数量只能为1，部署名称：\[{0}\]。                               | IEF实例为专业版，实例数量只能为1                                                                                                                           |
| 400 | OptVerse_13020003    | CPU is lower than the app\[{0}\] version\[{1}\] requirement. required:\[{2}\], provided:\[{3}\]. deployment name:\[{4}\].    | cpu配置低于应用\[{0}\]版本\[{1}\]要求。要求：\[{2}\]，提供：\[{3}\]。部署名称：:\[{4}\]。 | 请根据报错信息调整CPU配额                                                                                                                               |
| 400 | OptVerse_13020004    | Memory is lower than the app\[{0}\] version\[{1}\] requirement. required:\[{2}\], provided:\[{3}\]. deployment name:\[{4}\]. | 内存配置低于应用\[{0}\]版本\[{1}\]要求。要求：\[{2}\]，提供：\[{3}\]。部署名称：:\[{4}\]。  | 请根据报错信息调整内存配额                                                                                                                                |
| 400 | OptVerse_13020005    | The deployment\[{0}\] does not exist.                                                                                        | 该应用部署\[{0}\]不存在。                                                 | 应用部署不存在，请刷新页面重试                                                                                                                              |
| 400 | OptVerse_13020006    | Resource is not found where projectId\[{0}\] and appType\[{1}\].                                                             | projectId\[{0}\]和应用类型\[{1}\]下找不到使用资源。                            | 未找到对应的资源，请重新选择关联资源                                                                                                                           |
| 400 | OptVerse_13020007    | The resources are insufficient where projectId\[{0}\] and appType\[{1}\].                                                    | projectId\[{0}\]和应用类型\[{1}\]下资源不足。                               | 资源配额不足，请重新选择关联资源                                                                                                                             |
| 400 | OptVerse_13020008    | The quota of billing are insufficient, projectId:\[{0}\], appType\[{1}\], subJobId\[{2}\].                                   | 订单配额不足， projectId:\[{0}\]， 应用类型\[{1}\]， 订单ID\[{2}\]。             | 订单资源配额不足，请重新选择关联资源，或购买实例数                                                                                                                    |
| 400 | OptVerse_13020009    | The app version is set to Offline, app version:\[{0}\].                                                                      | 该应用版本已下线，版本号:\[{0}\]。                                            | 应用版本已下线，请重新选择应用版本                                                                                                                            |
| 400 | OptVerse_13020010    | When type is 0, create an AK/SK configmap, ak and sk are required in configs.                                                | 当type为0时，创建ak/sk配置项，configs中需要有ak和sk。                            | 请重新填写AK/SK                                                                                                                                   |
| 400 | OptVerse_13020011    | When type is 1, create a HTTPS secret, server.crt and server.key are required in configs.                                    | 当type为1时，创建Https配置项，configs中需要有server.crt和server.key。            | 请重新在页面添加证书及密钥                                                                                                                                |
| 400 | OptVerse_13020012    | The config\[{0}\] type is invalid.                                                                                           | 该配置项类型\[{0}\]不合法。                                                | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_13020013    | The domain4 secret\[{0}\] is not found.                                                                                      | domain4密钥\[{0}\]未找到。                                             | 在OptVerse边缘应用-应用配置页面添加一个AKSK配置时，会在IEF的边缘应用-应用配置页面的配置项和密钥AKSK配置项和domain4密钥（命名示例：optverse-aksk-test、optverse-domain4-test）请检查domain4密钥是否被手动误删除 |
| 400 | OptVerse_13020014    | The container\[{0}\] of deployment\[{1}\] does not exist.                                                                    | 应用部署\[{1}\]下的容器\[{0}\]不存在。                                       | 应用启动时报此错误属于正常现象，边缘应用容器会自动重试                                                                                                                  |
| 400 | OptVerse_13020015    | The replicas of deployment\[{0}\] is incorrect.                                                                              | 该应用部署\[{0}\]的实例数量有误。                                             | 请勿在IEF页面手动修改实例数，应用实例数需要与OptVerse页面显示实例数一致                                                                                                    |
| 400 | OptVerse_13020017    | The order status is abnormal, projectId:\[{0}\], subJobId:\[{1}\].                                                           | 订单状态异常，项目Id：\[{0}\]，资源Id：\[{1}\]。                                | 资源对应的订单状态异常，请检查是否已冻结或受限                                                                                                                      |
| 400 | OptVerse_13020018    | Failed to create share domain in SWR, serviceType: {0}, domainName: {1}, error message: {2}.                                 | 在SWR中创建共享账号失败， 服务类型： {0}, 账号名： {1}，错误信息： {2}。                    | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_13020019    | Failed to update share domain in SWR, serviceType: {0}, domainName: {1}, error message: {2}.                                 | 在SWR中更新共享账号信息失败， 服务类型： {0}, 账号名： {1}，错误信息： {2}。                  | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_13020020    | Failed to query share domain in SWR, serviceType: {0}, domainName: {1}, error message: {2}.                                  | 在SWR中查询共享账号信息失败， 服务类型： {0}, 账号名： {1}，错误信息： {2}。                  | 请联系管理员处理                                                                                                                                     |
| 500 | OptVerse_13020021    | Invalid image URL, please contact the administrator.                                                                         | 无效的镜像URL，请联系管理员。                                                 | 无效的镜像URL，请联系管理员                                                                                                                              |
| 500 | OptVerse_13030001    | Failed to request the IEF \[{0}\] API, request:\[{1}\], message:\[{2}\].                                                     | 请求IEF\[{0}\]API失败，请求参数:\[{1}\]，错误信息\[{2}\]。                      | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_13040001    | SCC reinitialize error, SCC conf:\[{0}\].                                                                                    | SCC重新初始化失败，SCC配置:\[{0}\]。                                        | 请联系管理员处理                                                                                                                                     |
| 400 | OptVerse_13040002    | SCC execute method error, error message: {0}.                                                                                | SCC执行方法失败，错误信息: {0}。                                             | 请联系管理员处理                                                                                                                                     |
   
