
# 历史错误码
调用接口出错后，调用方可根据每个接口对应的错误码来定位错误原因。 当调用出错时，HTTP 请求返回一个 4xx 或 5xx 的 HTTP 状态码。返回的消息体中包含具体的错误代码及错误信息。在调用方找不到错误原因时，可以联系华为云客服，并提供错误码，以便我们尽快帮您解决问题。
#### 错误响应Body体格式说明
当接口调用出错时，会返回错误码及错误信息说明，错误响应的Body体格式如下所示。
```
{
    "error_code": "OMS.0064",
    "error_msg": "Invalid request parameters."
}
```
其中，error_code表示错误码，error_msg表示错误描述信息。
#### 错误码说明
表1请求接口的错误码 
| 错误码      | 错误信息                                              |
|:---|:---|
| S3M.0001 | 非法参数。                                             |
| S3M.0002 | 非法参数格式。                                           |
| S3M.0004 | 无效HTTP请求。                                         |
| S3M.0005 | 请求的HTTP方法不存在。                                     |
| S3M.0014 | 输入的参数可能造成注入攻击风险，导致系统不稳定。                          |
| S3M.0051 | 参数range不合法。                                       |
| S3M.0052 | 参数state不合法。请输入0-5的整数。                             |
| S3M.0053 | 任务查询失败或权限不足。                                      |
| S3M.0054 | 任务ID无效。                                           |
| S3M.0055 | 源端文件和文件夹无效。                                       |
| S3M.0056 | 用户ID无效。                                           |
| S3M.0057 | 源端参数无效。                                           |
| S3M.0058 | 目的端参数无效。                                          |
| S3M.0059 | 迁移线程数无效。请输入0-50的整数。                               |
| S3M.0060 | 不支持迁移对象至当前区域的桶。                                   |
| S3M.0061 | 任务参数格式错误。                                         |
| S3M.0062 | 任务保存失败。                                           |
| S3M.0063 | 任务正在迁移中。您必须先暂停此任务然后再删除它。                          |
| S3M.0064 | 请求参数无效。                                           |
| S3M.0065 | 任务已经启动。                                           |
| S3M.0066 | 暂停任务失败。该任务未处于迁移中状态。                               |
| S3M.0067 | 参数不是JSON格式。                                       |
| S3M.0068 | 鉴权失败。                                             |
| S3M.0069 | 由于目前KMS服务不可用，因此暂时不支持设置enableKMS为true。             |
| S3M.0070 | 迁移任务已完成。您不能再启动或暂停它。                               |
| S3M.0072 | 您没有足够的权限。                                         |
| S3M.0073 | 删除任务失败。                                           |
| S3M.0074 | 请求参数必须与OMS服务的API参考文档中提供的内容保持一致。                   |
| S3M.0075 | 过去24小时之内您创建的任务数已经达到上限。请稍后再试。                      |
| S3M.0076 | 您创建的处于等待中迁移任务数已达到上限。请稍后再试。                        |
| S3M.0077 | 用户当前创建的任务数量已经超过限制。                                |
| S3M.0078 | 描述中不能包含如下特殊字符：\<\>()\\"\\'\&                      |
| S3M.0079 | 不支持的源端区域。                                         |
| S3M.0080 | 不支持的目的端区域。                                        |
| S3M.0081 | 自定义域名检查失败，请确保输入正确。                                |
| S3M.0082 | 暂不支持该源端云厂商归档数据的解冻。                                |
| S3M.0083 | 流量控制策略数量超过上限。                                     |
| S3M.0084 | 最大带宽取值超出范围。                                       |
| S3M.0085 | 时段有重叠。                                            |
| S3M.0086 | 修改流量控制参数失败。                                       |
| S3M.0087 | 流量控制参数错误。                                         |
| S3M.0088 | 所选择的任务类型与传入参数不匹配。                                 |
| S3M.0151 | 无效参数。                                             |
| S3M.0152 | 查询区域信息失败。                                         |
| S3M.0153 | 查询桶信息失败。                                          |
| S3M.0154 | 连接OBS失败。                                          |
| S3M.0155 | 查询桶所在的区域信息失败                                      |
| S3M.0156 | SMN服务内部错误，发送SMN通知消息失败。                            |
| S3M.0157 | SMN消息主题不存在，发送SMN通知消息失败。                           |
| S3M.0158 | OMS服务无权限访问迁移任务所选的SMN消息主题，发送SMN通知消息失败。             |
| S3M.0159 | OMS服务鉴权失败，无法发送SMN通知消息。                            |
| S3M.0160 | OMS服务内部错误，发送SMN通知消息失败。                            |
| S3M.0161 | 网络异常，无法使用SMN服务发送通知。                               |
| S3M.0162 | 请求头长度超过限制。                                        |
| S3M.0163 | 请求Token长度超过限制。                                    |
| S3M.0167 | 找不到失败对象列表。                                        |
| S3M.0168 | 您的SMN主题与当前服务不在同一区域，发送SMN通知消息失败。                   |
| S3M.0169 | SMN消息主题不存在或您没有使用当前主题的权限。 请选择另一个主题或获取当前主题所需的权限后重试。 |
| S3M.0256 | API版本不存在。                                         |
| S3M.0307 | 追加迁移失败对象信息到OBS失败。                                 |
| S3M.0308 | 失败对象列表不完整，请联系对象存储迁移服务查询处理。                        |
   
表2查询任务的错误码 
| 错误码      | 错误信息                                                                                                                    |
|:---|:---|
| TRF.0001 | 系统内部异常。请单击重启按钮尝试重启迁移任务。                                                                                                 |
| TRF.0002 | 服务器未响应。请单击重启按钮尝试重启迁移任务。                                                                                                 |
| TRF.0003 | 迁移任务等待超时。请单击重启按钮尝试重启迁移任务。                                                                                               |
| TRF.0004 | 服务器错误。请单击重启按钮尝试重启迁移任务。                                                                                                  |
| TRF.0005 | 服务器错误。请单击重启按钮尝试重启迁移任务。                                                                                                  |
| TRF.0006 | 迁移任务已完成，迁移后的部分文件与源端不一致。请单击重启按钮尝试重启迁移任务。                                                                                 |
| TRF.0007 | 网络中断或OBS服务无响应。请稍后重试。                                                                                                    |
| TRF.0008 | 任务迁移失败。请确认AK/SK是否正确。单击重启按钮尝试重启迁移任务。                                                                                     |
| TRF.0009 | 源桶查询失败，请检查网络或AK/SK是否有效。单击重启按钮尝试重启迁移任务。                                                                                  |
| TRF.0010 | 目的桶查询失败，请检查网络或AK/SK是否有效。单击重启按钮尝试重启迁移任务。                                                                                 |
| TRF.0011 | 当前迁移任务所选的源端对象为空，请重新创建迁移任务。                                                                                              |
| TRF.0012 | 任务参数校验失败，请确认在所选择的迁移方式下对象存在。                                                                                             |
| TRF.0013 | 任务参数校验失败， 请确保对象列表文件存在且可以正常获取（具有读写权限）。                                                                                   |
| TRF.0014 | 任务参数校验失败， 请确保对象列表文件大小不能超过100MB且必须是".txt"类型的文件。                                                                          |
| TRF.0018 | 任务参数校验失败，请确保对象列表文件中每一行的长度都不超过65535。                                                                                     |
| TRF.0019 | 任务参数校验失败，请确保对象列表文件的metaData中contentType为text/plain、且不能设置contentEncoding。                                                |
| TRF.0051 | 您输入的AK/SK对应账号无足够权限访问目的端桶或者对象。请确认AK/SK对应账号有足够权限后重试。                                                                      |
| TRF.0052 | 您输入的AK/SK对应账号无足够权限访问目的端桶或者对象。请确认AK/SK对应账号有足够权限后重试。                                                                      |
| TRF.0053 | 由于您的账号状态异常（过期或已被冻结）导致迁移操作无法完成。                                                                                          |
| TRF.0054 | 您输入的AK/SK对应账号无足够权限访问目的端桶或者对象。请确认AK/SK对应账号有足够权限后重试。                                                                      |
| TRF.0055 | 目的端桶的剩余空间不足。请确认该桶具有充足空间后重试。                                                                                             |
| TRF.0056 | 您的迁移账户已被冻结。请解冻后重试。                                                                                                      |
| TRF.0057 | 您输入的AK/SK无效。请输入正确AK/SK后重试。                                                                                              |
| TRF.0058 | 目的端桶不存在（迁移过程中请勿修改目的端桶或者对象的访问权限）。请确认桶名正确后重试。                                                                             |
| TRF.0059 | 目的端对象不存在（迁移过程中请勿修改目的端桶或者对象的访问权限）。请确认桶名或对象名正确后重试。                                                                        |
| TRF.0060 | 用于存储迁移对象的路径太长, 请更改要迁移的对象的名称或路径。                                                                                         |
| TRF.0061 | 目的端对象存储服务异常，请稍后重试。                                                                                                      |
| TRF.0062 | 部分对象上传失败，请确认没有其他迁移同名对象的任务后重试。                                                                                           |
| TRF.0063 | 解冻归档数据失败，请前往源端手动解冻归档数据后再迁移。                                                                                             |
| TRF.0064 | 存在未解冻的归档数据，请先解冻后再进行迁移。                                                                                                  |
| TRF.0151 | 源端AK/SK无效。请输入有效的AK/SK后重试。                                                                                               |
| TRF.0152 | 您输入的AK/SK对应账号无足够权限访问源端桶或者对象。请确认AK/SK对应账号有足够权限后重试。                                                                       |
| TRF.0153 | 您输入的AK/SK对应账号无足够权限访问源端桶或者对象。请确认AK/SK对应账号有足够权限后重试。                                                                       |
| TRF.0154 | 您输入的AK/SK对应账号无足够权限访问源端桶或者对象。请确认AK/SK对应账号有足够权限后重试。                                                                       |
| TRF.0155 | 源端桶不存在（迁移过程中请勿修改源端桶或者对象的访问权限）。请确认桶名正确后重试。                                                                               |
| TRF.0156 | 源端对象不存在（迁移过程中请勿修改源端桶或者对象的访问权限）。请确认桶名或对象名正确后重试。                                                                          |
| TRF.0157 | 源端对象存储服务异常，请稍后重试。                                                                                                       |
| TRF.0158 | 任务迁移完成，但目的端对象数据加密状态不正确，请确认目的端区域是否支持KMS加密。                                                                               |
| TRF.0159 | 由于源端对象存储访问频率过高，受源端限制导致任务失败，解决方法请参见：[源端对象存储访问频率过高导致迁移失败怎么办？](https://support.huaweicloud.com/oms_faq/oms_faq_0007.html)。 |
| TRF.0160 | 无法读取归档类型数据，请解冻数据后进行迁移。                                                                                                  |
| TRF.0301 | 选定的对象列表文件属于归档数据无法获取，请手动解冻后再进行迁移。                                                                                        |
   
