
# 错误码
调用接口出错后，将不会返回结果数据。调用方可根据每个接口对应的错误码来定位错误原因。 当调用出错时，HTTP请求返回一个4xx的HTTP状态码。返回的消息体中是具体的错误代码及错误信息。在调用方找不到错误原因时，可以联系华为云客服，并提供错误码，以便尽快帮您解决问题。
#### 错误响应Body体格式说明
当接口调用出错时，会返回错误码及错误信息说明，错误响应的Body体格式如下所示。
```
{ 
    "error_msg": "您请求的资源已经被占用，或存在关联资源", 
    "error_code": "octopus.402009" 
}
```
其中，error_code表示错误码，error_msg表示错误描述信息。
#### 错误码说明
当您调用API时，如果遇到"APIGW"开头的错误码，请参见[API网关错误码](https://support.huaweicloud.com/devg-apisign/api-sign-errorcode.html)进行处理。
表1仿真服务错误码 
| 状态码 | 错误码            | 错误信息                                                                                               | 描述                            | 处理措施                       |
|:---|:---|:---|:---|:---|
| 400 | octopus.400000 | Request parameter verification failed.                                                             | 请求参数校验失败。                     | 请确认请求参数正确。                 |
| 401 | octopus.400001 | The request token is invalid.                                                                      | 请求token不合法。                   | 请更新Authorization中的Token。   |
| 403 | octopus.400003 | Insufficient permission to operate.                                                                | 操作权限不足。                       | 请联系管理员申请权限。                |
| 404 | octopus.400004 | The resource does not exist.                                                                       | 您请求的资源不存在。                    | 请确认您访问的资源是否正确。             |
| 405 | octopus.400005 | The server denies the request using the current HTTP method.                                       | 服务器禁止了使用当前HTTP方法的请求。          | 请改变HTTP请求方法。               |
| 409 | octopus.400009 | The resource you requested is already in use， or the resource is bound to another resource.        | 您请求的资源已经被占用，或存在关联资源。          | 请稍后重试，或请确保请求资源已解除或已删除关联资源。 |
| 500 | octopus.400100 | Internal server error.                                                                             | 内部服务错误。                       | 请联系华为自动驾驶云服务技术支持团队或稍后再试。   |
| 502 | octopus.400102 | The response received from the upstream server is invalid.                                         | 从上游服务器中接收到的响应是无效的。            | 请检查网关和代理服务器。               |
| 504 | octopus.400104 | The server acting as a gateway or proxy cannot get the desired response within the specified time. | 扮演网关或者代理的服务器无法在规定的时间内获得想要的响应。 | 请检查网关和代理服务器。               |
   
表2Common-SDK错误码 
| 状态码 | 错误码            | 错误信息                                                                                       | 描述                      | 处理措施                       |
|:---|:---|:---|:---|:---|
| 400 | octopus.000001 | Request parameter verification failed                                                      | 请求参数校验失败                | 请确认请求参数正确                  |
| 400 | octopus.000003 | Request params \[{key}:{value}\] is invalid                                                | 请求参数\[{key}:{value}\]错误 | 请确保请求参数\[{key}:{value}\]正确 |
| 400 | octopus.000122 | Insufficient object storage quota                                                          | 对象存储配额不足                | 请确认您拥有足够的对象存储配额            |
| 401 | octopus.000101 | The request token header is missing                                                        | 请求头token丢失              | 请求头中请添加正确的X-Auth-Token     |
| 401 | octopus.000102 | The request token expires                                                                  | 请求token过期               | 请更新请求头X-Auth-Token中的token  |
| 401 | octopus.000103 | The request token is invalid                                                               | 请求token不合法              | 请更新请求头X-Auth-Token中的token  |
| 403 | octopus.000111 | Insufficient permission to operate                                                         | 操作权限不足                  | 请联系管理员申请权限                 |
| 403 | octopus.000112 | Permission is denied                                                                       | 您无权访问该资源                | 请确认您访问的资源或项目ID是否正确         |
| 403 | octopus.000113 | Iam role is suspended, permission is denied                                                | 您的用户角色被冻结，无权访问该资源       | 请联系华为自动驾驶云服务技术支持团队         |
| 403 | octopus.000114 | Iam role is restricted, permission is denied                                               | 您的用户角色被受限，无权访问该资源       | 请联系华为自动驾驶云服务技术支持团队         |
| 403 | octopus.000115 | Insufficient permission to operate service interfaces                                      | 操作权限不足，无权访问服务间接口        | 请联系管理员申请权限                 |
| 404 | octopus.000141 | The resource does not exist                                                                | 您请求的资源不存在               | 请确认您访问的资源是否正确              |
| 409 | octopus.000142 | Resource has already existed                                                               | 您请求的资源已经存在              | 请更换资源名称                    |
| 409 | octopus.000143 | The resource you requested is already in use, or the resource is bound to another resource | 您请求的资源已经被占用，或存在关联资源     | 请稍后重试，或请确保请求资源已解除或已删除关联资源  |
| 500 | octopus.000002 | Internal server error                                                                      | 内部服务出现错误                | 请联系华为自动驾驶云服务技术支持团队或稍后再试    |
| 500 | octopus.000110 | IAM access error                                                                           | IAM接入连接出现错误             | 请联系华为自动驾驶云服务技术支持团队或稍后再试    |
| 500 | octopus.000121 | Object storage access error                                                                | 对象存储访问错误                | 请联系华为自动驾驶云服务技术支持团队或稍后再试    |
| 500 | octopus.000131 | Database access error                                                                      | 数据库接入连接出现错误             | 请联系华为自动驾驶云服务技术支持团队或稍后再试    |
   
表3镜像仓库错误码 
| 状态码 | 错误码            | 错误信息                                             | 描述             | 处理措施                |
|:---|:---|:---|:---|:---|
| 404 | octopus.007001 | The image not exist or deleted.                  | 请求的镜像不存在或已被删除。 | 请确认请求了正确的镜像或创建新的镜像。 |
| 409 | octopus.007004 | Current image status do not support this action. | 镜像当前状态不支持该操作。  | 请稍后再试。              |
   
表4数据服务错误码 
| 状态码 | 错误码            | 错误信息                                                                                                                                                | 描述                      | 处理措施                     |
|:---|:---|:---|:---|:---|
| 400 | octopus.101001 | Built-in Tag Edit Illegal                                                                                                                           | 内置标签不支持编辑               | 请选择自建标签                  |
| 400 | octopus.101004 | Tag Does Not Exist                                                                                                                                  | 标签不存在                   | 请选择正确的标签                 |
| 400 | octopus.107001 | Scenario Name is already exists                                                                                                                     | 场景名称已存在                 | 请检查后重试                   |
| 400 | octopus.102003 | The collect yaml content error                                                                                                                      | 采集说明文件内容有误              | 请检查采集说明文件的内容             |
| 400 | octopus.102004 | User do not agree the statement                                                                                                                     | 用户未同意申明                 | 请勾选同意后再试                 |
| 400 | octopus.102010 | The data package is not found                                                                                                                       | 数据包不存在                  | 请选择其他数据包                 |
| 400 | octopus.103005 | The bucket name specified in the request is invalid, which may have exceeded the maximum length, or contain special characters that are not allowed | 请求中指定的桶名无效，超长或带不允许的特殊字符 | 更换桶名                     |
| 400 | octopus.108002 | Time parameters is invalid                                                                                                                          | 时间不符合规范                 | 请检查时间格式是否正确或结束时间是否小于开始时间 |
| 400 | octopus.108008 | Time interval is invalid                                                                                                                            | 时长不符合规范                 | 请选择时长在10-99秒的片段          |
| 400 | octopus.108009 | The episode not exists                                                                                                                              | 回放片段不存在                 | 请检查后重试                   |
| 403 | octopus.109004 | The job status is abnormal                                                                                                                          | 作业状态异常                  | 请稍后重试                    |
| 403 | octopus.109008 | The user is different from the processor creation user                                                                                              | 当前用户与创建该算子的用户不一致        | 请切换账号后重试                 |
| 404 | octopus.107002 | Scenario is not exists                                                                                                                              | 场景不存在                   | 请检查后重试                   |
| 404 | octopus.107003 | The data package is missing the necessary data types                                                                                                | 数据包缺少必要的数据类型，无法生成仿真场景   | 请检查后重试                   |
| 404 | octopus.107004 | Tag is not exist                                                                                                                                    | 标签不存在                   | 请检查后重试                   |
| 404 | octopus.109001 | The processor you requested does not exist                                                                                                          | 您请求的算子不存在               | 请检查输入参数并重试               |
| 404 | octopus.109003 | The job does not exist                                                                                                                              | 作业不存在                   | 请检查输入参数并重试               |
| 409 | octopus.101002 | Node In Use                                                                                                                                         | 节点使用中                   | 请检查节点                    |
| 409 | octopus.101003 | Level Exceed Limit                                                                                                                                  | 节点层级超过限制                | 请尝试其他节点                  |
| 409 | octopus.101005 | Tag Name Already Exists                                                                                                                             | 请求的标签名称已存在              | 请更换标签名称                  |
| 409 | octopus.101006 | Tag Used In Segments                                                                                                                                | 标签被场景片段引用               | 请删除场景片段或解除标签引用           |
| 409 | octopus.101006 | Tag Used In Packages                                                                                                                                | 标签被数据包引用                | 请检查数据包状态或解除标签引用          |
| 409 | octopus.101006 | Tag Used In Data Warehouse                                                                                                                          | 标签被数据仓库引用               | 请删除数据仓库或解除标签引用           |
| 409 | octopus.102005 | Can not restore deleted failed package                                                                                                              | 不能删除已经删除失败的数据包          | 请参考API文档                 |
| 409 | octopus.102006 | Collection status conflict                                                                                                                          | 收集任务状态冲突                | 请检查数据收集状态                |
| 409 | octopus.102009 | Package status conflict                                                                                                                             | 数据包状态冲突                 | 请检查数据包状态                 |
| 409 | octopus.107005 | There is already a running scenario job                                                                                                             | 已有场景作业正在运行中             | 请稍后再试                    |
| 409 | octopus.109002 | The name of processor already exist                                                                                                                 | 算子名称已存在                 | 请使用不同的名称                 |
| 428 | octopus.109005 | The job precondition unsatisfied                                                                                                                    | 作业状态不符合要求               | 请检查后重试                   |
   
表5数据集服务错误码 
| 状态码 | 错误码            | 错误信息                                                         | 描述              | 处理措施                    |
|:---|:---|:---|:---|:---|
| 400 | octopus.202101 | Cce interface error                                          | CCE接口异常错误       | 请稍后重试或联系华为自动驾驶云服务技术支持团队 |
| 400 | octopus.202201 | Name has already exists                                      | 名称已经存在          | 请使用未使用的名称后重试            |
| 400 | octopus.202202 | Dataset do not exist error                                   | 数据集不存在          | 请确认数据集是否存在              |
| 400 | octopus.202205 | Dataset version does not exist error                         | 数据集版本不存在        | 请确认数据集版本是否存在            |
| 400 | octopus.202207 | This version is not the latest version                       | 此版本非最新版本        | 删除需从最新版本开始              |
| 400 | octopus.202210 | This label task is being executed in other versions          | 其它版本中有该标注任务在执行  | 请等待其他版本中的该标注任务执行完成后重试   |
| 500 | octopus.202213 | Data repeat                                                  | 数据重复            | 数据不允许重复，请检查数据后重试        |
| 400 | octopus.202223 | The dataset only support one version                         | 该数据集只支持一个版本     | 请确认数据集类型是否正确，或选择其他数据集   |
| 400 | octopus.202225 | The data does not exist                                      | 该数据不存在          | 请确认该数据是否存在，或更换其余数据      |
| 429 | octopus.202230 | Too many request exceeds the threshold                       | 请求次数过多超出了限定次数阈值 | 请稍等后重试                  |
| 400 | octopus.202238 | The dataset has already been associated with annotation task | 该数据集关联了标注任务     | 请确认是否该数据集关联了标注任务        |
| 400 | octopus.202239 | The OBS quota is insufficient                                | OBS配额不足         | 请确认OBS配额                |
   
