
# 错误码
调用接口出错后，将不会返回结果数据。调用方可根据每个接口对应的错误码来定位错误原因。当调用出错时，HTTP 请求返回一个4xx或5xx的HTTP状态码。返回的消息体中是具体的错误代码及错误信息。在调用方找不到错误原因时，可以联系客服，并提供错误码，以便尽快帮您解决问题。
错误响应示例如下：
```
{
    "errors": [
        {
            "error_code": "DLV.1000",
            "error_msg": "Screen number exceed quota."
        }
    ]
}
```
表1错误码 
| 状态码 | 错误码      | 错误信息                                                             | 处理措施                    |
|:---|:---|:---|:---|
| 400 | DLV.1000 | Screen number exceed quota.                                      | 删除大屏后重新尝试。              |
| 400 | DLV.1001 | The screen name exists. Use another name.                        | 检查大屏名称是否与已有大屏名称重复。      |
| 400 | DLV.1003 | Processing failed.                                               | 请联系服务管理员。               |
| 400 | DLV.1004 | The operation with the resource entity occur some error.         | 请联系服务管理员。               |
| 400 | DLV.1005 | Invalid screen name                                              | 检查大屏名称，修改正确后重新尝试。       |
| 500 | DLV.1006 | Invalid screen config.                                           | 检查请求参数内容，修改正确后重新尝试。     |
| 400 | DLV.1007 | The screen does not exist.                                       | 检查大屏ID是否正确。             |
| 400 | DLV.1008 | The screen is already shared.                                    | 检查大屏是否已经被发布，无需重复发布。     |
| 400 | DLV.1009 | The screen is not shared.                                        | 发布大屏后重新尝试。              |
| 400 | DLV.1010 | Component config is null.                                        | 检查请求参数内容，修改正确后重新尝试。     |
| 400 | DLV.1011 | Invalid template id.                                             | 检查模板ID是否正确，使用正确的ID重新尝试。 |
| 400 | DLV.1012 | Invalid screen id.                                               | 检查大屏ID是否正确，使用正确的ID重新尝试。 |
| 400 | DLV.1013 | Invalid snapshot id.                                             | 检查快照ID是否正确，使用正确的ID重新尝试。 |
| 400 | DLV.1014 | The datasource name exists. Use another name.                    | 修改名字后重新尝试。              |
| 400 | DLV.1015 | The datasource name not exists.                                  | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1016 | The param info is not enough.                                    | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1017 | The datasource type is not support.                              | 更换支持的数据源类型重新尝试。         |
| 400 | DLV.1018 | The component does not exist.                                    | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1019 | Wrong affiliation                                                | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1020 | The templateId cannot be empty.                                  | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1021 | Snapshot number exceed quota.                                    | 确保快照数目不超限后重新尝试。         |
| 500 | DLV.1022 | The comList of screenConfig mismatch components.                 | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1023 | Get cluster failed.                                              | 请联系服务管理员。               |
| 400 | DLV.1024 | The image does not exist.                                        | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1025 | The datasource connect error.                                    | 请联系服务管理员。               |
| 400 | DLV.1026 | Invalid template name.                                           | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1027 | The template is already published.                               | 无需重复发布。                 |
| 400 | DLV.1028 | The template is not published.                                   | 请发布后重新尝试。               |
| 400 | DLV.1029 | The template does not exist.                                     | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1030 | The template status is null.                                     | 请联系服务管理员。               |
| 400 | DLV.1031 | The datasource type dli get failed for submit job failed.        | 请联系服务管理员。               |
| 400 | DLV.1032 | The datasource type dli get failed for get job status failed.    | 请联系服务管理员。               |
| 400 | DLV.1033 | The datasource type dli get failed for get job result failed.    | 请联系服务管理员。               |
| 400 | DLV.1034 | The datasource type dli get failed.                              | 请联系服务管理员。               |
| 400 | DLV.1035 | Get job result failed because of the schema or the rows is null. | 请联系服务管理员。               |
| 400 | DLV.1036 | Get queues failed.                                               | 请联系服务管理员。               |
| 400 | DLV.1037 | Get databases failed.                                            | 请联系服务管理员。               |
| 400 | DLV.1038 | upload image fail.                                               | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1039 | The type of file is wrong.                                       | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.1040 | The size of file is too big.                                     | 尝试用小一点的文件重试。            |
| 400 | DLV.1041 | Invalid datasource name.                                         | 检查参数，使用正确的参数重新尝试。       |
| 400 | DLV.6311 | Failed to get Mrs Cluster information.                           | 请联系服务管理员。               |
   
