
# 错误码
调用接口出错后，将不会返回结果数据。调用方可根据每个接口对应的错误码来定位错误原因。 当调用出错时，HTTP请求返回一个HTTP状态码。返回的消息体中是具体的错误编码及错误描述信息。
当您调用API时，如果遇到"APIGW"开头的错误码，请参见[API网关错误码](https://support.huaweicloud.com/devg-apisign/api-sign-errorcode.html)进行处理。
#### 错误码说明
表1错误码说明 
| 状态码 | 错误码        | 错误信息                                                                                                                                              | 描述                              | 处理措施                                             |
|:---|:---|:---|:---|:---|
| 400 | DBS.200001 | Parameter Error                                                                                                                                   | 参数错误                            | 检查传入的参数或URL是否全部正确。                               |
| 404 | DBS.200002 | The DB instance does not exist.                                                                                                                   | 实例不存在或已被删除                      | 检查实例ID、实例是否正确，实例是否存在。                            |
| 400 | DBS.200004 | Operation is illegal.                                                                                                                             | 操作不合法                           | 检查操作是否符合接口要求说明。                                  |
| 400 | DBS.200010 | Authentication failed.                                                                                                                            | 鉴权失败                            | 检查租户与实例的关系是否匹配。                                  |
| 403 | DBS.200011 | This instance {0} status makes it not be allowed to do this {1} operation now.                                                                    | 实例状态不允许                         | 检查实例的状态或实例正在进行的操作是否与请求冲突。                        |
| 404 | DBS.200013 | This node does not exist.                                                                                                                         | 节点不存在                           | 检查节点ID或组ID是否正确。                                  |
| 403 | DBS.200018 | Operation cannot be executed in current state of the DB instance.                                                                                 | 实例不可用                           | 检查实例的状态或实例正在进行的操作是否与请求冲突。                        |
| 403 | DBS.200019 | Another operation is being performed on the DB instance or the DB instance is faulty.                                                             | 实例状态不允许                         | 检查实例的状态或实例正在进行的操作是否与请求冲突。                        |
| 400 | DBS.200024 | The region is unavailable.                                                                                                                        | 所选区域不可用                         | 检查可用区名称是否正确，可用区是否在可用范围内。                         |
| 400 | DBS.200025 | Invalid AZ.                                                                                                                                       | 可用区非法                           | 检查可用区名称是否正确，可用区是否在可用范围内。                         |
| 403 | DBS.200028 | Volume size reach limit.                                                                                                                          | 磁盘大小已达到最大限制                     | 检查设置的磁盘大小是否已经超过上限。                               |
| 400 | DBS.200029 | Invalid username and password.                                                                                                                    | 非法的用户名密码                        | 检查用户名和密码是否匹配，密码是否符合密码要求。                         |
| 400 | DBS.200041 | Invalid datastore version.                                                                                                                        | 数据库版本非法                         | 检查数据库的版本号是否支持。                                   |
| 404 | DBS.200042 | Invalid database engine.                                                                                                                          | 数据库引擎非法                         | 检查数据库引擎是否为DDS支持的引擎。                              |
| 400 | DBS.200047 | Operation cannot be executed in current state of the DB instance or node.                                                                         | 不合法的实例或节点状态，该操作不允许              | 检查实例的状态或实例正在进行的操作是否与请求冲突。                        |
| 400 | DBS.200048 | Invalid VPC.                                                                                                                                      | 非法的虚拟私有云                        | 检查VPC ID、名称是否正确，是否符合要求。                          |
| 400 | DBS.200049 | Invalid subnet.                                                                                                                                   | 非法的子网                           | 检查子网ID、名称是否正确，是否符合要求。                            |
| 400 | DBS.200050 | Invalid security group.                                                                                                                           | 非法的安全组                          | 检查安全组ID、名称是否正确，是否符合要求。                           |
| 400 | DBS.200052 | Invalid password.                                                                                                                                 | 非法密码                            | 检查用户名和密码是否匹配，密码是否符合密码要求。                         |
| 400 | DBS.200053 | The DB instance specifications do not exist.                                                                                                      | 实例规格不存在                         | 检查规格是否正确，当前可用区是否支持该规格。                           |
| 400 | DBS.200054 | Invalid DB instance specifications.                                                                                                               | 下发规格非法                          | 检查规格是否正确，当前可用区是否支持该规格。                           |
| 400 | DBS.200057 | Invalid parameter group ID.                                                                                                                       | 非法的参数模板ID                       | 检查参数组是否正确，参数组是否存在，参数组是否与实例类型匹配。                  |
| 400 | DBS.200058 | Parameter template does not exist.                                                                                                                | 参数模板不存在                         | 检查参数模板是否存在。                                      |
| 400 | DBS.200059 | Invalid database port.                                                                                                                            | 非法的数据库端口                        | 检查数据库端口是否缺失或者数据库端口是否合法。                          |
| 400 | DBS.200060 | The database port is out of range.                                                                                                                | 数据库端口不在指定范围内                    | 检查数据库端口是否合法。                                     |
| 400 | DBS.200068 | Weak password.                                                                                                                                    | 弱密码                             | 检查密码是否符合要求，建议输入高强度密码。                            |
| 400 | DBS.200072 | Invalid storage space.                                                                                                                            | 磁盘大小超限                          | 检查磁盘大小是否超出了最大限制。                                 |
| 400 | DBS.200075 | Invalid node role.                                                                                                                                | 非法的节点角色                         | 检查节点角色是否符合要求，实例是否正常。                             |
| 403 | DBS.200076 | Operation cannot be executed in current state of the DB instance.                                                                                 | 实例状态不允许                         | 检查实例的状态或实例正在进行的操作是否与请求冲突。                        |
| 400 | DBS.200077 | Failed to change the password.                                                                                                                    | 更新密码失败                          | 检查用户名是否正确。                                       |
| 400 | DBS.200091 | Invalid IP address.                                                                                                                               | 无效的IP                           | 检查是否缺少必要的IP地址或者传入的IP地址是否合法。                      |
| 400 | DBS.200092 | The IP address already exists.                                                                                                                    | IP已经存在                          | 检查IP是否已经存在。                                      |
| 400 | DBS.200095 | Invalid parameter.                                                                                                                                | 参数错误                            | 检查请求体和URL的参数是否正确。                                |
| 400 | DBS.200302 | The storage space must be a multiple of 10.                                                                                                       | 扩容磁盘大小不是10的倍数                   | 检查磁盘大小是否是10的倍数。                                  |
| 400 | DBS.200303 | The maximum number of times that the storage space can be scaled up has been reached.                                                             | 扩容磁盘次数已达上限                      | 实例的扩容磁盘次数已达上限，需要继续扩容请联系技术支持。                     |
| 400 | DBS.200304 | The storage space can be scaled up for a maximum of four times.                                                                                   | 最多存储扩容四次                        | 检查实例是否已经进行了多次扩容。                                 |
| 400 | DBS.200306 | Invalid storage space.                                                                                                                            | 非法的磁盘大小                         | 检查磁盘大小的值是否正确，是否符合要求。                             |
| 400 | DBS.200311 | Scaling up storage space is not allowed in current state of the node.                                                                             | 节点不允许磁盘扩容                       | 检查节点类型是否正确，实例类型是否正确，节点ID是否正确。                    |
| 400 | DBS.200434 | Failed to restart the DB instance.                                                                                                                | 重启实例失败                          | 检查实例状态是否正常，实例否正在进行其它操作。                          |
| 400 | DBS.200451 | The node does not exist.                                                                                                                          | 节点不存在                           | 检查节点ID是否有误。                                      |
| 400 | DBS.200462 | The database port is the same as the current port.                                                                                                | 数据库端口和当前端口相同                    | 检查修改端口号时是否下发了相同的端口。                              |
| 400 | DBS.200470 | Invalid AZ.                                                                                                                                       | 非法的可用区                          | 检查可用区是否正确。                                       |
| 400 | DBS.200501 | The subnet does not exist.                                                                                                                        | 该子网已经被删除                        | 检查子网ID、名称是否存在，是否匹配VPC。                           |
| 400 | DBS.200502 | The security group does not exist.                                                                                                                | 安全组不存在，或不属于该vpc                 | 检查安全组ID、名称是否存在，是否匹配VPC。                          |
| 400 | DBS.200503 | The VPC does not exist.                                                                                                                           | 该vpc已经被删除                       | 检查租户是否拥有该VPC。                                    |
| 400 | DBS.200506 | The encryption key does not exist.                                                                                                                | 磁盘加密密钥不存在                       | 检查磁盘加密密钥ID是否存在。                                  |
| 400 | DBS.200507 | The encryption key is not available.                                                                                                              | 磁盘加密密钥状态不可用                     | 检查磁盘加密密钥状态是否是可用状态。                               |
| 403 | DBS.200604 | InstanceId and userId may be null, or an unauthorized operation has been issued.                                                                  | 实例不属于当前用户                       | 检查project_id和实例ID是否具有从属关系。                       |
| 400 | DBS.200700 | The EIP status does not allow EIP binding.                                                                                                        | EIP正在绑定中，不允许再次下发绑定              | 检查实例是否正在绑定弹性IP。                                  |
| 400 | DBS.200701 | The EIP status does not allow EIP unbinding.                                                                                                      | EIP状态不允许解绑                      | 检查弹性IP的状态是否允许该操作。                                |
| 400 | DBS.200702 | The node has been bound to a public IP address and cannot be bound again.                                                                         | 该节点已经绑定过公网IP，不能再次下发绑定。          | 检查节点是否已经有绑定的公网IP。                                |
| 400 | DBS.200816 | Failed to create the database user.                                                                                                               | 创建数据库用户失败                       | 检查数据库用户名称是否合法，并且检查数据库状态以及实例状态。                   |
| 400 | DBS.200817 | Failed to obtain the database user list.                                                                                                          | 获取数据库用户列表失败                     | 检查数据库状态以及实例状态。                                   |
| 400 | DBS.200818 | Failed to delete the database user.                                                                                                               | 删除数据库用户失败                       | 检查数据库状态以及实例状态。                                   |
| 400 | DBS.200823 | The database does not exist.                                                                                                                      | 数据库不存在                          | 检查数据库名称是否合法。                                     |
| 400 | DBS.200824 | The database account does not exist.                                                                                                              | 数据库账号不存在                        | 检查数据库用户名称是否合法。                                   |
| 400 | DBS.200826 | The database name already exists.                                                                                                                 | 数据库名称已存在                        | 检查数据库名称是否合法。                                     |
| 400 | DBS.200827 | The database user already exists.                                                                                                                 | 数据库账号名称已存在                      | 检查数据库用户是否合法。                                     |
| 400 | DBS.200828 | Built-in database accounts cannot be edited.                                                                                                      | 数据库内置账号，用户不可操作                  | 检查数据库用户是否合法。                                     |
| 400 | DBS.200998 | The system is busy. Try again later.                                                                                                              | 系统繁忙，请稍后再试                      | 系统繁忙， 稍后再试。                                      |
| 403 | DBS.201000 | The status of DB instance {0} does not allow the {1} operation.                                                                                   | 实例状态不允许                         | 检查实例状态或实例正在进行的操作是否和请求冲突。                         |
| 400 | DBS.201006 | Parameter error.                                                                                                                                  | 参数错误                            | 检查传入的参数或URL是否全部正确。                               |
| 403 | DBS.201014 | Operation cannot be executed in current state of the DB instance.                                                                                 | 实例状态不允许操作                       | 检查实例状态或实例正在进行的操作是否和请求冲突。                         |
| 403 | DBS.201015 | This operation cannot be performed because another operation is being performed on the DB instance or the DB instance is faulty. Try again later. | 该实例正在进行其它操作或该实例故障，无法执行该操作，请稍后重试 | 检查实例状态或实例正在进行的操作是否和请求冲突。                         |
| 400 | DBS.201020 | Invalid DB engine.                                                                                                                                | 数据库引擎非法                         | 检查数据库引擎是否为DDS支持的引擎。                              |
| 403 | DBS.201028 | The DB instance does not exist.                                                                                                                   | 实例不存在或已被删除                      | 检查实例是否属于该租户，实例是否存在。                              |
| 400 | DBS.201035 | The database name must be different.                                                                                                              | 存在相同的数据库名称                      | 检查是否存在相同的数据库名称。                                  |
| 400 | DBS.201038 | The collection name must be different.                                                                                                            | 存在相同的集合名称                       | 检查是否存在相同的集合名称。                                   |
| 400 | DBS.201101 | Invalid backup period.                                                                                                                            | 备份周期非法                          | 检查备份周期是否符合要求。                                    |
| 400 | DBS.201201 | The backup already exists.                                                                                                                        | 备份已存在                           | 检查该备份的备份名称或ID是否已经存在。                             |
| 400 | DBS.201202 | Operation cannot be executed in current state of the DB instance.                                                                                 | 实例不允许操作                         | 检查实例状态或实例正在进行的操作是否和请求冲突。                         |
| 400 | DBS.201204 | Operation cannot be executed in current state of the DB instance.                                                                                 | 备份文件不存在                         | 检查该备份是否存在，备份是否匹配实例。                              |
| 400 | DBS.201212 | Backup ID is illegal.                                                                                                                             | 备份ID非法                          | 检查该备份ID是否存在。                                     |
| 400 | DBS.201214 | The backup file does not exist.                                                                                                                   | 备份文件不存在                         | 检查该备份是否存在，备份是否匹配实例。                              |
| 400 | DBS.201215 | Time is illegal.                                                                                                                                  | 检查时间是否符合要求                      | 检查时间是否符合要求。                                      |
| 400 | DBS.201319 | Deleting backup file is not allowed because a restoration task is currently in progress. Please wait.                                             | 恢复时不允许删除原备份文件                   | 检查该备份是否正在用于恢复实例。                                 |
| 400 | DBS.201501 | The DB instance does not exist.                                                                                                                   | 实例不存在或已被删除                      | 检查租户是否拥有该实例，实例名或实例ID是否正确，实例是否存在。                 |
| 400 | DBS.201502 | The DB instance does not exist.                                                                                                                   | 实例不存在或已被删除                      | 检查租户是否拥有该实例，实例名或实例ID是否正确，实例是否存在。                 |
| 500 | DBS.201509 | Failed to access OBS.                                                                                                                             | OBS服务系统故障                       | 内部错误，请联系运维人员查看问题                                 |
| 404 | DBS.212001 | The parameter group {0} does not exist.                                                                                                           | 参数模板不存在                         | 检查参数组是否存在。                                       |
| 400 | DBS.212002 | The number of para groups exceeds quota.                                                                                                          | 参数模板个数超过配额                      | 删除不必要的参数组后再创建。                                   |
| 400 | DBS.212003 | This operation is not permitted.                                                                                                                  | 暂不能进行此操作                        | 检查实例状态或实例正在进行的操作是否和请求冲突。                         |
| 400 | DBS.212006 | The node associated with this parameter group is not available.                                                                                   | 参数模板所关联节点状态异常                   | 检查参数组关联的节点状态是否正常。                                |
| 400 | DBS.212008 | The database type does not exist.                                                                                                                 | 此版本数据库暂不支持                      | 数据库版本是否支持该操作。                                    |
| 400 | DBS.212013 | The parameter group does not exist.                                                                                                               | 参数模板不存在                         | 检查参数是否存在。                                        |
| 400 | DBS.212017 | The parameter is invalid.                                                                                                                         | 非法参数                            | 检查传入的参数或URL是否全部正确，是否符合要求。                        |
| 400 | DBS.212019 | Invalid parameter.                                                                                                                                | 非法参数                            | 检查传入的参数或URL是否全部正确，是否符合要求。                        |
| 400 | DBS.212028 | Invalid description.                                                                                                                              | 参数模板描述非法                        | 检查参数组描述是否合法。                                     |
| 400 | DBS.212030 | The parameter group name already exists.                                                                                                          | 参数名称已存在                         | 检查参数组名称是否正确，租户是否已经创建了该参数组。                       |
| 400 | DBS.212031 | Invalid parameter group name.                                                                                                                     | 参数模板名称非法                        | 检查参数组名称是否符合要求。                                   |
| 400 | DBS.212032 | The operation cannot be performed because this parameter group is being applied to one or more DB instance nodes.                                 | 该操作不被允许，因为此参数模板应用于一个或多个数据库实例节点  | 检查参数组是否已经被应用到实例。                                 |
| 400 | DBS.216026 | The node does not exist.                                                                                                                          | 节点不存在或已被删除                      | 检查传入的节点是否存在，节点是否归属当前的实例。                         |
| 403 | DBS.216030 | The queried node does not belong to the current instance.                                                                                         | 操作节点不属于该实例                      | 检查传入的节点是否归属当前实例。                                 |
| 400 | DBS.216031 | Invalid entity id.                                                                                                                                | entityId非法                      | 检查entityId是否正确。                                  |
| 400 | DBS.238007 | This operation cannot be performed in the current IP address status.                                                                              | 该IP的状态不允许进行该操作                  | 检查下发的IP是否已经被使用。                                  |
| 400 | DBS.239011 | Invalid SSL option.                                                                                                                               | 非法的SSL选项                        | 检查SSL参数是否缺失或者SSL选项是否合法。                          |
| 400 | DBS.239012 | The specifications are improper.                                                                                                                  | 规格大小不合理                         | 增强版在恢复到新实例的时候，下发的规格大小是否合理。                       |
| 400 | DBS.239014 | Failed to create the database role.                                                                                                               | 创建数据库角色失败                       | 请检查数据库状态以及实例状态。                                  |
| 400 | DBS.239015 | Failed to obtain the database role list.                                                                                                          | 获取数据库角色列表失败                     | 请检查数据库状态以及实例状态。                                  |
| 400 | DBS.239016 | Invalid database role.                                                                                                                            | 数据库角色非法                         | 请检查角色是否符合规范，并且检查数据库状态以及实例状态。                     |
| 400 | DBS.239017 | The database role name already exists.                                                                                                            | 数据库角色名称已存在                      | 检查数据库角色是否已经存在。                                   |
| 400 | DBS.239018 | The database role does not exist.                                                                                                                 | 数据库角色不存在                        | 请填写已存在的数据库状态。                                    |
| 400 | DBS.239019 | Invalid database permission.                                                                                                                      | 数据库权限非法                         | 检查数据库权限是否合法。                                     |
| 400 | DBS.239020 | Invalid database name.                                                                                                                            | 数据库名称非法                         | 检查数据库名称是否合法。                                     |
| 400 | DBS.239021 | Roles in the non-admin databases cannot be inherited from other databases.                                                                        | 非admin数据库上的角色不能从其它数据库继承         | 请检查数据角色是否合法。                                     |
| 400 | DBS.239022 | Cannot use database built-in roles.                                                                                                               | 数据库内置角色，禁止使用                    | 请检查角色是否合法。                                       |
| 400 | DBS.239023 | Invalid auditlog ID.                                                                                                                              | 审计日志ID非法                        | 请检查审计日志ID是否合法。                                   |
| 400 | DBS.239024 | The auditlog does not exist.                                                                                                                      | 审计日志不存在                         | 请检查审计日志是否存在。                                     |
| 400 | DBS.239025 | Invalid auditlog scope.                                                                                                                           | 审计范围非法                          | 请检查审计范围是否合法。                                     |
| 400 | DBS.239026 | Invalid auditlog type.                                                                                                                            | 审计类型非法                          | 请检查审计类型是否合法。                                     |
| 400 | DBS.239027 | Invalid restore type.                                                                                                                             | 恢复类型非法                          | 请检查恢复类型是否合法。                                     |
| 400 | DBS.239028 | Invalid table name.                                                                                                                               | 表名非法                            | 请检查表名是否合法。                                       |
| 400 | DBS.239029 | Failed to delete database role.                                                                                                                   | 删除数据库角色失败                       | 请检查数据库角色是否存在，实例状态是否正常。                           |
| 400 | DBS.239031 | Invalid balancer action.                                                                                                                          | 均衡开关动作非法                        | 检查action参数是否正确。                                  |
| 400 | DBS.239032 | Invalid balancer window.                                                                                                                          | 均衡活动时间窗非法                       | 检查时间窗的startTime和stopTime参数是否正确。                  |
| 400 | DBS.239033 | Balancer window not supported.                                                                                                                    | dds 4.0以下版本不支持设置均衡活动时间窗         | 冻结实例和DDS 4.0以下版本实例不支持设置均衡活动时间窗。                  |
| 400 | DBS.280001 | Parameter error.                                                                                                                                  | 参数错误                            | 检查传入的参数或URL是否全部正确，是否符合要求。                        |
| 400 | DBS.280004 | Operate type illegal.                                                                                                                             | 操作不合法                           | 检查操作是否符合接口要求说明。                                  |
| 500 | DBS.280005 | Server error. Try again later.                                                                                                                    | 服务器错误，请稍后重试                     | 联系技术支持处理。                                        |
| 400 | DBS.280015 | Permission denied.                                                                                                                                | 账号权限不足                          | 检查token是否过期，实例是否匹配租户。                            |
| 404 | DBS.280016 | Resource not found.                                                                                                                               | 未找到资源                           | 检查入参是否正确，实例是否存在。                                 |
| 403 | DBS.280019 | Account suspended.                                                                                                                                | 账户欠费                            | 检查账户余额。                                          |
| 403 | DBS.280032 | You do not have permission to perform this operation. Contact the administrator to obtain permission.                                             | 当前用户无操作权限，请联系管理员授权              | 检查当前用户所在用户组的权限是否允许对应的操作。                         |
| 403 | DBS.280042 | Invalid request.                                                                                                                                  | 非法请求                            | 检查实例当前状态及正在进行的操作是否允许该请求，请求是否合法。                  |
| 403 | DBS.280056 | Invalid token.                                                                                                                                    | Token非法                         | 检查实例是否属于租户，token是否已经重新获取。                        |
| 403 | DBS.280063 | You do not have following permission to perform this operation: {0}. Contact the administrator to obtain permission.                              | 当前用户无"*xxx*"操作权限，请联系账户管理员授权。    | 检查当前用户所在用户组的权限是否允许对应的操作。                         |
| 401 | DBS.280064 | Check PDP permissions failed.                                                                                                                     | 细粒度鉴权失败                         | 请联系客服处理。                                         |
| 400 | DBS.280066 | Invalid log type.                                                                                                                                 | 非法的日志类型                         | 检查日志类型是否符合要求。                                    |
| 400 | DBS.280067 | Invalid start time.                                                                                                                               | 非法的开始时间                         | 检查开始时间是否符合要求。                                    |
| 400 | DBS.280068 | Invalid end time.                                                                                                                                 | 非法的结束时间                         | 检查结束时间是否符合要求。                                    |
| 400 | DBS.280110 | The DB instance does not exist.                                                                                                                   | 实例不存在或已被删除                      | 检查租户是否拥有该实例，实例名或实例ID是否正确，实例是否存在。                 |
| 400 | DBS.280122 | Invalid DB engine.                                                                                                                                | 存储引擎非法                          | 检查存储引擎是否和实例引擎匹配。                                 |
| 400 | DBS.280123 | Invalid node number.                                                                                                                              | 扩容个数非法                          | 检查扩容的节点个数是否符合要求。                                 |
| 400 | DBS.280124 | Invalid backup.                                                                                                                                   | 非法的备份ID                         | 检查备份ID是否正确，是否符合要求。                               |
| 400 | DBS.280127 | Invalid backup description.                                                                                                                       | 非法的备份描述                         | 检查备份描述是否正确，是否符合要求。                               |
| 400 | DBS.280200 | The password contains invalid characters.                                                                                                         | 密码中包含非法字符                       | 检查密码是否正确，是否符合要求。                                 |
| 400 | DBS.280214 | Invalid retention period.                                                                                                                         | 保留天数非法                          | 检查备份保留天数是否正确。                                    |
| 400 | DBS.280215 | Invalid backup cycle.                                                                                                                             | 备份周期非法                          | 检查备份开始时间、结束时间，备份周期是否正确，是否符合要求。                   |
| 400 | DBS.280216 | Invalid backup start time.                                                                                                                        | 备份开始时间非法                        | 检查备份开始时间是否符合要求，备份开始时间和备份结束时间的关系是否正确。             |
| 400 | DBS.280234 | Invalid DB instance name.                                                                                                                         | 实例名称非法                          | 检查实例名称是否正确，实例是否存在。                               |
| 400 | DBS.280235 | Invalid database type.                                                                                                                            | 数据库类型非法                         | 检查数据库类型是否正确。                                     |
| 400 | DBS.280236 | Invalid database version.                                                                                                                         | 数据库版本非法                         | 检查数据库的版本号是否支持。                                   |
| 400 | DBS.280237 | DataStore is invalid.                                                                                                                             | 数据库信息非法                         | 检查数据库信息是否正确。                                     |
| 400 | DBS.280239 | Invalid specifications.                                                                                                                           | 非法的规格                           | 检查规格码是否正确，规格在当前可用区是否存在，规格是否支持。                   |
| 400 | DBS.280241 | Invalid storage type                                                                                                                              | 非法的磁盘类型                         | 检查磁盘的类型是否正确，是否符合要求。                              |
| 400 | DBS.280242 | The storage space is out of range.                                                                                                                | 磁盘大小超出范围                        | 检查磁盘大小的值是否正确。                                    |
| 400 | DBS.280244 | Invalid AZ.                                                                                                                                       | 可用区非法                           | 检查可用区的参数是正确，可用区是否存在，可用区是否和规格匹配。                  |
| 400 | DBS.280247 | Invalid VPC.                                                                                                                                      | VPC非法                           | 检查VPC ID是否正确，VPC是否存在。                            |
| 400 | DBS.280248 | Invalid subnet.                                                                                                                                   | 子网非法                            | 检查子网ID是否正确，子网是否存在。                               |
| 400 | DBS.280249 | Invalid security group.                                                                                                                           | 安全组非法                           | 检查安全组ID是否正确，安全组是否存在。                             |
| 400 | DBS.280266 | Invalid storage space.                                                                                                                            | 磁盘大小非法                          | 检查磁盘大小的值是否正确，是否符合要求。                             |
| 400 | DBS.280267 | Specifications not match.                                                                                                                         | 规格不匹配                           | 检查规格信息是否正确，规格是否和实例匹配。                            |
| 400 | DBS.280271 | Parameter value out of range.                                                                                                                     | 参数值过长                           | 检查参数值长度是否正确。                                     |
| 400 | DBS.280277 | Invalid backup name.                                                                                                                              | 备份名称非法                          | 检查备份名称是否正确，是否符合要求。                               |
| 400 | DBS.280280 | Invalid DB instance number.                                                                                                                       | 实例个数非法                          | 检查实例个数是否正确，是否符合要求。                               |
| 400 | DBS.280284 | Invalid IP address.                                                                                                                               | IP非法                            | 检查IP是否正确，是否符合要求。                                 |
| 400 | DBS.280292 | Invalid database username.                                                                                                                        | 用户名非法                           | 检查用户名是否正确，是否符合要求。                                |
| 400 | DBS.280311 | Invalid storage space.                                                                                                                            | 磁盘大小非法                          | 检查磁盘大小的值是否正确，是否符合要求。                             |
| 400 | DBS.280314 | Invalid storage space.                                                                                                                            | 磁盘类型非法                          | 检查磁盘类型是否正确，是否符合要求，实例是否支持该磁盘类型。                   |
| 400 | DBS.280327 | Invalid node type.                                                                                                                                | 节点类型非法                          | 检查节点类型是否正确，是否符合要求，节点类型与实例是否匹配，节点类型与组ID、节点ID是否匹配。 |
| 406 | DBS.280328 | Invalid DB instance type.                                                                                                                         | 实例类型非法                          | 检查实例类型是否正确。                                      |
| 400 | DBS.280342 | Invalid DB instance mode.                                                                                                                         | 实例模式非法                          | 检查实例模式是否正确，是否符合要求，实例模式与实例ID是否匹配。                 |
| 400 | DBS.280343 | Unsupported operation.                                                                                                                            | 操作不支持                           | 检查操作实例、节点是否符合接口要求。                               |
| 400 | DBS.280347 | Unsupported database type.                                                                                                                        | 数据库类型不支持                        | 检查实例类型是否正确，是否符合要求。                               |
| 400 | DBS.280361 | Invalid file name.                                                                                                                                | 非法的文件名称                         | 检查传入的文件名称是否正确， 是否符合要求。                           |
| 400 | DBS.280365 | Invalid payment mode.                                                                                                                             | 非法的付费模式                         | 检查付费模式是否正确，是否符合要求。                               |
| 400 | DBS.280366 | Invalid order ID.                                                                                                                                 | 非法的订单号                          | 检查包周期订单号是否传入，是否符合要求。                             |
| 400 | DBS.280404 | Invalid DB instance ID.                                                                                                                           | 非法的实例ID                         | 检查实例ID是否正确，是否符合要求。                               |
| 403 | DBS.280406 | The DB instance cannot be deleted.                                                                                                                | 不允许删除实例                         | 检查实例引擎和计费方式是否支持直接删除实例。                           |
| 400 | DBS.280407 | Invalid node ID.                                                                                                                                  | 非法的节点ID                         | 检查节点ID是否正确，是否符合要求。                               |
| 400 | DBS.280408 | Invalid project id.                                                                                                                               | 非法的租户ID                         | 检查租户ID是否正确，是否符合要求。                               |
| 400 | DBS.280409 | Invalid date.                                                                                                                                     | 非法的时间格式                         | 检查时间格式、内容是否正确，是否符合要求。                            |
| 400 | DBS.280414 | Invalid group type.                                                                                                                               | 非法的组类型                          | 检查组类型是否正确，是否符合要求，组类型与实例是否匹配，组类型与组ID是否匹配。         |
| 400 | DBS.280416 | Invalid backup end time.                                                                                                                          | 结束时间非法                          | 检查是否缺失结束时间，检查结束时间周期、格式是否满足要求。                    |
| 400 | DBS.280421 | Invalid EIP.                                                                                                                                      | 弹性IP非法                          | 检查弹性IP是否存在，是否符合要求。                               |
| 400 | DBS.280431 | Invalid package type.                                                                                                                             | 不合法的包周期类型                       | 检查参数"period_type"是否符合要求。                         |
| 400 | DBS.280432 | Invalid duration for yearly/monthly DB instances.                                                                                                 | 不合法的包周期时长                       | 检查参数"period_num"值是否符合要求。                         |
| 403 | DBS.280433 | Invalid enterprise project ID.                                                                                                                    | 企业项目ID无效                        | 检查企业项目ID是否符合要求。                                  |
| 400 | DBS.280434 | The specifications are unavailable.                                                                                                               | 资源规格编码无效                        | 检查资源规格编码是否存在，是否符合要求。                             |
| 400 | DBS.280437 | Not support enterprise project.                                                                                                                   | 不支持企业多项目                        | 当前用户尚未开通企业多项目服务，请开启企业多项目服务或不传入相关参数。              |
| 400 | DBS.280438 | Invalid encryption key.                                                                                                                           | 磁盘加密密钥ID无效                      | 检查请求中的磁盘加密密钥ID是否已经创建并且状态可用，当前引擎是否支持磁盘加密。         |
| 400 | DBS.280439 | Invalid limit.                                                                                                                                    | 限制查询数量不正确                       | 检查参数"limit"值设置是否符合要求。                            |
| 400 | DBS.280440 | Invalid offset.                                                                                                                                   | 偏移量不正确                          | 检查参数"offset"值设置是否符合要求。                           |
| 400 | DBS.280441 | Invalid key.                                                                                                                                      | 标签key无效                         | 检查标签key是否符合要求。                                   |
| 429 | DBS.280443 | The maximum number of connections has been reached.                                                                                               | 超出最大连接数                         | 同一租户调用接口请求过于频繁，请降低频率。                            |
| 400 | DBS.280445 | The DB instance class is not available.                                                                                                           | 实例规格不可用                         | 当前实例规格不可用，请更换为其他规格。                              |
| 400 | DBS.280446 | The database information does not exist.                                                                                                          | 数据库信息不存在                        | 检查"datastore"字段是否存在。                             |
| 400 | DBS.280453 | Invalid DSS storage pool ID.                                                                                                                      | 专属存储池ID无效                       | 检查专属存储池ID是否正确。                                   |
| 400 | DBS.280456 | This operation is not supported by the current billing mode.                                                                                      | 当前计费模式不支持该操作                    | 检查当前实例的计费模式， 是否符合接口要求。                           |
| 400 | DBS.280469 | Invalid ECS group policy.                                                                                                                         | 非法的云服务器组关联策略                    | 检查云服务器组关联策略是否正确。                                 |
| 400 | DBS.280482 | Invalid user tag key.                                                                                                                             | 无效的用户标签key                      | 检查tag的key是否有效。                                   |
| 400 | DBS.280483 | Invalid tag value.                                                                                                                                | 无效的标签value                      | 检查tag的value是否有效。                                 |
| 400 | DBS.280484 | Tag number reach limit.                                                                                                                           | tag数量过多                         | 检查tag数量是否正确。                                     |
| 400 | DBS.290000 | Parameter error!                                                                                                                                  | 参数错误                            | 检查传入的参数或URL是否全部正确，是否符合要求。                        |
| 400 | DBS.301024 | Invalid backup restore information.                                                                                                               | 无效的备份恢复信息                       | 检查备份恢复信息是否合法。                                    |
| 400 | DBS.301071 | Invalid session id.                                                                                                                               | 非法会话ID                          | 检查会话ID是否正确，是否符合要求。                               |
| 400 | DBS.301072 | Invalid plan summary.                                                                                                                             | 非法执行计划                          | 检查执行计划是否正确，是否符合要求。                               |
| 400 | DBS.301073 | Invalid operation type.                                                                                                                           | 非法操作类型                          | 检查操作类型是否正确，是否符合要求。                               |
| 400 | DBS.301074 | Invalid namespace.                                                                                                                                | 非法命名空间                          | 检查命名空间是否正确，是否符合要求。                               |
| 400 | DBS.301075 | Invalid cost time.                                                                                                                                | 非法执行时间                          | 检查执行时间是否正确，是否符合要求。                               |
| 400 | DBS.301076 | Query session failed.                                                                                                                             | 查询会话失败                          | 检查实例状态，请联系客服处理。                                  |
| 400 | DBS.301077 | Kill session failed.                                                                                                                              | 终结会话失败                          | 检查实例状态，请联系客服处理。                                  |
| 400 | DBS.301079 | Query OS version failed.                                                                                                                          | 查询操作系统版本失败                      | 请联系客服处理。                                         |
   
