
# 错误码
调用接口出错后，将不会返回结果数据。调用方可根据每个接口对应的错误码来定位错误原因。 当调用出错时，HTTP请求返回一个HTTP状态码。返回的消息体中是具体的错误编码及错误描述信息。
当您调用API时，如果遇到"APIGW"开头的错误码，请参见[API网关错误码](https://support.huaweicloud.com/devg-apisign/api-sign-errorcode.html)进行处理。
| 状态码 | 错误码        | 错误信息                                                                                              | 描述                           | 解决方案                         |
|:---|:---|:---|:---|:---|
| 400 | DAS.200002 | Frequent requests.                                                                                | 请求频繁。                        | 请稍后再试。                       |
| 400 | DAS.200100 | The parameter is invalid.                                                                         | 参数错误。                        | 请检查参数是否正确。                   |
| 400 | DAS.200101 | The start_at parameter is invalid.                                                                | start_at参数错误。                | 请检查参数是否正确。                   |
| 400 | DAS.200102 | The end_at parameter is invalid.                                                                  | end_at参数错误。                  | 请检查参数是否正确。                   |
| 400 | DAS.200103 | The offset parameter is invalid.                                                                  | offset参数错误。                  | 请检查参数是否正确。                   |
| 400 | DAS.200104 | The limit parameter is invalid.                                                                   | limit参数错误。                   | 请检查参数是否正确。                   |
| 400 | DAS.200105 | The order parameter is invalid.                                                                   | order参数错误。                   | 请检查参数是否正确。                   |
| 400 | DAS.200106 | The order_by parameter is invalid.                                                                | order_by参数错误。                | 请检查参数是否正确。                   |
| 400 | DAS.200107 | The datastore_type is invalid.                                                                    | datastore_type参数错误。          | 请检查参数是否正确。                   |
| 400 | DAS.200108 | The database value is invalid!                                                                    | database参数错误。                | 请检查参数是否正确。                   |
| 400 | DAS.200109 | The script value is invalid!                                                                      | script参数错误。                  | 请检查参数是否正确。                   |
| 400 | DAS.200110 | The lock_status value is invalid!                                                                 | lock_status参数无效。             | 请检查参数是否正确。                   |
| 400 | DAS.200111 | The lock_type value is invalid!                                                                   | lock_type参数错误。               | 请检查参数是否正确。                   |
| 400 | DAS.200112 | The db_user_id value is invalid!                                                                  | db_user_id参数错误。              | 请检查参数是否正确。                   |
| 400 | DAS.200113 | The project_id parameter is invalid.                                                              | project_id参数错误。              | 请检查参数是否正确。                   |
| 400 | DAS.200114 | The instance_id parameter is invalid.                                                             | instance_id参数错误。             | 请检查参数是否正确。                   |
| 400 | DAS.200115 | The parameter of DeleteProcess is invalid!                                                        | 查杀会话参数错误。                    | 请检查参数是否正确。                   |
| 400 | DAS.200116 | The type parameter is invalid.                                                                    | type参数错误。                    | 请检查参数是否正确。                   |
| 400 | DAS.200117 | The status parameter is invalid.                                                                  | status参数错误                   | 请检查参数是否正确。                   |
| 400 | DAS.200118 | The retention_days parameter is invalid.                                                          | retention_days参数错误           | 请检查参数是否正确。                   |
| 400 | DAS.200119 | The object_type parameter is invalid.                                                             | object_type参数错误。             | 请检查参数是否正确。                   |
| 400 | DAS.200120 | This API is only available for paid instances.                                                    | 该API仅对付费实例可用。                | 请购买云DBA收费版并将当前实例设置为付费实例。     |
| 400 | DAS.200121 | The marker is only valid for three minutes. If the expiration time is exceeded, please re export. | marker仅三分钟内有效，如超过有效时间，请重新导出。 | 请重新导出。                       |
| 400 | DAS.220002 | Failed to connect to the database.                                                                | 连接数据库异常。                     | 请确认实例是否正常，数据库用户名和密码是否正确。     |
| 400 | DAS.220003 | The database user does not exist.                                                                 | 数据库用户不存在。                    | 请检查参数是否正确。                   |
| 400 | DAS.220004 | The database user already exists.                                                                 | 数据库用户已存在。                    | 请检查数据库用户是否已经存在。              |
| 400 | DAS.220029 | Failed to operate the SQL limit switch.                                                           | 操作SQL限流开关失败。                 | 请根据error_msg提供的具体信息进行处理。     |
| 400 | DAS.220030 | Failed to operate the SQL limit rules.                                                            | 操作SQL限流规则失败。                 | 请根据error_msg提供的具体信息进行处理。     |
| 403 | DAS.200050 | Invalid token.                                                                                    | token不合法。                    | 请检查token是否正确，或者重新获取token后再试。 |
| 403 | DAS.200051 | Authentication failed.                                                                            | 鉴权失败。                        | 请检查是否有权限。                    |
| 500 | DAS.200001 | Internal service error.                                                                           | 内部服务异常。                      | 请联系客服处理。                     |
| 500 | DAS.200003 | Internal service invoking error.                                                                  | 内部服务调用异常。                    | 请联系客服处理。                     |
| 500 | DAS.220005 | Failed to kill process.                                                                           | kill会话失败。                    | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220006 | Failed to Query Metadata Locks.                                                                   | 查询元数据锁失败。                    | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220007 | Failed to query InnoDB locks.                                                                     | 查询InnoDB锁等待失败。               | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220008 | Failed to query process list.                                                                     | 查询实例会话失败。                    | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220009 | Failed to query SQL execution plan.                                                               | 查询SQL执行计划失败。                 | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220010 | Failed to list slow query logs.                                                                   | 获取慢SQL明细失败。                  | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220011 | Failed to list SQL statements.                                                                    | 获取全量SQL失败                    | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220012 | Failed to enable/disable DAS SQL explorer.                                                        | 开启/关闭DAS收集全量SQL失败            | 请重试。                         |
| 500 | DAS.220013 | Failed to enable/disable DAS Slow Query Log.                                                      | 开启/关闭DAS收集慢日志失败              | 请重试。                         |
| 500 | DAS.220014 | Failed to query the status.                                                                       | 查询开关开启状态失败                   | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220015 | Failed to query space analysis data.                                                              | 查询空间分析数据失败。                  | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220016 | Failed to execute the space analysis task.                                                        | 执行空间分析任务失败。                  | 请检查此实例是否已经录入数据库账号。           |
| 500 | DAS.220017 | The switch is not enabled.                                                                        | DAS收集日志的开关未打开。               | 请打开开关。                       |
| 500 | DAS.220065 | Failed to turn on/off the DAS transaction switch.                                                 | DAS开启/关闭历史事务开关失败。            | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220066 | Failed to query the DAS historical transaction switch.                                            | DAS查询历史事务开关状态失败。             | 请根据error_msg提供的具体信息进行处理。     |
| 500 | DAS.220067 | Failed to query the DAS historical transaction list.                                              | DAS查询历史事务列表失败。               | 请根据error_msg提供的具体信息进行处理。     |
   
