
# 错误码
当您调用API时，如果遇到"APIGW"开头的错误码，请参见[API网关错误码](https://support.huaweicloud.com/devg-apisign/api-sign-errorcode.html)进行处理。
| 状态码 | 错误码          | 错误信息                                                                                                                                    | 描述                             | 处理措施                                               |
|:---|:---|:---|:---|:---|
| 200 | CDN.0005     | The upper limit is exceeded.                                                                                                            | 超出最大限制。                        | 请按配额合理规划操作，或提工单申请扩大配额。                             |
| 200 | CDN.0015     | Service area not supported.                                                                                                             | 不支持当前服务范围。                     | /                                                  |
| 200 | CDN.0016     | This service type is not supported.                                                                                                     | 不支持的业务类型。                      | 请输入正确的业务类型。                                        |
| 200 | CDN.0101     | The acceleration domain name already exists.                                                                                            | 加速域名已经添加。                      | 请提交工单处理。                                           |
| 200 | CDN.0102     | The domain name has not been filed or the filing has expired.                                                                           | 加速域名审核失败。                      | 请在工信部为加速域名备案。                                      |
| 200 | CDN.0103     | Information about the origin server format is incorrect.                                                                                | 源站审核失败。                        | 请在工信部为源站域备案。                                       |
| 200 | CDN.0104     | The number of acceleration domain names has reached the upper limit.                                                                    | 加速域名已达到上限。                     | 请提交工单申请扩大域名配额。                                     |
| 200 | CDN.0105     | The acceleration domain name does not exist.                                                                                            | 加速域名不存在。                       | 请确认操作域名是否正确，如确认正确请提交工单处理。                          |
| 200 | CDN.0106     | This operation is not supported by the domain name in the current state.                                                                | 当前域名状态无法操作。                    | 请检查域名是否被封禁、锁定或域名状态是否支持当前操作（如：未在启用状态下的域名不可执行停用操作）。  |
| 200 | CDN.0107     | The retrieval host failed the audit.                                                                                                    | 回源host审核失败。                    | 请在工信部为回源host域名备案。                                  |
| 200 | CDN.0108     | The URL domain name is not the acceleration domain name of the current tenant.                                                          | 域名不属于当前租户。                     | 请确认操作域名是否正确，如确认正确请提交工单处理。                          |
| 200 | CDN.0109     | The domain name of the origin server must be different from the acceleration domain name.                                               | 源站域名不能与加速域名相同。                 | 源站域名不能与加速域名相同，需要调整加速域名。                            |
| 200 | CDN.0110     | The number of URLs to be preheated or refreshed exceeds the upper limit.                                                                | URL数超出预热刷新限制。                  | 请提交工单申请扩大刷新预热配额。                                   |
| 200 | CDN.0114     | The billing mode has not been configured.                                                                                               | CDN服务未开通。                      | 请前往CDN服务界面选择计费模式并开通CDN服务。                          |
| 200 | CDN.0115     | Acceleration domain names are prohibited.                                                                                               | 域名已被封禁。                        | 请提交工单申请解封。                                         |
| 200 | CDN.0116     | Acceleration domain names are locked.                                                                                                   | 域名已被锁定。                        | 请提交工单申请取消锁定。                                       |
| 200 | CDN.0117     | If the retrieval host is set to an origin server domain name, the origin server cannot be an IP address.                                | 源站域名为回源HOST，源站不能为IP地址形式。       | 请修改源站接入形式。                                         |
| 200 | CDN.0120     | The domain name has been added by another user.                                                                                         | 域名已被其他用户添加。                    | 请提交工单处理。                                           |
| 200 | CDN.0121     | The IP address must not be an internal network IP address.                                                                              | 输入的IP不能是内网IP。                  | IP不能是内网IP地址，请检查填写的IP地址类型。                          |
| 200 | CDN.0126     | Only domain names that are disabled or fail to be configured, audited, or synchronized can be deleted.                                  | 仅停用，配置失败，审核失败，同步失败的域名才可进行删除操作。 | 请检查域名状态是否为停用、配置失败、审核失败或同步失败，其他状态无法删除。              |
| 200 | CDN.0127     | The domain name format is incorrect.                                                                                                    | 域名格式错误。                        | 请填写正确格式的域名。                                        |
| 200 | CDN.0128     | The service type is incorrect.                                                                                                          | 业务类型错误。                        | 请根据接口文档填写正确的业务类型。                                  |
| 200 | CDN.0129     | The origin type is incorrect.                                                                                                           | 源站类型错误。                        | 请根据接口文档填写正确的源站类型。                                  |
| 200 | CDN.0130     | The number of origin server IP addresses exceeds the upper limit.                                                                       | 源站IP个数超出限制。                    | 请检查输入的IP是否超出数量限制。                                  |
| 200 | CDN.0131     | The number of origin server domain names exceeds the upper limit.                                                                       | 源站域名个数超出限制。                    | 请检查输入的源站域名个数是否超出数量限制。                              |
| 200 | CDN.0132     | The retrieval host type is incorrect.                                                                                                   | 回源Host类型错误                     | 请根据接口文档填写正确的回源host类型                               |
| 200 | CDN.0133     | The retrieval host is incorrect.                                                                                                        | 回源host错误。                      | 请根据接口文档填写正确格式的回源host。                              |
| 200 | CDN.0134     | The weight of cache rules must be an integer from 1 to 100.                                                                             | 缓存规则的权重应为1到100之间的整数。           | 请输入1-100的整数。                                       |
| 200 | CDN.0135     | The cache rule type is incorrect.                                                                                                       | 缓存规则类型错误。                      | 请根据接口文档查看CDN支持的缓存规则类型。                             |
| 200 | CDN.0136     | The time range must fall within 0 to 365 days.                                                                                          | 时间范围必须在0到365天内。                | 请输入0-365天。                                         |
| 200 | CDN.0137     | The cache rule format is invalid.                                                                                                       | 缓存过期规则设置格式不合法。                 | 请根据接口文档查看CDN支持的缓存规则格式。                             |
| 200 | CDN.0138     | The anti-leeching URL type is incorrect.                                                                                                | 防盗链类型错误。                       | 请根据接口文档填写CDN支持的防盗链类型。                              |
| 200 | CDN.0139     | The number of anti-leeching domain names must range from 1 to 100.                                                                      | 防盗链域名数量必须在1\~100之间。            | 请输入1-100个防盗链域名。                                    |
| 200 | CDN.0141     | The domain name is not filed with the Ministry of Industry and Information Technology of the People's Republic of China.                | 域名未备案。                         | 加速域名未备案。                                           |
| 200 | CDN.0142     | Https not support yet.                                                                                                                  | 不支持https协议。                    | /                                                  |
| 200 | CDN.0143     | The ownership of the domain name is not verified.                                                                                       | 泛域名所有权未验证。                     | 请检查创建的泛域名是否与已有域名冲突或提交工单联系运维处理。                     |
| 200 | CDN.0145     | Only domain names in the Enabled state and that are not banned or locked in the background support this operation.                      | 只有处于已开启状态的域名才可执行此操作。           | 请检查域名是否处于启用状态。                                     |
| 200 | CDN.0147     | The origin is an OBS domain name. Retrieval host cannot be modified.                                                                    | OBS桶做为源站，不能修改回源host。           | /                                                  |
| 200 | CDN.0148     | The origin is an OBS domain name. Standby origin cannot be configured.                                                                  | OBS桶做源站，不能添加备源站。               | /                                                  |
| 200 | CDN.0149     | Not allowed because the domain name is in a shared cache group.                                                                         | 不支持删除共享缓存组主域名。                 | /                                                  |
| 200 | CDN.0156     | \*\*\*\*, source is illegal.                                                                                                            | 源站无效                           | 更换有效源站。                                            |
| 200 | CDN.0163     | The domain has special config. Please contact CDN operators to change.                                                                  | 域名有特殊配置。                       | 请联系CDN管理员修改。                                       |
| 200 | CDN.0201     | Domain name error.                                                                                                                      | 域名错误。                          | 加速域名无效或不存在，请刷新页面检查域名是否在域名列表中，如果仍有问题，请提交工单处理。       |
| 200 | CDN.0202     | Statistical time error.                                                                                                                 | 统计时间错误。                        | 请按接口文档检查统计开始时间、结束时间是否正确，如查询范围超限、开始时间大于结束时间、时间为负数等。 |
| 200 | CDN.0203     | Sampling interval error.                                                                                                                | 采样间隔错误。                        | 请检查采样间隔是否与时间跨度匹配。                                  |
| 200 | CDN.0401     | Certificates are deleted mistakenly.                                                                                                    | 证书删除错误。                        | 请提交工单处理。                                           |
| 200 | CDN.0402     | The certificate or private key cannot be left blank.                                                                                    | 证书或私钥不能为空。                     | 请检查是否输入了证书或私钥。                                     |
| 200 | CDN.0403     | The certificate must be in the PEM format.                                                                                              | 证书格式需要为pem。                    | 请检查证书格式是否为PEM格式。                                   |
| 200 | CDN.0404     | The private key format must be in the PEM format.                                                                                       | 私钥格式需要为pem。                    | 请检查私钥格式是否为PEM格式。                                   |
| 200 | CDN.0405     | The certificate and private key do not match.                                                                                           | 证书与私钥不匹配。                      | 请检查证书是否与私钥配对。                                      |
| 200 | CDN.0406     | The certificate and domain name do not match.                                                                                           | 证书与域名不匹配。                      | 请检查证书是否与加速域名配对。                                    |
| 200 | CDN.0407     | Certificate error.                                                                                                                      | 证书错误。                          | 请提交工单处理。                                           |
| 200 | CDN.0408     | The certificate has expired.                                                                                                            | 证书已过期。                         | 请更新证书链中的证书。                                        |
| 200 | CDN.0409     | The certificate will expire in less than 24 hours.                                                                                      | 证书剩余有效期不足24小时。                 | 请更新证书链中的证书。                                        |
| 200 | CDN.0410     | The certificate chain cannot be supplemented.                                                                                           | 证书链无法补齐。                       | 请补齐证书链。                                            |
| 200 | CDN.0411     | The certificate status is incorrect.                                                                                                    | 证书状态不正确。                       | 请提交工单处理。                                           |
| 200 | CDN.0412     | The length of the certificate or private key content exceeds the upper limit.                                                           | 证书或私钥内容长度超出限制。                 | 请查看CDN资料查看证书支持长度。                                  |
| 200 | CDN.0413     | The certificate not yet valid.                                                                                                          | 证书还未生效。                        | 请提交工单处理。                                           |
| 200 | CDN.0414     | Invalid private key format of the certificate. Only RSA format is supported.                                                            | 证书私钥错误。                        | 请提交工单处理。                                           |
| 400 | CDN.0001     | Parameter error.                                                                                                                        | 参数格式错误（格式错误或者缺失参数）。            | 请根据接口文档核对并纠正错误参数。                                  |
| 400 | CDN.00010177 | Failed to add a domain name whose service area covers Chinese mainland because your account has not completed real-name authentication. | 账号未实名认证。                       | 实名认证后重新添加。                                         |
| 400 | CDN.00010178 | Domain name restricted. Submit a service ticket.                                                                                        | 待添加的域名受限。                      | 请提交工单处理。                                           |
| 400 | CDN.00010179 | Wildcard domain names cannot be added as origin servers.                                                                                | 源站错误。                          | 不支持泛域名作为源站，请更换源站域名后重新添加。                           |
| 400 | CDN.00010180 | The origin server cannot be a subdomain of a wildcard domain.                                                                           | 源站错误。                          | 您已添加泛域名作为加速域名，不可用该泛域名的子域名作为源站，请更换源站域名后重新添加。        |
| 400 | CDN.00010183 | Not allowed because the domain name has shared settings.                                                                                | 不支持删除共享配置组主域名。                 | /                                                  |
| 400 | CDN.00010185 | Domain owner verify failed.                                                                                                             | 域名归属验证失败。                      | /                                                  |
| 401 | CDN.0002     | Unauthenticated user.                                                                                                                   | 用户未鉴权。                         | 请携带正确的鉴权信息。                                        |
| 403 | CDN.00010181 | No enterprise projects available.                                                                                                       | 错误的企业项目。                       | 请确认当前账号是否已开通企业项目。                                  |
| 403 | CDN.00010182 | Resource does not belong to this enterprise project.                                                                                    | 域名不在当前企业项目中。                   | 请确认域名归属的企业项目后重新执行该操作。                              |
| 403 | CDN.00010198 | Insufficient permission to access scm.                                                                                                  | 账号访问SCM委托权限不足。                 | 账号未开通SCM委托，请开通后重试。                                 |
| 403 | CDN.0004     | Insufficient permission.                                                                                                                | 用户权限不足。                        | 请检查是否拥有操作权限。如没有，请获取相应操作权限；如有，请提交工单处理。              |
| 403 | CDN.0019     | Operation not allowed.                                                                                                                  | 不支持当前操作。                       | /                                                  |
| 403 | CDN.0020     | The user is not authorized to the enterprise project.                                                                                   | 对应用户无该企业项目授权。                  | 请先获取企业项目授权。                                        |
| 403 | CDN.0021     | The user does not have operation permissions because the fine-grained authentication is not passed.                                     | 对应用户细粒度鉴权不通过，无操作权限。            | 请先获取细粒度鉴权。                                         |
| 404 | CDN.0003     | The object does not exist.                                                                                                              | 对象不存在。                         | 请确定操作的对象存在。                                        |
| 500 | CDN.0000     | System error.                                                                                                                           | 系统内部错误。                        | 请提交工单处理。                                           |
   
