
# 错误码
更多服务错误码请参见[API错误中心](https://apierrorcenter.developer.huaweicloud.com/apierrorcenter)。
| 状态码 | 错误码      | 错误信息                                                                                                                              | 描述                             | 处理措施                           |
|:---|:---|:---|:---|:---|
| 400 | SCM.0003 | Tenant has no privilege.                                                                                                          | 租户无法操作不属于自己的证书                 | 请操作自己的证书                       |
| 400 | SCM.0005 | Incorrect request parameter.                                                                                                      | 请求参数错误                         | 请填写正确的请求参数                     |
| 400 | SCM.0006 | The uploaded certificate failed to be resolved. Ensure that the uploaded certificate has been issued.                             | 上传证书解析不正确                      | 请上传已签发的证书                      |
| 400 | SCM.0008 | Abnormal certificate ID                                                                                                           | 证书编号异常                         | 请填写正确的证书编号                     |
| 400 | SCM.0009 | Failed to upload the certificate because no domain name is bound to the certificate.                                              | 证书未绑定域名，上传失败                   | 请传递已绑定域名的证书                    |
| 400 | SCM.0010 | This operation is not allowed by the current certificate type or status.                                                          | 证书类型或当前状态不支持此操作                | 请传递证书的证书类型或者选择证书状态的证书进行此操作     |
| 400 | SCM.0011 | The max number of free certificates for the current user has been reached, and you cannot continue to purchase free certificates. | 当前用户证书数量已经达到最大值,不能继续添加         | 请不要继续添加证书                      |
| 400 | SCM.0012 | The uploaded private key failed to be resolved. Ensure that the certificate has been issued.                                      | 上传私钥解析不正确，请确保填写已签发证书           | 请填写正确的证书私钥                     |
| 400 | SCM.0014 | The uploaded certificate does not match the private key.                                                                          | 上传证书和私钥不匹配                     | 请传递正确的证书和私钥                    |
| 400 | SCM.0015 | The number or format of domain names entered does not meet the requirements of the your certificate.                              | 填写域名数量或格式与所购买证书要求不一致           | 请上传单域名和泛域名证书                   |
| 400 | SCM.0016 | Failed to order.                                                                                                                  | 订单异常                           | 请联系技术支持                        |
| 400 | SCM.0020 | Incorrect certificate ID.                                                                                                         | 证书ID错误                         | 请传递正确的证书编号                     |
| 400 | SCM.0023 | Modify key format error.                                                                                                          | 修改键错误                          | 请输入不为空的键                       |
| 400 | SCM.0024 | Modify value format error.                                                                                                        | 修改内容错误                         | 请输入不为空的值                       |
| 400 | SCM.0025 | Exceed the limit                                                                                                                  | 超出限额                           | 证书超出重签时效                       |
| 400 | SCM.0026 | Revoke cert error                                                                                                                 | 证书吊销异常                         | 请联系技术支持                        |
| 400 | SCM.0027 | Have no revoke reason                                                                                                             | 吊销原因未填写                        | 请输入吊销原因                        |
| 400 | SCM.0028 | Push cert error                                                                                                                   | 证书推送异常                         | 请联系技术支持                        |
| 400 | SCM.0030 | Certificates cannot be pushed to this service.                                                                                    | 暂不支持的推送服务类型                    | 请填写正确的推送服务                     |
| 400 | SCM.0031 | Certificate parsing error.                                                                                                        | 证书解析异常                         | 请上传正确的证书                       |
| 400 | SCM.0032 | Incorrect certificate name.                                                                                                       | 证书名称错误                         | 请填写正确的证书名称                     |
| 400 | SCM.0033 | Csr not bind domain.                                                                                                              | CSR未绑定域名                       | 请输入包含域名的csr                    |
| 400 | SCM.0034 | Csr parse error.                                                                                                                  | CSR解析异常                        | 请输入合法的csr                      |
| 400 | SCM.0035 | Csr domain not match input domain.                                                                                                | CSR域名与输入域名不匹配                  | 请保持域名一致                        |
| 400 | SCM.0036 | Domain number not match product.                                                                                                  | 域名数量与产品不匹配                     | 请输入正确数量的域名                     |
| 400 | SCM.0039 | The updated quota value must be greater than the currently used quota.                                                            | 更新的配额数值必须大于当前已使用的配额数量          | 请输入正确的配额数值                     |
| 400 | SCM.0042 | Cert has expired.                                                                                                                 | 证书已过期                          | 请不要上传已过期的证书                    |
| 400 | SCM.0044 | Permission denied,please obtain {0} permission.                                                                                   | 权限不足,请先获取{0}权限                 | 请先获取权限                         |
| 400 | SCM.0049 | Cert brand error.                                                                                                                 | 证书品牌异常                         | 请输入证书品牌                        |
| 400 | SCM.0050 | Cert type error.                                                                                                                  | 证书类型异常                         | 请输入正确的证书类型                     |
| 400 | SCM.0051 | Domain type error.                                                                                                                | 域名类型异常                         | 请输入正确的域名类型                     |
| 400 | SCM.0052 | Cert effective time error.                                                                                                        | 证书有效期异常                        | 请输入正确的证书                       |
| 400 | SCM.0059 | The certificate private key is empty.                                                                                             | 证书私钥为空                         | 请联系客服处理                        |
| 400 | SCM.0060 | Order number error.                                                                                                               | 订单数量异常                         | 请输入正确的订单数量                     |
| 400 | SCM.0061 | Region parameter error.                                                                                                           | region参数异常                     | 请输入正确的region                   |
| 400 | SCM.0063 | Duplicate domain error.                                                                                                           | 域名重复                           | 请输入不重复的域名                      |
| 400 | SCM.0064 | The order is executing.                                                                                                           | 订单正在处理中                        | 请不要重复下单                        |
| 400 | SCM.0065 | File size exceeds limit.                                                                                                          | 文件大小超过限制                       | 请输入正确大小的文件                     |
| 400 | SCM.0066 | Current domain type not allowed to operate.                                                                                       | 证书域名类型不支持当前操作                  | 请联系客服处理                        |
| 400 | SCM.0067 | Sans changed.                                                                                                                     | 已有附加域名被修改                      | 请输入正确的附加域名                     |
| 400 | SCM.0068 | Unsupported region.                                                                                                               | 暂不支持推送到该Region                 | 请联系技术支持                        |
| 400 | SCM.0070 | Incorrect format of the domain bound to the certificate to be uploaded.                                                           | 上传证书域名格式错误                     | 请传递正确证书                        |
| 400 | SCM.0072 | SCM does not support this status.                                                                                                 | SCM暂不支持的操作类型                   | 请联系技术支持                        |
| 400 | SCM.0073 | Help content format error.                                                                                                        | 求助内容错误                         | 请输入正确的邮件内容                     |
| 400 | SCM.0074 | Cert is not renewal paid.                                                                                                         | 证书不是已续费状态                      | 请联系技术支持                        |
| 400 | SCM.0075 | Invalid region id.                                                                                                                | 无效的region id                   | 请输入合法的region id                |
| 400 | SCM.0076 | DIGICERT DV basic not support to renew.                                                                                           | DIGICERT DV basic证书不支持续费       | 请联系客服处理                        |
| 400 | SCM.0079 | Subject of CaCert not match issuer of Cert                                                                                        | CaCert的主题与证书的签发者不匹配            | 请联系技术支持                        |
| 400 | SCM.0080 | Required param cert_info is null or empty.                                                                                        | 必填请求参数cert_info为空              | 请输入非空的证书信息                     |
| 400 | SCM.0081 | Required param cert_info is null or empty.                                                                                        | 必填请求参数cert_info为空              | 请输入非空的证书信息                     |
| 400 | SCM.0082 | Invalid validity_period, should be 12.                                                                                            | 无效参数validity_period，必须为12      | 请输入合法的属性                       |
| 400 | SCM.0083 | Required param first_name is null or empty.                                                                                       | 必填请求参数first_name为空             | 请输入不为空的属性                      |
| 400 | SCM.0085 | Required param phone is null or empty.                                                                                            | 必填请求参数phone为空                  | 请输入不为空的属性                      |
| 400 | SCM.0086 | Required param email is null or empty.                                                                                            | 必填请求参数email为空                  | 请输入不为空的属性                      |
| 400 | SCM.0095 | Run RmsApiController failed.                                                                                                      | 请求有误，调用接口时报                    | 请联系技术支持                        |
| 400 | SCM.0101 | The cert not support to auto deploy.                                                                                              | 该证书不支持资源到期自动替换                 | 请联系客服处理                        |
| 400 | SCM.0102 | This resource has been open to auto deploy.                                                                                       | 资源已开启到期自动替换                    | 请不要重复操作                        |
| 400 | SCM.0103 | This resource is not exist.                                                                                                       | 资源不存在                          | 请不要操作不存在的资源                    |
| 400 | SCM.0104 | This region is not support.                                                                                                       | 不支持的region                     | 请不要操作不支持的region                |
| 400 | SCM.0105 | The cert has associated the auto deployed resources.                                                                              | 证书关联到开启到期自动替换资源，请先关闭所有到期自动替换资源 | 请联系客服处理                        |
| 400 | SCM.0106 | The resource domain is not equals the cert.                                                                                       | 资源域名与证书域名不匹配                   | 请输入正确的域名                       |
| 400 | SCM.0108 | Domain format is invalid.                                                                                                         | 域名格式非法                         | 请输入正确的域名                       |
| 400 | SCM.0109 | Cert chain length must be more than 1.                                                                                            | 证书链长度必须大于1                     | 请联系技术支持                        |
| 400 | SCM.0201 | Failed to push to ELB.                                                                                                            | 推送失败，ELB error message：        | 请联系客服处理                        |
| 400 | SCM.0202 | Insufficient ELB permissions                                                                                                      | ELB权限不足                        | 请配置ELB权限                       |
| 400 | SCM.0204 | ELB does not support this region.                                                                                                 | ELB暂不支持此region                 | 请选择其他支持的region                 |
| 400 | SCM.0211 | Failed to push to CDN.                                                                                                            | 推送失败，CDN error message：        | 请联系客服处理                        |
| 400 | SCM.0212 | Insufficient CDN permissions                                                                                                      | CDN权限不足                        | 请配置CND权限                       |
| 400 | SCM.0221 | Failed to push to WAF.                                                                                                            | 推送失败，WAF error message：        | 请联系客服处理                        |
| 400 | SCM.0222 | Insufficient WAF permissions                                                                                                      | WAF权限不足                        | 请配置WAF权限                       |
| 400 | SCM.0224 | WAF does not support this region.                                                                                                 | WAF暂不支持此region                 | 请选择其他支持的region                 |
| 400 | SCM.0225 | Insufficient WAF quota.                                                                                                           | WAF配额不足                        | 请联系客服处理                        |
| 400 | SCM.0301 | Tag is not found.                                                                                                                 | 标签未找到                          | 请联系客服处理                        |
| 400 | SCM.0302 | Tag quota is upper limit.                                                                                                         | 标签配额达到上限                       | 请不要添加标签                        |
| 400 | SCM.0303 | Match tag invalid.                                                                                                                | 标签匹配错误                         | 请添加合法标签                        |
| 400 | SCM.0304 | Field action is error.                                                                                                            | action字段有误                     | 请联系客服处理                        |
| 400 | SCM.0305 | Tag value is invalid.                                                                                                             | 标签值非法                          | 请输入合法的标签值                      |
| 400 | SCM.0306 | Tag key is invalid.                                                                                                               | 标签键非法                          | 请输入合法的标签键                      |
| 400 | SCM.0309 | Tag value length is invalid.                                                                                                      | 标签值长度非法                        | 请输入长度合法的标签值                    |
| 400 | SCM.0310 | Tag key length is invalid.                                                                                                        | 标签键长度非法                        | 请输入长度合法的标签键                    |
| 400 | SCM.0311 | Tag key list is invalid.                                                                                                          | 标签键列表非法                        | 请输入合法的标签键列表                    |
| 400 | SCM.0312 | Tag value list is invalid.                                                                                                        | 标签值列表非法                        | 请输入合法的标签值列表                    |
| 400 | SCM.0313 | Tag list is invalid.                                                                                                              | 标签列表非法                         | 请输入合法的标签列表                     |
| 400 | SCM.0314 | Match resourceId invalid.                                                                                                         | 匹配错误                           | 请联系客服处理                        |
| 400 | SCM.0318 | Tag limit invalid.                                                                                                                | 标签查询limit参数非法                  | 请输入合法的参数                       |
| 400 | SCM.0319 | Tag offset invalid.                                                                                                               | 标签查询offset参数非法                 | 请输入合法的参数                       |
| 400 | SCM.0321 | Invalid param sys_tags.                                                                                                           | 参数sys_tags错误                   | 请输入合法的参数                       |
| 400 | SCM.0323 | Invalid tag parameter.                                                                                                            | 不合法的标签参数                       | 请输入合法的参数                       |
| 400 | SCM.0401 | Gm cert is not support to be pushed.                                                                                              | 不支持推送国密证书                      | 请联系技术支持                        |
| 400 | SCM.0501 | The parameter cannot be null or the parameter is wrong. Currently only supports:                                                  | 参数不可为空或者参数错误，目前仅支持：            | 目前仅支持WAF/CDN/ELB               |
| 400 | SCM.0502 | The certificate ID list cannot be empty.                                                                                          | 证书ID列表不可为空                     | 请输入不为空的证书id列表                  |
| 400 | SCM.0505 | Parameter error, parameter is null or its list size is out of range, additional info:{0}                                          | 参数错误，参数为null或其列表大小超出范围         | 请输入长度大于0小于51的列表参数              |
| 400 | SCM.0506 | There is no corresponding certificate ID under the tenant, and the set of certificate IDs that cannot be found:{0}                | 该租户下不存在对应证书ID                  | 请联系技术支持                        |
| 400 | SCM.0507 | The list parameter cannot have duplicate elements                                                                                 | 该列表参数不可存在重复元素                  | 请输入不重复的参数                      |
| 400 | SCM.0508 | Parameter error, the following certificates do not support querying deployed resources:{0}                                        | 参数错误，以下证书不支持查询已部署资源            | 请输入合法的证书                       |
| 401 | SCM.0092 | Decrypt jwt token failed.                                                                                                         | 解密JWT token失败                  | 请联系技术支持                        |
| 401 | SCM.1000 | The token of the request fails to be authenticated                                                                                | 请求所带的Token没有经过认证或者认证失败         | 请填写正确token                     |
| 401 | SCM.1004 | Failed to apply for OBT.                                                                                                          | 用户未申请服务公测，请先申请公测               | 请申请公测                          |
| 401 | SCM.1009 | Your account is restricted.                                                                                                       | 账户受限                           | 请联系管理员解冻                       |
| 401 | SCM.1010 | Your account is frozen.                                                                                                           | 账户冻结                           | 请联系管理员解冻                       |
| 401 | SCM.4002 | You do not have permission to perform this operation.                                                                             | 您的权限不足。缺少策略                    | 请联系管理员添加策略                     |
| 403 | SCM.0001 | Service is not open.                                                                                                              | 服务未开放                          | 请联系技术支持                        |
| 403 | SCM.0002 | Incorrect tenant ID.                                                                                                              | 租户ID错误                         | 请传递正确与X-Auth-Token匹配的projectId |
| 403 | SCM.0040 | The max number of free certificates for the current user has been reached, and you cannot continue to purchase free certificates. | 当前用户免费证书数量已经达到最大值，不能继续购买免费证书   | 请停止购买免费证书                      |
| 403 | SCM.0322 | Invalid user token, user role don't contain op_service.                                                                           | 用户token非法，未包含op_service角色      | 请联系客服处理                        |
| 403 | SCM.1019 | The user role has no permission to access the interface                                                                           | 用户角色无权限访问该接口                   | 请联系技术支持                        |
| 404 | SCM.0069 | No projects found.                                                                                                                | 项目不存在                          | 请选择存在的项目                       |
| 404 | SCM.0094 | Resource not found.                                                                                                               | 未找到资源                          | 请联系技术支持                        |
| 500 | SCM.0004 | Fail to get ca response.                                                                                                          | 请求ca接口出现错误                     | 请联系技术支持                        |
| 500 | SCM.0007 | Failed to download the certificate.                                                                                               | 证书下载失败                         | 请联系客服处理                        |
| 500 | SCM.0013 | The uploaded certificate chain failed to be resolved. Ensure that the certificate has been issued.                                | 上传证书链解析不正确，请确保填写已签发证书          | 请填写正确的证书链                      |
| 500 | SCM.0017 | product wrong.                                                                                                                    | 产品错误                           | 请联系技术支持                        |
| 500 | SCM.0019 | CSB response error.                                                                                                               | CSB连接失败                        | 请联系技术支持                        |
| 500 | SCM.0037 | Failed to encrypt the certificate.                                                                                                | 证书加密失败                         | 请联系客服处理                        |
| 500 | SCM.0038 | Cert decrypt fail.                                                                                                                | 证书解密失败                         | 请联系技术支持                        |
| 500 | SCM.0062 | DNS query fail.                                                                                                                   | DNS查询失败                        | 请联系技术支持                        |
| 500 | SCM.0071 | SCM does not support this resourceType.                                                                                           | SCM不支持的资源类型                    | 请联系技术支持                        |
| 500 | SCM.0087 | Request cert failed.                                                                                                              | 申请证书失败                         | 请联系技术支持                        |
| 500 | SCM.0091 | Connect jwt server failed.                                                                                                        | 连接到JWT服务器失败                    | 请联系技术支持                        |
| 500 | SCM.0093 | Invalid jwt token.                                                                                                                | 无效的JWT token                   | 请联系技术支持                        |
| 500 | SCM.0097 | Encode next token failed.                                                                                                         | 加密next token失败                 | 请联系技术支持                        |
| 500 | SCM.0098 | Decode next token failed.                                                                                                         | 解密next token失败                 | 请联系技术支持                        |
| 500 | SCM.0099 | Invalid domain id.                                                                                                                | 无效的domain id                   | 请输入合法的domain id                |
| 500 | SCM.0100 | UnKnown error.                                                                                                                    | 未知错误                           | 请联系技术支持                        |
| 500 | SCM.0203 | Failed to push to ELB.                                                                                                            | ELB推送失败                        | 请联系客服处理                        |
| 500 | SCM.0213 | Failed to push to CDN.                                                                                                            | CDN推送失败                        | 请联系客服处理                        |
| 500 | SCM.0223 | Failed to push to WAF.                                                                                                            | WAF推送失败                        | 请联系客服处理                        |
| 500 | SCM.0324 | Calculate digest failure.                                                                                                         | 计算签名失败                         | 请联系技术支持                        |
| 500 | SCM.0402 | Encrypt cert content or private key is null.                                                                                      | 加密证书内容或私钥为空                    | 请联系技术支持                        |
| 500 | SCM.0504 | Service internal error, please contact technical support.                                                                         | 服务内部错误，请联系技术支持                 | 请联系技术支持                        |
| 500 | SCM.4001 | An error occurred when accessing the PDP API.                                                                                     | 获取细粒度授权结果失败                    | 请联系客服处理                        |
   
