# 错误码
调用接口出错后，将不会返回结果数据。调用方可根据每个接口对应的错误码来定位错误原因。 当调用出错时，HTTP 请求返回一个 4xx 或 5xx 的 HTTP 状态码。返回的消息体中是具体的错误代码及错误信息。在调用方找不到错误原因时，可以联系客服，并提供错误码，以便尽快帮您解决问题。
#### 错误响应Body体格式说明
当接口调用出错时，会返回错误码及错误信息说明，错误响应的Body体格式如下所示。
```
{ 
    "errorMessage": "The format of message is error", 
    "errorCode": "CCE.01400001" 
}
```
其中，errorCode表示错误码，errorMessage表示错误描述信息。
#### 错误码说明
当您调用API时，如果遇到"APIGW"开头的错误码，请参见[API网关错误码](https://support.huaweicloud.com/devg-apisign/api-sign-errorcode.html)进行处理。
| 状态码    | 错误码             | 错误信息                                                                   | 描述                           | 处理措施                                                                                        |
|:---|:---|:---|:---|:---|
| 400   | CCE.01400001      | Invalid request.                                                         | 请求体不合法。                        | 请参考返回的message和CCE接口文档修改请求体，或联系技术支持。                                                             |
| 400       | CCE.01400002       | Subnet not found in the VPC.                                             | 未在VPC中找到子网。                    | 请确认请求体中的子网是否在对应VPC下。                                                                         |
| 400    | CCE.01400003     | IPv6 not supported for the subnet.                                     | 子网不支持ipv6。                      | 请使用支持ipv6的子网。                                                                                 |
| 400      | CCE.01400004    | No available flavors for master nodes.                                  | Master节点无可用规格。                  | 请更换其他可用的集群规格，或联系技术支持。                                                                        |
| 400       | CCE.01400005    | Container network CIDR blocks conflict.                                | 容器网络网段冲突。                    | 请参考返回的message检查容器网段。                                                                        |
| 400    | CCE.01400006    | Content type not supported.                                              | Content type不合法。              | 请参考CCE接口文档使用支持的Content type。                                                                  |
| 400      | CCE.01400007     | Insufficient cluster quota.                                             | 集群配额不足。                       | 请提交工单增加集群配额。                                                                                   |
| 400     | CCE.01400008     | Insufficient server quota                                                | ECS配额不足。                     | 请提交工单增加ECS配额。                                                                                  |
| 400    | CCE.01400009     | Insufficient CPU quota.                                                 | ECS CPU配额不足。                 | 请提交工单增加ECS CPU配额。                                                                             |
| 400      | CCE.01400010      | Insufficient memory quota.                                              | ECS 内存配额不足。                   | 请提交工单增加ECS内存配额。                                                                               |
| 400      | CCE.01400011    | Insufficient security group quota.                                       | 安全组配额不足。                        | 请提交工单增加安全组配额。                                                                                |
| 400    | CCE.01400012     | Insufficient EIP quota.                                               | EIP配额不足。                      | 请提交工单增加EIP配额。                                                                                  |
| 400     | CCE.01400013    | Insufficient volume quota.                                               | 磁盘配额不足。                        | 请参考返回的message，提交工单增加相应的磁盘配额。                                                                 |
| 400    | CCE.01400014      | Excessive nodes in the cluster.                                        | 节点数超出集群规模限制。                 | 请提交工单申请变更集群规格。                                                                               |
| 400      | CCE.01400015    | Version not supported.                                                  | 不受支持的集群版本。                   | 请参考返回的message，创建支持的集群版本。                                                                    |
| 400       | CCE.01400016    | Current cluster type does not support this node flavor.                  | 当前集群类型不支持此节点规格。               | 请参考返回的message，使用正确的节点规格。                                                                      |
| 400    | CCE.01400017       | No available container CIDR block found.                                 | 没有找到可用的容器网段。                   | 请参考返回的message，使用正确的容器网段。                                                                        |
| 400     | CCE.01400018     | This type of OS cannot be created in this CCE version.                   | 当前CCE版本不支持创建该类型的操作系统。        | 请参考返回的message，使用支持的操作系统。                                                                     |
| 400    | CCE.01400019   | Insufficient resource tenant quota.                                    | 资源租户配额不足。                    | 请参考返回的message，或联系技术支持。                                                                        |
| 400    | CCE.01400020     | Insufficient VPC quota.                                                 | VPC配额不足。                      | 请参考返回的message，或联系技术支持。                                                                         |
| 400    | CCE.01400021      | No available flavors for nodes.                                          | 节点无可用规格。                       | 请更换其他可用的节点规格，或联系技术支持。                                                                        |
| 400    | CCE.01400022     | No available node volumes for nodes.                                   | 节点无可用EVS卷规格。                   | 请更换其他可用的EVS卷规格，或联系技术支持。                                                                       |
| 400    | CCE.01400023   | operation conflict                                                   | 集群扩容中不可创建节点。                | 稍后再试。                                                                                       |
| 400   | CCE.01400024 | operation conflict                                                      | 创建节点时不可删除集群。                | 稍后再试。                                                                                       |
| 400    | CCE.01400025  | Unsupported flavor with insufficient sub-ENI quota                      | subeni配额不足, 虚机规格不支持Turbo集群。 | 选择subeni配额不为0的虚拟机规格。                                                                        |
| 400    | CCE.01400033     | Snapshot task already exists.                                            | 集群备份任务已经存在。                   | 等待集群备份任务结束后重试备份操作。                                                                             |
| 400   | CCE.01400034    | Cluster enables deletion protection,forbidden to delete.               | 集群已开启删除保护，无法删除集群。          | 关闭集群删除保护后再删除集群。                                                                            |
| 400  | CCE.01400037    | Request is invalid.                                                   | 委托创建失败，请求体不合法。              | 请参考返回的message处理，详情请参见[委托创建失败](https://support.huaweicloud.com/cce_faq/cce_faq_00512.html)。   |
| 400   | CCE.01400074   | The key upgrade task is failed and cannot be canceled.                  | 集群升级中关键步骤失败，无法取消升级任务。         | 单击重试升级或联系技术支持。                                                                               |
| 400  | CCE.01400075   | Task is expired.                                                       | 升级前检查已过期。                      | 请重新进行升级前检查。                                                                                |
| 400      | CCE.02400001    | Invalid request.                                                        | 请求体不合法。                        | 请参考返回的message和CCE接口文档修改请求体，或联系技术支持。                                                            |
| 400      | CCE.03400001    | Invalid request.                                                        | 请求体不合法。                      | 请参考返回的message和CCE接口文档修改请求体，或联系技术支持。                                                            |
| 400      | CCE.03400002    | Missing access key.                                                      | 缺少Access key。                | 请确认安装或升级的存储插件版本正确，或联系技术支持。                                                                    |
| 400   | CCE.03400003   | Request is invalid.                                                   | 委托创建失败，请求体不合法。              | 请参考返回的message处理，详情请参见[委托创建失败](https://support.huaweicloud.com/cce_faq/cce_faq_00512.html)。   |
| 401   | CCE.01401001    | Authorization failed.                                                    | 认证失败。                        | 请参考返回的message，或联系技术支持。                                                                        |
| 401    | CCE.01401003  | Authorization failed.                                                 | 认证失败。                       | 请参考返回的message处理，详情请参见[委托创建失败](https://support.huaweicloud.com/cce_faq/cce_faq_00512.html)。  |
| 401    | CCE.02401001    | Authorization failed.                                                     | 认证失败。                         | 请参考返回的message，或联系技术支持。                                                                        |
| 401      | CCE.03401001    | Authorization failed.                                                   | 认证失败。                         | 请参考返回的message，或联系技术支持。                                                                          |
| 401 | CCE.03401004    | Authorization failed.                                                 | 认证失败。                       | 请参考返回的message处理，详情请参见[委托创建失败](https://support.huaweicloud.com/cce_faq/cce_faq_00512.html)。 |
| 403     | CCE.01403001      | Forbidden.                                                               | 禁止访问。                        | 请参考返回的message，或联系技术支持。                                                                         |
| 403  | CCE.01403002  | Account is restricted.                                                | 账号受限。                       | 请参考返回的message，或联系技术支持。                                                                        |
| 403   | CCE.01403003   | Current node pool status does not allow node pool to be deleted.        | 当前节点池状态不允许删除节点池。               | 等待节点池状态稳定后重试删除操作。                                                                            |
| 403  | CCE.01403004    | Node pool cannot be deleted when it is locked by an order.           | 节点池被订单锁定时不允许删除节点池。         | 请支付或者取消包周期订单后重试删除操作。                                                                       |
| 403    | CCE.01403005  | Node pool cannot be deleted when it is scaling.                        | 节点池扩容中不允许删除节点池。              | 等待节点池扩容结束后重试删除操作。                                                                           |
| 403   | CCE.01403006    | Node pool cannot be deleted when exists installing or deleting nodes. | 节点池中存在安装中或者删除中的节点时不允许删除节点池。 | 等待节点池下节点安装完毕或者删除后重试删除操作。                                                                      |
| 403 | CCE.01403007  | You do not have the permission to query the volume quota.              | 用户不具备查询卷配额的权限。                | 请参考返回的message，或联系技术支持。                                                                       |
| 403   | CCE.01403008  | You do not have the permission to create/grant agency.               | 委托创建失败，用户不具备委托创建/授权权限。       | 请参考返回的message处理，详情请参见[委托创建失败](https://support.huaweicloud.com/cce_faq/cce_faq_00512.html)。 |
| 403  | CCE.01403009  | Current cluster status does not allow node pool to be deleted.        | 当前集群状态不允许删除节点池。              | 等待集群状态稳定后重试删除操作。                                                                          |
| 403     | CCE.02403001    | Forbidden.                                                             | 禁止访问。                          | 请参考返回的message，或联系技术支持。                                                                        |
| 403     | CCE.03403001      | Forbidden.                                                             | 禁止访问。                        | 请参考返回的message，或联系技术支持。                                                                        |
| 403    | CCE.03403004   | You do not have the permission to create/grant agency.                 | 委托创建失败，用户不具备委托创建/授权权限。     | 请参考返回的message处理，详情请参见[委托创建失败](https://support.huaweicloud.com/cce_faq/cce_faq_00512.html)。   |
| 404     | CCE.01404001     | Resource not found.                                                      | 未找到资源。                       | 请确认要访问的资源是否已被删除。                                                                               |
| 404     | CCE.02404001   | Resource not found.                                                     | 未找到资源。                       | 请确认要访问的资源是否已被删除。                                                                               |
| 404      | CCE.03404001     | Resource not found.                                                    | 未找到资源。                        | 请确认要访问的资源是否已被删除。                                                                              |
| 409       | CCE.01409001    | The resource already exists.                                            | 资源已存在。                        | 请先删除资源后，再进行创建。                                                                               |
| 409    | CCE.01409002     | Resource updated with out-of-date version.                               | 要更新的资源版本已过期。                   | 请确认要更新的资源为版本为最新，或联系技术支持。                                                                     |
| 409     | CCE.02409001    | The resource already exists.                                           | 资源已存在。                        | 请先删除资源后，再进行创建。                                                                                 |
| 409    | CCE.03409001       | Addon instance has installed.                                            | 插件实例已安装。                      | 请先删除插件实例，再进行安装。                                                                              |
| 429     | CCE.01429002  | Resource locked by other requests.                                       | 资源被其他请求锁定。                   | 请参考返回的message，或联系技术支持。                                                                      |
| 429  | CCE.01429003   | The concurrency limit of tasks has been reached.                       | 已达并发任务上限。                    | 请减少发送请求的频率，或联系技术支持。                                                                        |
| 429    | CCE.02429001     | The throttling threshold has been reached.                             | 已达到最大请求数量限制。                   | 请减少发送请求的频率，或联系技术支持。                                                                          |
| 500    | CCE.01500001    | Internal error.                                                          | 内部错误。                       | 请参考返回的message，或联系技术支持。                                                                       |
| 500   | CCE.02500001   | Internal error.                                                        | 内部错误。                       | 请参考返回的message，或联系技术支持。                                                                       |
| 500    | CCE.03500001    | Internal error.                                                          | 内部错误。                         | 请参考返回的message，或联系技术支持。                                                                      |
   
