文档首页 > > API参考> 应用侧JAVA SDK API参考> 设备升级> 删除指定版本包

删除指定版本包

分享
更新时间: 2019/11/12 GMT+08:00

典型场景

对于不需要继续使用和保留的设备版本包,第三方应用可调用此接口在物联网平台上删除指定的版本包。

接口功能

支持第三方应用在物联网平台根据版本包ID删除指定的版本包文件,在调用该接口前需要通过“查询版本包列表”接口查询获得要删除

接口描述

void deleteUpgradePackage(String fileId, String accessToken) throws NorthApiException

参数说明

参数

必选/可选

类型

位置

描述

fileId

必选

String

path

版本包ID,在上传版本包后获得。

accessToken

必选

String

header

如果调用了定时刷新token接口,此参数值可以填写null,否则要填写鉴权接口获取的accessToken。

响应参数

void

错误码

Http状态码

错误码

错误描述

说明

400

120015

Bad request error.

请求错误。

处理建议:请检查接口请求中fileId的格式是否正确。

403

1010009

app throttle exceed.

应用调用接口过于频繁,超过流控值(默认值是100次/60s)。

处理建议:联系物联网平台维护人员调大流控阈值或者控制接口的调用频率。

403

1010005

Invalid access token or appId.

错误的token信息。

处理建议:请检查接口请求中所携带的accessToken是否有误。

404

123002

Device or package file not found.

设备或包不存在

处理建议:请检查接口请求中的fileId是否正确。

分享:

    相关文档

    相关产品

文档是否有解决您的问题?

提交成功!

非常感谢您的反馈,我们会继续努力做到更好!

反馈提交失败,请稍后再试!

*必选

请至少选择或填写一项反馈信息

字符长度不能超过200

提交反馈 取消

如您有其它疑问,您也可以通过华为云社区问答频道来与我们联系探讨

跳转到云社区